[New Binding] Ambient Weather WS-1400IP weather station

Yes it will if you purchase as a spare part the ip observer unit which goes for $50 as a spare part. Be aware that they make them in three frequencies so get the same brand so it works. I run a screen like yours with the same outdoor unit and use an up observer at the same time. Works great and have had no issues since I moved to the ip observer as my screen would stop uploading to the cloud all the time.

Just changed from the version 2.2.2 to the SNAPSHOT 2.5 and everything works perfectly! Thank you for the work.

I am using it with an AmibentWeather WS-1550-IP.

One question though, is it possible to change the format of the “Time of last update”? I would like to display h:m D/M/Y (not M/D/Y)

What is the reason of this module? I can reach the inside screen through the local network with a desktop app so I think it has some web server capability. but I am not an network expert

New Firmware of the observer ip Gateway Support 8 indoor Sensors… Anybody tried that?

Actually I think my inside unit works same as the ip observer, because collects display thedata and sends to wundergroud servers

The screens usually do not work for this address which the binding uses to scrape the data locally before it leaves your network.

The advantage is this will work if your internet connection goes down which is highly likely during a storm, if you want reliable weather data in a storm then I would purchase the extra box and do this method. As mentioned the screen will still fully work at the same time as the IP box, they can work in parallel.

Sold separately here but be aware different countries have different RF freq so stick to the same brand unless you check on this.

Hello @matt1
Yesterday I’ve installed your binding for my WS-1400IP and some informations doesn’t work by me. Do you know why ?

best regards

Sorry to be picky but this is NOT MY BINDING. 99% at least is the hard work of
Thomas Hentschel, I have just made some tiny changes.

NAN means Not a Number, have a look at the livedata page directly and see if the field has text or perhaps is null… Wait and if the value changes the binding should update it.

Also it confuses me why yours has degrees C next to the outdoor temp value, the mods I made should have removed all unit labelling, perhaps you need to do a clean of your tmp and cache folders if you have tried multiple jar files?

No problem matt1
I will search the problem. The binding I have downloaded is from this page: http://www.pcmus.com/openhab/WeatherStationBinding/


My mistake about the degrees C, I forgot I had played with the ability for the binding to follow the regional settings of Openhab, this is only done for the temperature and nothing else. I had not done it for the other settings as some of them have 4 different units they can be set to like wind. KM/hr, m/sec, Knotts, miles/hr, fps…
It would be possible to automate this by scraping the settings page just like what is done for the livedata and then setting up the %units% but that is a LOT of work which I am not keen on doing until I hear back from @captndelta so I can upload the changes to his github page in a way that wont effect the other bindings all in the same project.

It is not worth the time to change it as it is a scrape of what the station provides at the livedata page and I don’t see a way of changing it in the IP Observer settings… You could use a rule that whenever the channel changes, set another String to the current time using Openhabs methods to display it in whatever format you wish.

@matt1 sorry I forgot it was a scraping of the live page! Yes, seems the easiest would be to create an other item with the current time. Thanks

Trying to install this binding, but when I add the .jar to Addons, OpenHAB barfs on it with this error:

org.osgi.framework.BundleException: A bundle is already installed with the name "org.openhab.binding.ambientweather1400ip" and version ""
	at org.eclipse.osgi.container.ModuleContainer.install(ModuleContainer.java:267) ~[?:?]
	at org.eclipse.osgi.storage.Storage.install(Storage.java:544) ~[?:?]
	at org.eclipse.osgi.internal.framework.BundleContextImpl.installBundle(BundleContextImpl.java:146) ~[?:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.installOrUpdateBundle(DirectoryWatcher.java:1037) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.install(DirectoryWatcher.java:963) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.install(DirectoryWatcher.java:884) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess(DirectoryWatcher.java:489) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.run(DirectoryWatcher.java:316) [10:org.apache.felix.fileinstall:3.6.4]
2019-03-26 12:31:09.681 [WARN ] [ig.xml.osgi.XmlDocumentBundleTracker] - The XML document '/ESH-INF/thing/thing-types.xml' in module 'org.openhab.binding.ambientweather1400ip' could not be parsed:  : ParseError at [row,col]:[183,33]
Message: /var/lib/openhab2/cache/org.eclipse.osgi/261/0/bundleFile :  : ParseError at [row,col]:[183,33]

I don’t already have it installed, it’s not in the bundle:list, and I’ve cleared cache, so I think the error message is a red herring. But thing-types.xml [183,33] is just a label close for Outdoor Battery, so I don’t see any problem there.

Any suggestions?

Have you tried turning it off and back on again? old trick works as it appears to be look at a cache file and you said you deleted them.

:smile: Yep, I’ve rebooted since clearing cache, didn’t help.

Does the binding work? What version openhab, java version and is it Zulu and what platform are you running it on? If the binding works then just ignore it till next time you upgrade.

No, unfortunately the binding doesn’t work (doesn’t show up in Bindings list). I’m running OpenHABian 2.4.0-1 on an RPi; versions are all “latest stable” releases.

At this point, I’m thinking of three main possibilies:
A) there’s another cached version of the plugin somewhere I can’t find;
B) my HAB install has something broken that is preventing it from loading any external addons;
C) there’s a version incompatibility between this particular plugin and the version of HAB I’m running.

To eliminate B I’m going to try installing some other external plugin just to see if it works.
For C, I guess I’ll have to try upgrading.
For A… No idea. I’ve done system searches and can’t find anything named “ambient” left over.

Do a bundle:list in Karaf console.

Also worth putting karaf into debug logging to see if it gives clues.

Thanks Matt1. I did check bundle:list, but haven’t tried debug karaf; will give that a shot.

Fixed! All I did was change log level to debug and restart OpenHAB; it then accepted the ambientweather addon! I’ve changed logging back to INFO and everything appears to be working fine.

Thanks for the help!