New binding for Groupe PSA (Peugeot, Citroen, DS, Opel, Vauxhall) cars

The initial version of this binding is finished: the binding allows to obtain a lot of information from connected cars of brands Opel, Peugeot, Citroen, DS and Vauxhall.

I need help testing (as I don’t own a car that supports the API yet).
The binding (for OpenHab 3) can be downloaded from: https://github.com/arjanmels/openhab2-addons/releases/tag/v1.0

If somebody could test and send me logs with log level trace (use log:set TRACE org.openhab.binding.groupepsa), that will help a lot!

3 Likes

Hi @arjanmels,

I own a Peugeot e208 and am very interested in your binding. Is it only available for Openhab 3? I operate a very complex environment with photovoltaics via modbus, zwave, irrigation and others. Thats why I am a little bit worried with upgrading to openHAB 3.

Do you know whether the upgrade from openHAB 2 to 3 with the openhabian-config tool works reliably? Is it possible to fall back to openHAB 2, like a snapshot for virtual machine?

I will try it as docker container, without an upgrade.

Currently only available for openhab 3. I run it on a virtual server next to my production openhab 2. I will take a look at making a version for OH2.5 (as I am also not yet looking forward to migrating my production system)

Arjan

I installed the binding and tried to add a bridge. What username and password do I have to use for the bridge? The credentials from https://developer.groupe-psa.com?

I registered myself at https://developer.groupe-psa.com. I added an app. I got a client id and secret. I also entered the client id an secret in the binding under advanced configuration. I subscribed to “Connected Car API” plan. But I get the following error:

HANDLER_INITIALIZING_ERROR
No enum constant org.openhab.binding.groupepsa.internal.GroupePSABindingConstants.VendorConstants.PEUGOT

I also added a Groupe PSA Car and entered my VIN. Since the bridge doesn’t work, the car doesn’t work either. But the preview of the available channels for the car are looking awesome.

Can you give me some advice or guidance, please. How can I get it working?

Torsten

Hi Torsten,

You need the username and password of the mypeugot app or site. (And you need to add your car in this system).

Leave the clientid and secret at the default.

I need to look at the no enum constant error, that might be a bug. (Hopefully I’ll find some time later today.)

Arjan

Hi Torsten,

I indeed found a small problem causing the HANDLER_INITIALIZING_ERROR. I have updated the version at: https://github.com/arjanmels/openhab2-addons/releases/tag/v1.0 . So please download again. (I didn’t create a new tag as it was a single letter change…)

Arjan

Hi Arjan,

the bridge is online now, but the car says COMMUNICTAION_ERROR:Unable to query the vehicle status.

I selected the correct brand/vendor and entered my VIN.

Torsten

Can you send me the log with TRACE level enabled? (best via direct message)

Hi is this working? The issue with the Peugeot apk is that it seems that only one phone can be registered to a car. I would like to be able to access the car and turn on the heating/charging through Openhab.

Hi, yes: thanks to the testing efforts of @torsten and @MarkusThurner, the binding is starting to get in a usable state. However it can only read information from the car, not control any functions.

Latest version v1.3.0 for OH3

Arjan

great, I’m waiting on a 2nd raspberry pi so I can try out openhab 3. Do you think 2 way communication is feasible? That would be very useful.

Hi @Julian_Divett,

you can use the myPeugeot app on different phones. You have to use the same Peugeot user account on all devices. Not nice, but it works.

@arjanmels: Thanks for the great work. I like the binding very much.

Torsten

@Julian_Divett 2-way is not possible via the published API. (Maybe via reverse engineering of the app, but that is beyond my current scope. One of the links to github you provided contains interesting info, but requires to obtain the credentials form the app, which is a bit cumbersome.)

Arjan

@arjanmels yes I tested the python app but it didn’t work for me.

@torsten thanks I didn’t try that using the same login on both phones.

I’ll be happy to test this as well with my e208 once there is an openHAB 2.5 binding available.

Hello, I’ve tested this now with openHAB 3. While the binding works really well, and setting it up was no problem at all, I’ve just removed it again because the data reported is so unreliable. It’s not a fault of the binding - it’s the same in the MyPeugeot app as well.

Thanks for testing. Good to hear the binding works. Pitty it is not reliable. Still waiting for my new car to be able to test it myself.

can somone explain how to connect this? I have added the binding to Openhab 3 connected the bridge using the login and password from the my Peugeot app. In the log files it shows it is connecting to 2 cars (I only have one!) but in the UI there are no channels. What do I do next?

thanks

I’m trying this binding. I can add correctly the Bridge and I can find my car with a scan. But when I add the car I have the following error:

2021-02-15 16:56:04.235 [hingStatusInfoChangedEvent] - Thing ‘groupepsa:vehicle:xxx’ changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Unable to query the vehicle status

2021-02-15 16:56:04.235 [WARN ] [psa.internal.things.GroupePSAHandler] - Unable to query groupepsa status for: xxx. Error: Rest call failed: statusCode=404, message=Not Found: We didn’t find the status for this vehicule.

Any suggestion?

You need to add the car’s that are autodetected as things. The bridge itself does not have channels.

So you add the bridge, then add a thing again. Choose the groupe psa binding and click the blue “scan” button at the top. That should detect your car.

If it doesn’t work, can you provide me the logs via private messages?

1 Like