New binding - Rego 6xx based heat pumps

You need to have build 1002 or later version…

Thanks, will move to snapshot.

How did it go?

up and running again, phew! Have taken another backup and tested it this time!

Hi @crnjan I notice that with the new binding there are a lot less attributes I can select. eg, previously I had the threshold values such as I had the threshold values such as;

Heating return target
Min heating return
Min heating return

Can I still get access to these? Or have they been removed now the binding is more ‘formal’ ?

Hi @sx3 I also have a Gria HS. I would say OH is actually much more flexible than HS - even though we have spent a lot of $$$$ on the HS ;-(

I find the HS quite difficult to do more than the basic stuff, and the tools really haven’t moved on a lot. With all the IoT and home automation stuff going on it really is getting left behind. That’s why I investigated OH - and I’ve not looked back. Once you get your KNX to talk ‘internet’ there won’t be any turning back :wink: I even have my Amazon Alexa switching my KNX lights on and off…

Take a look at the KNX binding and the support in this thread [SOLVED] KNX Binding: no confirmation reply received

@crnjan Scrub that - just remembered i click the ‘show more’ button on the Things page, then i get all the attributes :wink:

:ok_hand: Glad you managed to solve it!

So @crnjan now things are stable I’ve ventured into using an ESP-07 instead of my RPi. Got the ESP-07 linked to my wifi ok with a static IP. Used a serial terminal app and a few AT commands. Tried to point to it from Openhab but can’t see it yet. It just says ‘unknown’ in the things config… I’m assuming now I have lo load some more code onto the ESP-07? I.e., it won’t just act as a wifi bridge yet?


You have to flash it, I’m using my own version. I finally integrated the whole thing into the heat pump and is running without any problems.

If you are going to use my code from above link, please note that depending on which UART you are using, you might need to comment out the line:


if you want to use UART0. And also, please note that with ESP module, you now need to use the tcpip rego thing and not the serial anymore ;).

Let me know if you have any questions or comments.

Thx, thought it was something like that, will grab your version and give it try…will let you know how it goes

Flashing all done, but still getting ‘unknown’ in the ‘things’ - I have used the TCPIP rego thing… anything i can test to see if the flash has gone ok? I can see the device on my wifi ok.

Made a bit more progress @crnjan I setup a new item in the ‘Rego IP Thing’ I’m now getting ‘Offline’ instead of ‘Unknown’ - so that means at least Openhab is seeing my ESP-07 !

When i look at the status of the IP Thing I have…


And in the logs…

2017-09-14 17:00:24.356 [DEBUG] [tpump.handler.Rego6xxHeatPumpHandler] - Reading Rego device version...
2017-09-14 17:00:24.359 [DEBUG] [p.internal.protocol.IpRegoConnection] - Connecting to '', port = 9265.
2017-09-14 17:00:24.442 [DEBUG] [p.internal.protocol.IpRegoConnection] - Connected to '', port = 9265.
2017-09-14 17:00:24.525 [DEBUG] [tpump.handler.Rego6xxHeatPumpHandler] - Sending 817F00000000000000
2017-09-14 17:00:24.896 [DEBUG] [tpump.handler.Rego6xxHeatPumpHandler] - Response not received, read 0 bytes => [0, 0, 0, 0, 0]

At least it’s connecting :wink: I think they call that progress :wink:

Durrr…I wish i would read your posts properly! I had forgotten to comment out the Serial.swap()

Now it’s working!!!

I also didn’t realised i had to setup at least one Item in the IP Rego Thing, or it just remained ‘offline’

I think i hit that problem before when i was using serial, should have remembered!

Now just need to make sure all my items are being updated from the IP version not the serial and we are all set - I can bring my RPI back to it’s warm home and not in my outside boiler room :wink:

Now here’s an interesting one…as I try to move from Serial Rego to IP Rego I’m getting some strange errors logged…eg,

2017-09-14 17:39:14.497 [WARN ] [ome.core.thing.internal.ThingManager] - Cannot delegate update '24.6' for item 'HeatPump_SensorValues_HeatFluidIn' to handler for channel 'regoheatpump:serialRego6xx:63ad6d20:sensorValues#heatFluidIn', because no thing with the UID 'regoheatpump:serialRego6xx:63ad6d20' could be found.

The serial thing is no longer there (I’ve delete it!) Should this not now be referencing a tcpip thing? Think I may have muddled things up a bit by trying to swap over :wink:


First of all - really glad you made it working! :star_struck: - congrats!

Yes, the one in my opinion should be referencing the tcpip thing, but I’m almost certain this is more of an setup/OH2 thing that a binding issue.

Also, the status remains unknown until at least one channel is added. To be honest, not sure if I should thread this as a bug or as a feature - since if there is no channel, there is no need to connect to the HP - hence binding has no clue about the status :slight_smile:

Last but not least - did you try to reset the ESP module to see if it will setup itself again? I.e. removing the power from ESP and plug it in again, as simulating power shortage? The reason I’m asking is the sole reason I went from ESP-01 to ESP-07 - (and also explained somewhere in my first posts above) - if you pull down rx or tx (don’t remember exactly) of UART0, it won’t boot properly.

I solved it by deleting all links and items in the karaf console then recreating again - all seems fine now. All those ‘delegate’ errors have gone away :wink: Yeah!

I’m using an ESP-07 like you now. Have rebooted a few times, and all seems fine.

I’ve finally managed to move my RPI back indoors - i’m sure its happy about that now winter is on it’s way :wink:

Thanks for all your help on this, it’s really going to help me monitor how my heat pump is doing over the winter months!

Been running for a week now, no problems. All seems pretty stable. Next step to make my ‘production’ board…but no rush :wink:

Hello and thank you for a great binding. I have connected my Bosch/Junkers heatpump with Rego637J using Husdata interface connected to a RPI and ser2net to Openhab installation on a VM. Its been working great for few weeks now.
i do have couple of issues.
Sometimes the RPI hangs or something and is not sending the data to Openhab and it shows the last values it got. Should it be like that or should it show NA or something?
Im constantly checking if the communication is online or not to see if i get real values.
Another thing, is it possible to use one value (ie outside temp) on Openhab sitemaps? Im thinking it would be nice to show for example the HP outside temperature sensor on the main page of Openhab.

I have been using this binding with RPi3 + OpenHABian over two months without any problems. Memory stick started cortupting so i switched my installation to a more powerful computer running Debian jessie. Installed openhab through apt-get repos. Everything else works like a charm but i can’t find this binding. It’s not listed in PaperUI so I can’t install it. Any clues? Something to do with this being new binding in the official openhab2 distro and it’s somehow no included in apt repos? Maybe some help from @maintainers?

Running Openhab 2.1.0 and already did fresh install but no help.

Thanks in advance!