New Binding: Vallox MV ventilation unit series

For me is the date of the next exchange interesting. I think, the calculation is only “last exchange date + defined exchange interval”. In my case every 3 month. After changing the filter I enter the date of the exchange via the webinterface of my Vallox and it shows me the date of the next exchange.

Being able to display the date of the next exchange is interesting for me because since I use your binding, I’ve never used the “official” control display again so I forgot to change my filters :wink:

Filter1 Filter2

PR is on its way.
You will get the date of last filter exchange and days remaining until next.

As my build is maven build is currently not working I’m sorry not to be able to provide any jar upfront.

Wohoo, simply great!

I received a BUILD FAILURE at the end of the “mvn clean install” but I think, it was only because of my quick and dirty maven installation. However it created a .jar-file so I could test your changes and it is working brilliant. Thank you so much for your work!

As far as I can see, it is actually not possible to link the new channels via PaperUI (in my environment). It doesn’t bother me, because I only use item-files.

Greate to hear that it’s working.

In paper UI those channels should be listed if you display although advanced channels.

Sorry, little blackout! You’re right. All channels will be shown after clicking on “show more”…

Hi Björn,

it seems, that the binding is not working anymore with OH 2.5.0 M3. The binding is installed but not listed in paperUI under installed bindings. The thing is still online but there are no items available. can you please check this and if you can reproduce this error maybe there is a way to fix it.

It can’t be the binding’s fault if your items are missing. You must have deleted them.
I’m using 2.5M3, too with no problems.

Hmm, both files (.items & .things) are equal to the files on my 2.4 system. I checked it with the todays snapshot version and there is the same problem. my things-file looks like this:

Thing valloxmv:valloxmv:07bcc33d "Vallox Lueftung" [ip="", updateinterval=60]

Is there something wrong? Can you please post your thing-file? Is something else necessary in 2.5 that wasn’t relevant in 2.4?

Here a part of my items-file:

Switch ValloxVentilationUnit_AnAus “Status” {channel=“valloxmv:valloxmv:07bcc33d:onoff”}
Number ValloxVentilationUnit_Profil “Profil [%d]” {channel=“valloxmv:valloxmv:07bcc33d:state”}
Number FanSpeed “Fanspeed [%d %%]” {channel=“valloxmv:valloxmv:07bcc33d:fanspeed”}

I am having exactly the same problem as Arne with 2.5.0 (stable release version) after upgrading from 2.4.0 today. Did you find any solution to your problem in 2.5? My Vallox is a 350MV.

The binding hasn’t been touched for quite a while (beside the move to the new build system).
Have to check myself when doing the upgrade over Christmas days.

Thanks for looking into this issue. I compiled some information regarding the addon that I could find. First of all I don’t receive any error message in openhab.log. If I set events to INFO the following messages are found in events.log:

2019-12-17 12:37:23.808 [hingStatusInfoChangedEvent] - 'valloxmv:valloxmv:lueftung' changed from UNINITIALIZED to INITIALIZING
2019-12-17 12:37:23.839 [hingStatusInfoChangedEvent] - 'valloxmv:valloxmv:lueftung' changed from INITIALIZING to UNKNOWN
2019-12-17 12:37:24.876 [hingStatusInfoChangedEvent] - 'valloxmv:valloxmv:lueftung' changed from UNKNOWN to ONLINE

In PaperUI it looks a bit odd because in “Configuration -> Binding” the binding is not listed at all. Under things it is listed without a description:

The bundle is loaded in Karaf:

248 │ Active │  80 │ 2.5.0                   │ openHAB Add-ons :: Bundles :: ValloxMV Binding

Uninstalling and reinstalling doesn’t change the behavior.

If any other info might help please let me know. The addon worked like a charm in 2.4.0. I didn’t change the configuration after updating to 2.5.0.

Hi Björn,

I have the same problem as Rene with update from 2.4.0 to 2.5.0 my Vallox.
The logs are the same as Rene.
I use Debian 9 with zulu-8.
Thanks if you can help.

log:set debug org.openhab.binding.valloxmv

@mstormi Thank you, that helped to get more details.

Here are the results:

2019-12-19 08:00:51.931 [DEBUG] [ng.valloxmv.internal.ValloxMVHandler] - Schedule vallox update every 60 sec                                                            
2019-12-19 08:00:51.933 [DEBUG] [ng.valloxmv.internal.ValloxMVHandler] - Connecting to ip:                                                               
2019-12-19 08:00:51.959 [DEBUG] [.valloxmv.internal.ValloxMVWebSocket] - Connecting to: ws://                                                          
2019-12-19 08:00:52.663 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Connect: /                                                                       
2019-12-19 08:00:52.703 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Got binary message                                                                             
2019-12-19 08:00:52.711 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Response length: 1410                                                                          
2019-12-19 08:00:52.713 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Fan Speed: 50                                                                                  
2019-12-19 08:00:52.807 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Data updated successfully                                                                      
2019-12-19 08:00:53.671 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - WebSocket Closed. Code: 1005; Reason: null                                                     
2019-12-19 08:01:54.159 [DEBUG] [.valloxmv.internal.ValloxMVWebSocket] - Connecting to: ws://                                                          
2019-12-19 08:01:54.237 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Connect: /                                                                       
2019-12-19 08:01:54.248 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Got binary message                                                                             
2019-12-19 08:01:54.253 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Response length: 1410                                                                          
2019-12-19 08:01:54.255 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Fan Speed: 50                                                                                  
2019-12-19 08:01:54.271 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - Data updated successfully                                                                      
2019-12-19 08:01:55.228 [DEBUG] [VWebSocket$ValloxMVWebSocketListener] - WebSocket Closed. Code: 1005; Reason: null    

FYI, got a message from Vallox support yesterday saying they’ll release v2.0 beginning of next year, to include major improvements on the MyVallox cloud service. That now we’re probably not interested in but I guess it can bring a number of new issues.
Following up, my contact at Vallox has let me know this:
We have (finally) decided that the websocket protocol will be public, and the protocol documentation will be released at the beginning of 2020. The problem has been that the protocol is autoregenerated at compile time and therefore too unstable to be supported officially. But now we decided that the current single register commands etc. will be frozen so that they will not change in the future. There are many bindings/implementations for it already and we do not want to break them in every firmware update (and I have already tried to keep the protocol as it is). So, we will make a public protocol description which will be stable in the future updates.

1 Like

Hmm, that looks super normal.

I took a clean docker instance of 2.5 and installed the vallox mv binding, but I was not able to install any vallox mv thing as no line item for it is displayed. Strange.

Created a issue to follow up in github

Seems like a typo in folder name did prevent the addon from working correctly. Sorry for that.

Patch is in the pipeline for a 2.5.x release. Download can be found here.

@bjoernbrings Thank you Björn, that jar is working for my setup (350MV). Just copied it to the addons folder and openHAB is immediately reporting the correct values.

Wish you a happy New Year, Rene

1 Like

Vallox just informed me that they’ll release v2.0 of their firmware next week.
They say that if your system is registered with and connected to the myVallox cloud it’ll automatically update.
My developer contact said they’re not gonna change modbus variables from now on but I’m not 100% sure what ‘now’ is.
So the binding may or may not continue to work with units when you update to v2.0.
(and if you don’t want that to happen automatically, log out of myVallox cloud)

Hi there,
first of all, thank you very much for this binding, @mstormi :+1:

Have anybody of you already updated your Vallow to the v2 firmware and can confirm that everything keeps working? I’m a bit anxious to upgrade :slight_smile: