New Inovelli Z-Wave On-Off switches (LZW30), Z-Wave integration with Openhab

Tags: #<Tag:0x00007f433c8f23d0>

Hope it helps!

BTW, do you mean the dimmers (LZW31)?

The switches (LZW30) are already working with the latest zwave binding. The rule above was written for an LZW30.

I have updated the post header.

1 Like

Thanks Sihui for clarifying this - it will help. I think there has been some very useful discussion despite/potentially because of the confusion, though. While the parameter number may change for the dimmer, the notification codes should be applicable for the dimmer (LZW31) as well.

@roy_liao - I mean for the LZW30 , not the LZW30-SN. From your rules/description, I believe you probalby have the LZW30-SN - with the scenes. The zwave binding currently available has the first iteration of the specifications - without the LED notification parameters. I’ve since updated it, to test this in the LZW30, but as Chris is on vacation, I haven’t been able to get the updated snapshot yet. In contrast, the current zwave binding snapshot does have a functional LED notification parameter for LZW30-SN.

1 Like

Ah, got it. Yes, you’re right. I have this working on the LZW30-SN (RED), not the Black series.

Hi Bruce,
This is Adrian and I’ve been playing with OH2 (v2.4 stable) for a little while and I love it! Sadly shortly after success with some other switches, I bought one of this LZW30 switches, and I was wondering what is the best way to get this into my OH2.4 (without leaving the stable) I read about installing the 2.5 Snapshot, or manually installing the specific device into existing binding but cannot make it work…
Do you mind sharing a link on the best way to stay with stable but get this switch supported? (if possible) I’m on Debian x86, and installed OH 2.4 from repository
Thank you very much!
Adrian

@aschmi

See Manual Z-Wave Installation
Also, if doing it completely manually, I occasionally revisit my summary
The first half could likely be ignored, but if you run on a raspberry pi, you can follow my second half almost verbatim.

1 Like

Thank you very much! I’ll check it out after work and let you know how it goes (for sure success!)

Hello
What will be a good switch to implement with Openhab?. I am looking for a on/off switch WiFi or Z-wave, no Neutral Required. I will be controlling LED lights. Is the Inovelli LZW31 will be a good choice?
Thanks,
Menachem

No neutral required will be a difficult requirement. Generally, the only switches that I’m aware of that don’t require a neutral wire are dimmers (the switch has to power itself, and dimmers just steal a little bit of power slowly, too little to actually result in the lights coming on. This may be a problem for LED lights, which don’t require much current at all to turn on.

A neutral wire allows the switch to take the current form the line (generally black), and send it back the neutral (generally white), rather than having to send it forward around the circuit to the light. Without a complete circuit, there is no power for the switch to be listening to zwave/wifi.

==
If you do have a neutral wire, there are lots of options. the inovelli LZW30 is a well-priced option, but it is only in the 2.5 and later zwave binding - meaning that you will need either to manually install this binding, or wait for the stable openhab 2.5 to be released. Zooz also puts out reasonably-priced z-wave switches. If you’re going with z-wave, make sure you are getting the correct one for your region (different world regions use different frequencies).

You mention the LZW31 - this is a dimmer switch, not an on-off switch. The dimmers are still only part-way through shipping pre-orders, while the on-off (LZW30) are shipping to the public. So far the LZW30’s have been solid for me. I suppose if you know you don’t have a neutral wire, you could use the dimmer LZW31, just as either on or off (0 or 100 via openhab, or short presses on the switch). You may run into problems, though, if you press and hold the switch, which would normally start the fading process either up or down.

I probably can use Smart Wifi E27 Light Socket

Thanks Ben,
The problem is that I do not have neutral wire so I am limited with what i can use.
So the LZW31-SN will do on/off?
Can you explain what problem you think I will have.
Thanks
Menachem

Hi Ben,
I’m in openhab installed in debian, and at first the script failed (missing curl) Even after that, was still giving me errors… But I was not going to give up! In the end I temporarily changed openhab user (so I can do su - openhab and get a shell command) and I did install in steps, the serial transport first, then disabled the zwave, finally install the snapshot one (all using your script).I’m a very happy user of LZW30 switch now thanks to you!
Have a great week ahead
Adrian

Thanks, but the real credit goes to 5iver, whose script it is. Several others with far more knowledge than I have helped as well.
I only compiled the various suggestions others have made, into one location.

I’m glad you had some success!

1 Like

@mpenzoh
The dimmer may possibly burn out a bit quicker, or the bulb may flicker if a non 0% or 100% brightness is inadvertently be chosen. You may accidentally move to a non 0/100 value by pressing the switch too long. That should be about it. Your programming in rules can easily set it to 0 or 100, but just setting it to ON (I believe) may set it to the previous brightness - so it may be a good idea to use .SendCommand(100) vs .SendCommand(ON).

One quick question related to my LZW30 success… I added three of these switches wishing they were going to extend my zwave network, but other battery devices don’t seem to use it as a gatewayy (I have a full ticket with network diagram and more - Please help! Set up of a small school with OpenHAB)

Is there a way to “force” this switch to route messages? Or the other battery devices to see the switch? They are very near (less than 10 ft) and still try to connect to the far away HUB…

Any hint will help. Thanks!!!
Adrian

No. Routing is autonomous in a zwave network - you can’t influence it. All devices that support routing should find the most appropriate route to the destination - there’s also nothing you can change in the end devices either.

How do you know that? I’m not aware of anything that shows what routes are being used?

Thank you for the information. What I’m looking for the second point is habmin information on the zwave diagram, that seems to show nearby devices don’t connect to the light switch that is just across the hallway (I tried to put the complete diagram and information on my original post here Please help! Set up of a small school with OpenHAB)
Thank you Chris for taking time to help me out!
Adrian

The HABmin diagram doesn’t show routes - it shows neighbours. Now, I’m sure you’re probably thinking that the neighbours list would be a superset of the routes being used, since a route can’t exist except via a neighbour, but…

The two things (the neighbours list and the routes) are probably separate - I say probably as it depends on the generation of the devices being used. If the devices are reasonably new (let’s say, ZWave+), then routing is normally undertaken by a device searching for routes using what’s called “Explorer Frames”. If the devices in this area of the network are older devices, then this may not be supported, and then the routes are chosen by the controller, and I believe that this configuration will use the neighbour table. The binding just tells the controller “configure a route from node A to node B” - there’s no control over how the route itself is derived.

I’m not sure that helps much, but hopefully it provides some insight at least :wink: .

That is great info! this is my (very horrible) diagram of the school, that is a long hallway. The classrooms that cannot connect (with Gocontrol zwave devices - battery powered) are the ones on the right of the diagram (G8, G6, G9, G7), even if they have the LZW30 (node 12 - electrical switch) very near to them.
When I bring the Gocontrol devices (G8, G6, G9, G7) near the Openhab z-wave master controller, they connect without any trouble…
What I’m trying to understand is how to fix this first… Should I move the server to a central location? (nothing easy maybe I can put the server temporarily in one of the classrooms) - Add more electrical switches? (another brand so they actually repeat the signal)
I tried to enable debug log, but those messages mean nothing to me… Should I upload some?
I feel bad that I’m using your time but I do appreciate your help very very much!

I think maybe we’re getting off topic of this thread, so I’ll respond on your other thread.