New instalation can't seem to start

Dear all,
I have been postponing to start with openhab for a while, and this week I have been trying to install this on a spare NUC i had lying around.
As I only had ubuntu installed, I said I would give it a try.
I followed the instructions to install it on linux, and to most extend did not had any problem. I have never used linux either (expect to run XBMC) so it took me a while to install the java part.

I keep trying to start Openhab, but I can’t seem to be capable of this.
I have even tried to reinstall openhab, but I keep getting the same error.

Can anyone give me a hand. I really want to jump into this :slight_smile:
I tried googling the error, but I can’t figure out what I should do or how linux works :)) so please be patient. I am a hardware guy, not a software guy.
Anyhow. This is what happens when I try to start it. (by the way, the linux installation restarts every day at 3 am, as I had it set ed up as an access point and it kept crashing after a few days.

-- ap@ap-desktop:~$ sudo systemctl daemon-reload
ap@ap-desktop:~$ sudo systemctl start openhab2.service
ap@ap-desktop:~$ sudo systemctl status openhab2.service
● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since So 2017-11-12 17:27:13 CET; 829ms ago
  Process: 9997 ExecStop=/usr/share/openhab2/runtime/bin/stop (code=exited, status=1/FAILURE)
  Process: 9886 ExecStart=/usr/share/openhab2/ server (code=exited, status=1/FAILURE)
 Main PID: 9886 (code=exited, status=1/FAILURE)

Nov 12 17:27:12 ap-desktop systemd[1]: openhab2.service: Unit entered failed state.
Nov 12 17:27:12 ap-desktop systemd[1]: openhab2.service: Failed with result 'exit-code'.
Nov 12 17:27:13 ap-desktop systemd[1]: openhab2.service: Service hold-off time over, scheduling restart.
Nov 12 17:27:13 ap-desktop systemd[1]: Stopped openHAB 2 - empowering the smart home.
Nov 12 17:27:13 ap-desktop systemd[1]: openhab2.service: Start request repeated too quickly.
Nov 12 17:27:13 ap-desktop systemd[1]: Failed to start openHAB 2 - empowering the smart home.
ap@ap-desktop:~$ java -version
openjdk version ""
OpenJDK Runtime Environment (Zulu build
OpenJDK 64-Bit Server VM (Zulu build, mixed mode)

P.S. i am running Ubuntu 16.04 x64 on an Celeron N2820 with 8gb ram.

Hopefully, someone smarter has any ideas of what I’m doing wrong.

best regards,

One, don’t use openjdk. Get a standard oracle jdk.
If switching to oracle isn’t sufficient, try using 1.8 instead of 1.9.

Thanks. I’ll try that this weekend.
Strange that we should not use openjdk as this was suggested in the installation tutorial.
Will report back in a week :slight_smile:

Zulu (an optimized version of OpenJDK) is recommended here:

Are you referring to another tutorial?

I’ve used that tutorial. That’s why it’s strange that someone recommends against it.
Had a reinstall of everything before posting here, as I wanted to make sure the instalation went OK.

I’m going to recommend following the openHABian Manual instructions and let Thom do all the work for you. It was designed to work with the Raspberry Pi but it will work just fine on Ubuntu and it will take care of all the installation and configuration stuff for you so you can focus on learning OH itself.

The real problem you have is OH doesn’t support running on 1.9 yet. The suggestion comes from awhile back there being some pretty significant problems running OH on openJDK. I beleive that may no longer be the case, though, as Dim said, Zulu is the recommended runtime I believe these days.

1 Like