New Insteon 2.5+ binding

Would love to help.

So I get a weird error message. Not sure why, as the org.apache.http is in the .jar.

2020-02-24 22:18:23.929 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.insteon-2.5.3-20200220.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.insteon [278]
Unresolved requirement: Import-Package: org.apache.http

Would like to try the binding. Can you add me?
Are the custom device configuration xml files supported in your binding?

Would be very happy to help with testing! Having real issues getting the legacy binding working on a RasPi, and haven’t been able to get the debugging working properly with the new setup. Would much rather try an (incomplete/beta) binding designed for OH2

I’ll send you a pm with info. The binding is complete, and is fully functional.

@ranielsen Would like to try the new binding. I’m able to get the version 1 binding with 2.5.2-1 but with the rapid progress in Openhab I really should get ready for OH3. Two questions:

Have you or anybody else used your binding with OH3?
Have you or anybody else using an Insteon thermostat?


The answer is no to both, it would be great if you could test the thermostat since nobody else has done it yet. Look for a PM with details.

I think this is currently not possible as the first oh3 snapshot has not been released yet.

Hi Rob,

Great work. I’ m interested in testing the binding as well. Let me know how I can install it.


I just stumbled upon this thread while re-installing OpenHab and the Insteon binding, which I had setup quite some time ago. Would rather start with something newer. Please add me to the testing group so I can download, install and test also, thanks!

The binding will be available in 2.5.4 and is available in the 2.5.4-SNAPSHOT build. You can see the updated documentation at

1 Like

Curious if anyone has having a similar issue as I am. The new binding installs fine, discovers the devices and works for a while. Then the devices stop responding and the status is not updated.

I am getting this from the log:

[steon.internal.device.ModemDBBuilder] - modem database download unsuccessful, restarting!

I tried restarting the bundle, and restarting openhab. Each time the same problem occurs. I thought maybe the modem was going bad, but it seems unlikely that it would work and then not work.

Did you delete the old binding?

Also need to look at your logs I had a case where after deleting the old binding some remnant files were buried in a config directory. I had to manually delete.

Same area as the addons.config var/lib/openhab2/config/org/openhab/insteonplm.config

I would also stop openHAB and clean cache if you have not.

Increase the modemDbRetryTimeoutSeconds as described at The default is 120 seconds, which might not be enough.

Thank you. I did as @Thedannymullen suggested (I did find that file there) and increased the modem timeout to 180. I am not seeing that error now. I will monitor and report back if this did not solve it. Thanks again!


Unfortunately, it worked for a while then failed again. I counted 8 of the “modem database download unsuccessful, restarting!” in a row, then it initialized all of the things, then it started the “modem database download unsuccessful, restarting!” cycle again. Would there be any information I could provide to help diagnose this?

Can you do this:

Log into the console:

ssh -p 8101 openhab@localhost

or whatever username is your OH user, but note you have to to this from localhost. the default pw is ‘habopen’


list | grep Insteon

Post the output.

I assume you’ve shut down and restarted OH? I’m a bit confused why it was working and now it’s not. The database is downloaded when the binding is initializing.

1 Like

@dvzkul, are you still having issues?

Sorry for the delay. Yes, I sure am. I am starting to think it is a hardware issue. I brought up a brand new copy of openhabian. Only installed the Insteon 2.5+ binding, and am still seeing the issue.