New Netatmo binding (starting OH 3.3 M5)

You have an example for home + camera in documentation, but not for energy stuff. You can also find the thing UIDs and the things hierarchy by looking at the things created with UI.

Could you please add the possibility to change the intensity of the floodlight?
Thank you.

Just a hint for everybody: this morning the binding was not working very well even after a OH reboot, I discovered that my things were sometimes OFFLINE and it was apparently due to the camera ping done by the binding which was time out. This leads to things going OFFLINE and warning logs about missing access token. I had the judicious idea to reboot the camera and now everything is well again.

Does the following notify in my mailbox this morning has impact on my openhab??

Netatmo API Security Update
Dear Netatmo developer,
To improve the security of our products, we inform you that the Client Credentials grant type method will be completely removed. It will no longer be possible to authenticate with the username and password of the user.

The effective date of this update is October 2022.

How can you authenticate with Netatmo API ?
From this date, the OAuth2 authorization code flow must be followed for authentication.

This new way to authenticate is already part of the current binding in OH 3.3, thanks to @glhopital

1 Like

Hi,
Maybe I’m overlooking something (already searched this thread & forum) but I do seem to have an issue with the “Setpoint End” channel of a room for a Netatmo Thermostat device.
I DID read this is a read only channel but I’m wondering why because via the Netatmo API you can update this and the examples in the instructions via an action of a rule also mentions you can update it (but doesn’t work either)

I can update all other Channels fine (like Setpoint, Thermostat Mode etc. ) but when I want to update “Setpoint End” (when you change a setpoint and want to revert it back to the previous setting after a defined time) it doesn’t seem to pick it up.

I have entered it in Unix Seconds (eg. 1659699085) like the instructions tell me to do so, I also tried to enter a date like 2022-08-05T16:08:00 but it doesn’t seem to send it correctly to Netatmo either.

I’ve tried this via NodeRed (with the OpenHab node) & via Rules in OpenHab itself.
I’m running OpenHab Release 3.3

Am I missing something here or might there be an issue with this channel or is there a reason why this is mentioned as read-only in the instructions ?

The setpoint end channel is read only because it depends upon either your schedule, either last hand modified setpoint+ setpoint modification duration

thx for the answer,

Via the API on dev.netatmo.com (/setroomthermpoint) I can use the endtime as parameter to fill in and it will accept it and works fine, can’t we have a channel in the OpenHab plugin to do something similar ?