New openHab2 EnOcean binding

openhab2-addons
enocean
binding
Tags: #<Tag:0x00007f014b0fd360> #<Tag:0x00007f014b0fce10> #<Tag:0x00007f014b0fca00>

(Daniel Weber) #322

Hi Christian (@tailor),

as I am using the exact same setup (even the same room :wink:), I can promise that this will work. You do not even need a rule as I implemented a profile to link a rockerswitch channel directly with a player item. In this way my sonos starts when I switch on my bathroom light and stops when I switch off my light (very high waf :grinning:).

If you want you could even link your rockerswitch with your volume item. However you have to be very careful as volume up triggers very fast.


(niri) #323

Hi there,

I am trying to add the Nodon SIN-2-RS-01 actuator to OpenHab.
It does indeed get discovered and added via Openocean and a new Thing is added. Moreover I get live position-updates while moving the blinds up and down via a physical switch.

Unfortunately I can’t seem to get the control via Openhab to work. The blinds do not move while controlling Openhab. The Log looks like this:

2018-11-17 18:25:38.735 [ome.event.ItemCommandEvent] - Item ‘Rollo_Rollershutter2’ received command DOWN

==> /var/log/openhab2/openhab.log <==

2018-11-17 18:25:38.743 [DEBUG] [nal.transceiver.OpenOceanTransceiver] - Enqueue new send request with ESP3 type RADIO_ERP1 without callback

2018-11-17 18:25:38.762 [DEBUG] [nal.transceiver.OpenOceanTransceiver] - RESPONSE with code RET_OK payload 00

When moving the blinds with a physical switch, the log shows:
2018-11-17 18:27:04.902 [DEBUG] [nal.transceiver.OpenOceanTransceiver] - RADIO_ERP1 with RORG RPS for FEF74796 payload F650FEF747963001FFFFFFFF5300

2018-11-17 18:27:04.911 [DEBUG] [an.handler.OpenOceanBaseThingHandler] - ESP Packet payload F650FEF7479630 for FEF74796 received

==> /var/log/openhab2/events.log <==

2018-11-17 18:27:04.953 [vent.ItemStateChangedEvent] - openocean_rollershutter_usb300_FEF74796_receivingState changed from Rssi 85, repeated 0 to Rssi 83, repeated 0

2018-11-17 18:27:04.964 [vent.ItemStateChangedEvent] - Rollo_ReceivingState changed from Rssi 85, repeated 0 to Rssi 83, repeated 0

==> /var/log/openhab2/openhab.log <==

2018-11-17 18:27:05.045 [DEBUG] [nal.transceiver.OpenOceanTransceiver] - RADIO_ERP1 with RORG VLD for 050EEF18 payload D211000004050EEF180001FFFFFFFF3A00

2018-11-17 18:27:05.047 [DEBUG] [an.handler.OpenOceanBaseThingHandler] - ESP Packet payload D211000004050EEF1800 for 050EEF18 received

==> /var/log/openhab2/events.log <==

2018-11-17 18:27:05.064 [vent.ItemStateChangedEvent] - Rollo_Rollershutter2 changed from 10 to 17

2018-11-17 18:27:05.068 [vent.ItemStateChangedEvent] - Rollo_ReceivingState2 changed from Rssi 61, repeated 0 to Rssi 58, repeated 0

==> /var/log/openhab2/openhab.log <==

2018-11-17 18:27:05.077 [DEBUG] [nal.transceiver.OpenOceanTransceiver] - RADIO_ERP1 with RORG RPS for FEF74796 payload F600FEF747962001FFFFFFFF5300

2018-11-17 18:27:05.081 [DEBUG] [an.handler.OpenOceanBaseThingHandler] - ESP Packet payload F600FEF7479620 for FEF74796 received

May someone can help me to find out how to control the blinds via Openhab?

Thanks!!


(niri) #324

solved: after adding the shutTime the Nodon Actor works fine!


(Daniel Weber) #325

Hi @niri,

thanks for the hint. Your NodOn actuator should not need the shutTime as it supports absolute values. However I use the same channel also for the FSB14 rollershutter actuator which need this parameter to calculate the position and run time. I will add a default value to this parameter,so you are not forced to set one any longer.

Best regards
Daniel


(niri) #326

@fruggy83
Thanks!

Do you also have an idea to why I do not get exact status reports from my TF61J-230V?
I can indeed set the rollershutter to e.g. 30% and it moves to the right posititon.
But as soon as I use the up/down/stop buttons openhab will only show position 0 or 100. The same happens when using a physical switch.


(Daniel Weber) #327

Hello all,

I just want to inform you that this binding finally got part of the official openHAB project. You should be able to install/activate the new enocean binding just as any other binding directly in openHAB after updating to the current version of openHAB.
Thank you very much for your help and support.

Best regards
Daniel


(Matt) #328

Hi @fruggy83,

im on OH 2.4.0 M6 and i was wondering if this would be the right one to install:

Enocean market:binding-3984102 - 1.0

regards
Matt


(Daniel Weber) #329

Hi Matt (@Matt77),

please use the ‘binding-enocean - 2.4.0.SNAPSHOT’ one.

Best regards
Daniel


(Andres Meyer) #330

This is absolutely great to hear!


(niri) #331

Any ideas?


(Daniel Weber) #332

Hi @niri,

Eltako rollershutter actors seem to not send correct status messages back. I have similar problems with my FSB14. Could you please enable the debug log level of the binding and post the messages when you move your rollershutter by your physical rocker switches?

Best regards
Daniel


(Daniel Weber) #333

Hi all, I just want to inform you that I merged the official binding version into the openocean repo. So if you use the marketplace version of this binding or directly download the the jar, you will always get the latest and greatest version :wink: . However you have to change your thing and item files accordingly. The most important change is, that the binding id changed from openocean to enocean.

I will use the openocean repo as a playground for further developement.

Best regards
Daniel


(Dennis Dittrich) #334

Hi @fruggy83 after the update i am not able to connect my enocean bridge anymore. The Error:
Status: OFFLINE - CONFIGURATION_PENDING opening serial port…
I cheked following setting:

  1. openhab user is in group tty
  2. openhab user is in group dialout
  3. etc/default/openhab2 with correct entry: EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"
  4. sudo raspi-config Interface 6. Serial Port is enable
  5. File: /boot/cmdline.txt without “console=serial0,115200”
  6. File: boot/config.txt with the line enable_uart=1

before i updated the enocean binding it works fine for me. i dont have any more idea to solve it by my own. Maybe you have a small hint where i can have a further look.
By the way the karaf consol log with debug log level did not shown more infos as the paperui.

best regards,
Dennis


(Daniel Weber) #335

Hi Dennis (@DennisAtHome),

do you use the current version of this binding from my github repo or did you updated to the official version? In both cases you have to update your thing and item files. I had to replace the “openocean” binding id with “enocean”. Therefore you have to replace all occurences of openocean with enocean. Furthermore I am using the serial port API of ESH now. So you no longer have to install the openhab-transport-serial feature but the esh-io-transport-serial and esh-io-transport-serial-rxtx. If you have installed the binding directly in openHAB these feature should have been activated automatically.

Best regards
Daniel


(Dennis Dittrich) #336

Hi Daniel @fruggy83,

I initially made the installation and the update via your repo.
I have now decided to use the official binding. Unfortunately I do not know exactly where I can install this. In Openhab itself, I only see the following choices: (EnOcean Binding binding-enocean1 - 1.12.0) that is not correct, right? The instructions from the old Readme had helped me a lot, but is now outdated. So how can I install the official version?

I’m still new to the Openhab and Enocean users. Please have the understanding that I ask such fundamental questions.
Best regards,
Dennis


(Daniel Weber) #337

Hi Dennis (@DennisAtHome),

I only see the following choices: (EnOcean Binding binding-enocean1 - 1.12.0) that is not correct, right?

Yes your are right. I forgot to say, that you need a snapshot build version of openHAB to be able to directly install the official version of this binding. I am running this snapshot/test builds for months now even on my productive system, so I just forget to mention it :man_facepalming:
So you have two options now:

  1. If you are using openhabian, you can easily switch to a snapshot build. Just use option 40 => 41 in openhabian-config.
  2. Wait until Dezember 17th. The release of openHAB 2.4 is planned for this day.

I’m still new to the Openhab and Enocean users. Please have the understanding that I ask such fundamental questions.

No problem. I guess without your questions other users would have the same problems.

Best regards
Daniel


(Ralf) #338

Hi Daniel @fruggy83,

I just bought some ELTAKO TF-FGB window handle sensors which are currently not directly supported by your binding, cause the EEP is A5-14-09. I have the following information from the documentation:
Teach-In telegram: 0x50480D80
Data_byte0 = 0x08 --> window closed
0x0E --> window open
0x0A --> window tilted
Data_byte3 = battery power 0…250, 0…5V

Is it possible that you implement this quite in time? I was not able to get them working based on your instructions. Sorry.

Additionally I cannot activate your currently precompiled *.jar in my openhab 2.3 installation, which was possible a few weeks ago (I downloaded it November 26th). Are there meanwhile any changes made which corrupt functionality in openhab 2.3?

Thanks in advance,
Ralf


(Daniel Weber) #339

Hi Ralf (@shotte),

it should not be a big problem to implement this EEP A5-14-09. Fortunately Eltako describes the content of their enocean messages very good in detail. I wish this would do other manufacturers too.

As I synced my openocean repo with my work for the official binding, you have to use oh2.4 now. I am using the ESH serial port API now, which got implemented in one of the 2.4 snapshots. So I gues it has something to do with this change. However the release of OH 2.4 is coming (December, 17th).

Best regards
Daniel


(Ralf) #340

Hi Daniel @fruggy83,

thank you for your quick response. I just updates to the current 2.4 snapshot but now I’m missing the OpenOcean TCP gateway, cause I’m using it in combination with ser2net which runs on my raspi. Is there any chance to get it back or are there alternatives to it?

Thank you,
Ralf


(Ralf) #341

Hi Daniel (@fruggy83) again,

now I have another issue: I got the bridge from 2.4 snapshot version working (for a few minutes) using ser2net and socat based on thins article [Forwarding of serial and USB ports over the network to openHAB].
But just after editing the newly added thing (renaming the element), it turned into “offline - configuration pending”. On the server side I can see messages coming up the the related serial port after editing the thing but no more turning into “green/onlne”.

The log announces the following:

2018-12-13 02:52:51.436 [INFO ] [transceiver.EnOceanSerialTransceiver] - Transceiver shutdown
2018-12-13 02:52:51.439 [hingStatusInfoChangedEvent] - 'enocean:bridge:40ef060c' changed from OFFLINE (CONFIGURATION_PENDING): trying to get bridge base id... to OFFLINE (CONFIGURATION_PENDING): opening serial port...
2018-12-13 02:52:51.444 [INFO ] [transceiver.EnOceanSerialTransceiver] - EnOceanSerialTransceiver initialized
2018-12-13 02:52:51.447 [hingStatusInfoChangedEvent] - 'enocean:bridge:40ef060c' changed from OFFLINE (CONFIGURATION_PENDING): opening serial port... to OFFLINE (CONFIGURATION_PENDING): starting rx thread...
2018-12-13 02:52:51.448 [hingStatusInfoChangedEvent] - 'enocean:bridge:40ef060c' changed from OFFLINE (CONFIGURATION_PENDING): starting rx thread... to OFFLINE (CONFIGURATION_PENDING): trying to get bridge base id...

The related HEX dump of the serial port after or while this message comes each minute up:

0000a60 ffff ffff 0041 556a 0500 0201 00db 8fff
0000a70 80e0 940a 0055 0021 2602 0200 000f 0200
0000a80 0906 0500 1f83 45c1 014f 4703 5441 5745

or

0000a90 5941 5443 4c52 0000 0000 8f00 0055 0105
0000aa0 db02 ff00 e08f 0a80 5594 2100 0200 0026
0000ab0 0f02 0000 0602 0009 8305 c11f 4f45 0301
0000ac0 4147 4554 4157 4359 5254 004c 0000 0000

I tried a lot: restarting openhab, clearing cache, restarting binding only, deleted and reinstalled thing… no chance. Now I’m at my end of all my knowledge and it’s late. Hope to hear quite quick from you with additional hints what to do.

Good night,
Ralf