New openHab2 EnOcean binding

openhab2-addons
enocean
binding
Tags: #<Tag:0x00007f0142c9e358> #<Tag:0x00007f0142c9e1f0> #<Tag:0x00007f0142c9e0b0>

(Daniel Weber) #402

Hi Markus (@mhrnr),

funny, I ordered this NodON PIR yesterday :smile:, so the support for this device should not be far away. The big e-seller with an “A” states that it should be delivered after christmas :frowning_face: . However if you have time for testing, I could try to implement this EEP today.

Best regards
Daniel


(Markus) #403

I think I can wait :grinning:


(Patrick Kötschau) #404

Hi Daniel, my be you can help me.
Last year I bought some 2-channel unidirectional actuators. (Which wasn’t very smart, I know that now).
First I was using FHEM and I got them to work with it.
But with openHab I had no success so far.
I have a working Enocean switch. So Enocean works in general.
I tried to teach in the actuators, like you mentioned in post #28. But it did not work for me. Obviously I am doing something wrong.
I created an enocean rocker switch. Selected my USB300 dongle as bridge. EEP=F6-02-01.
But what Enocean ID do I use? The documentation was not specific enough, at least for me. I used a random ID.
I would expect that I would see an enocean command in the logs, but there only stands:

2018-12-20 16:14:06.128 [ome.event.ItemCommandEvent] - Item 'Testswitch' received command ON
2018-12-20 16:14:06.150 [vent.ItemStateChangedEvent] - Testswitch changed from OFF to ON

So maybe you can help me…
Best regards,
Patrick


(Martin Klein) #405

Hi Patrick,

you need to use a ClassicDevice , put your device in learn mode and than use the switch item you bound to the classicdevice to teach it into the actor.

Unfortunately currently the classicdevice is broken in the release 2.4 version so you would need to use a snapshot build.

Hope this helps you get started

Martin


(Patrick Kötschau) #406

Hi Martin,
thanks!
So I have to switch to snapshot to get it working? ok.
I made my tries not with ClassicDevice but with Rocker Switch, so it could not go twice. :frowning:
May be I will switch to snapshot. I hope I don’t get other problems with it.
Regards,
Patrick


(JonT) #407

I had the same problem as you describe in problem #1. I think there might be an error in your configuration file (and also in the documentation of the binding) as the enocean ID should be defined as “enoceanId”, not “enoceanID”. Take a look at the configuration you described under problem 3.


(Daniel Weber) #408

Hi Patrick (@Novize),

you do not need to switch to openHAB 2.5 snapshot, is sufficient to just use the snapshot version of my binding. You find a precompiled version in my repo or in the marketplace.

Best regards
Daniel


(Patrick Kötschau) #409

Thanks, I will give it a try. Maybe this weekend.
Best regards,
Patrick


(Patrick Kötschau) #410

Hi Daniel,
Maybe you gave me a hint, where to put the jar file on my raspi?
I can’t find the correct folder
I tried to place it in /usr/share/openhab2/addons. But I guess that’s wrong. I probably have to exchange the original jar file


(Martin Klein) #411

Hi,

if you are using openhabian it should go to /srv/openhab2-addons/


(Patrick Kötschau) #412

Puh, I guess I’m stealing your time…
It is under /srv/openhab2-addons/org.openhab.binding.openocean-2.5.0-SNAPSHOT.jar
But openhab still shows 2.4.0 under Add-ons->Bindings


(Martin Klein) #413

try:

ssh -p 8101 openhab@localhost on your pie
do a

bundle:list

you should see something like

254 │ Active   │  80 │ 2.5.0.201812192037     │ OpenOcean Binding

if in the list there is also the enocean binding and not only the openocean / an old version
do a bundle:uninstall NUMBER
where number is the 254 in the above example (first column)


(Ralf) #414

I just updated to the brand new 2.4 release and got it working quite properly. Thank you all for investigating to this new release.

But one problem still occurs in EnOcean binding, which I cannot solve myself. There is hopefully someone that can help:
I added a “measurementSwitch” (Afriso APR 234) with permundo sendingEEPid & receivingEEPid. When I now want to switch the power plug it works once, but immediately after switching to on or off, I receive the opposite event and no more switching is possible (neither from Paper UI nor from Basic UI).

Her is what happens:

2018-12-20 22:13:05.133 [ome.event.ItemCommandEvent] - Item 'PowerPlug_01_Switch' received command OFF
2018-12-20 22:13:05.136 [nt.ItemStatePredictedEvent] - PowerPlug_01_Switch predicted to become OFF
2018-12-20 22:13:05.142 [vent.ItemStateChangedEvent] - PowerPlug_01_Switch changed from ON to OFF
2018-12-20 22:13:05.291 [vent.ItemStateChangedEvent] - PowerPlug_01_Switch changed from OFF to ON

Is there someone that knows a solution for my problem?

Regards,
Ralf


(Patrick Kötschau) #415

Hello Martin,
Now I completely uninstalled enocean bundles. With your command and also with paper ui.
There I didn’t find a openocean, but only
229 │ Active │ 80 │ 2.4.0 │ EnOcean Binding
So I uninstalled this one und also in the paper ui.
But when I try to install it again, it again tells me that it version 2.4.0.
In the directory /srv/openhab-addons/ I have given all right to the binding:
-rwxrwxrwx 1 openhab openhab 57400 Dec 20 20:41 org.openhab.binding.openocean-2.5.0-SNAPSHOT.jar

Is there any config I have to modify to use this binding?


(Daniel Weber) #416

Hi Patrick (@Novize),

uninstall everything again and install the following feature in the console feature:install openhab-transport-serial. This will automatically install/initialize the openocean 2.5 binding.

Best regards
Daniel


(Patrick Kötschau) #417

Hi Daniel,
I uninstalled the old bindings and installed the mentioned feature.
But the openocean binding was not installed :frowning:
In paper ui I still see the uninstalled version 2.4.0
edit:
maybe I will switch to unstable openhab and give it a try…
edit:
f…k
I just realized that the jar file is just 56728 bytes. I used wget to download it.
When I download with windows, the package is 229kb. So I guess the jar file is corrupt.
But right now wget only downloads 56kb… Boah, the next problem. This does not seem to be my week…
edit 3:
my fault was that I didn’t download the jar file itself, but the link to the download page.
Now, as I did it right, I got version 2.5.0 running.
I will try to get my actuator running later

Thanks to all for your help and your patience


(Sepp99) #418

Hi all,
thanks to @JonT I was able to solve my issues with enocean thing config file. The “enoceanId=” tag seems to be case sensitiv. If that’s no mistake, please consider changing the documentation!
As soon as the config file was used the NodOn contact switches were working again (@fruggy83) . I’m pretty sure that I had no typo in the manual creation of the things. Also the receivingState channel was working. Very strange :frowning:

Best regards,
Christoph


(Patrick Kötschau) #419

Hi all,
as I got version 2.5.0 I couldn’t stop myself to try it out. But again I have a little problem.
I have created a Classic Device and want to teach in my actuator. To activate the Classic Device I have created a switch item. That works so far.
Than I set the actuator in teach-in mode. When I switch the Classic device the actuator stops the tean-in for a short moment, but then starts again.
Do you have any idea whats going wrong?
Edit:
I have tried several things but none of them did work. In the end, I annoyed repeatedly pressed the switch and suddenly it worked. Obviously my actuator needed a kick in the a…
Sorry for bothering you with my misbehaving electronic rubbish…
Thank you all!


(Frank) #420

Hi all,

I’m doing my first steps with home automation at all since a couple of days, played a bit with FHEM and actually with openhab2. I have tested manual installation on Raspian using a RPi2 + EnoceanPi. Now I’m playing with OpenHABian on that little RPi2. I got many things working, can e.g. watch status of my physical EnOcean Rocker Switches etc.

But one thing I don’t get run. I have some unidirectional Peha Easyclick actuators and I don’t get a “virtual” Rocker Switch running to switch these actuators from openhab2.

I tried to follow New openHab2 EnOcean binding, but I’m struggeling with the input fields. There’s is no “Sender Id”, openhab2 is just asking for an “EnOceanId of device this thing belongs to”. What to enter in that field for an unidirectional actuator?

The unidirectional actuators don’t have a “Base ID” or a “Chip ID” … ?

Thanks you all.


(Tino) #421

Hi Daniel (@fruggy83),
after some misconfiguration I had to setup everything from scratch, with OH 2.4.0 (stable) and your Enoncean 2.5.0 Snapshot-Jar. (I changed the Bridge communication to my Enocean PI to rfc2217).

So I have two issues / questions:

  1. The FMS61NP can handle two different lights. It is working when I press on my FT55 the Upper Left and Upper Right button. I teached-in UT1 and UT2 on the FMS61NP.
    Now I want to do the same from OH. I created a Classic Device with a Listener and a Switch on Channel A (Toggle Switch). Then I teach-in this Switch as the Upper-Left(UT1). And it works fine. But how to handle the second light? Do I need to create a second Classic Device, with a second Listener on Channel B? But when I do so the result is that both lights going on the same time. Strange. Any hints?

  2. I have a second FMS61NP where I just use 1 channel for switching a third light. And I teached-in on the FT55 the lower right button. But I always get the ID 00000000 back from Enoncean. Can I only handle one FMS61NP with your binding at the moment?

Many Thanks, Tino