New openHab2 EnOcean binding

I tried different gateways for enocean. The easiest to setup is an USB 300 stick. It is plug and play (auto detected by binding) and you can buy it from time to time for about 20€ when buying it second hand.

Your needed EEP is supported as a smoke detector… so there should be no problem using it with your device.

Yes that’s of course even better if your OH machine is close to your sensor. Unfortunately my server is in the basement so I had to come up with something else.

Thanks a lot Dirk, I saw the smoke detector EEP at enOceans list but wasn’t quite sure if the openHab binding would support it since the manuel didn’s mention this EEP family.
Thanks for clarifying!
Price of the enOcean gateway stick wasn’t my concern. But if I had to use the wibuttler gateway eg. this would exceed my budget.
Yes the Hab is close so no Problem there. Even it’s just one sensore there will be much of a benefit cause it’s detecting leakage an malfunction of a pump in the basement which would be quite a desaster if it’s not working properly :slight_smile:
Thanks for your advice.
Since I have no experience in coding an openHab binding this could be a challenge, but coding in general should be no problem.

Well as Dirk pointed out your device should be supported so apparently I was wrong and no coding should be necessary. I just did not find this information in the documentation.

It’s definitely not in documentation but I was curious, so went looking for a point to start implementing missing parts in fruggy83s openocean (this is the source for the openHab enocean binding right?) and was very happy to find a “MultiChannelSmokeDetector” definition and the EEP A5_30_03 class right next to it.
So @dirkdirk was totally right in the first place. Thanks very much u2!

Yes that’s fruggy‘s repository for the binding. However if it is not on the official documentation then this feature was probably not merged to the official OH repo. You should be aware that eventually you need to download and install the addon from this repository and cannot use the official one that is provided through the OH GUI.

I am having troubles with the Trigger channel B of rocker switches right now. They worked fine using the official binding.
thingTypeUID: enocean:rockerSwitch
receivingEEPId: F6_02_01

When Channel A Up is pressed:

14:34:39.038 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchA triggered DIR1_PRESSED
14:34:39.263 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchA triggered DIR1_RELEASED

When Channel A Down is pressed:

14:34:53.134 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchA triggered DIR2_PRESSED
14:34:53.309 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchA triggered DIR2_RELEASED

When Channel B Up is pressed:

14:35:07.404 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchA triggered DIR2_RELEASED
14:35:07.405 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchB triggered DIR1_PRESSED
14:35:07.612 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchB triggered DIR1_RELEASED

When Channel B Down is pressed:

14:35:10.396 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchA triggered DIR2_RELEASED
14:35:10.398 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchB triggered DIR2_PRESSED
14:35:10.604 [INFO ] [openhab.event.ChannelTriggeredEvent  ] - enocean:rockerSwitch:[GATEWAYID]:[ENOCEANID]:rockerswitchB triggered DIR2_RELEASED

Why would the “rockerswitchA triggered DIR2_RELEASED” get triggered when channel B is pressed? This makes no sense.

Hi Tanel,
I added a new channel to handle a second pressed action (CHANNEL RockerSwitchAction). So you can toggle up to 8 switch items with a single rocker switch. However current openocean release is a WIP release. This error is fixed in the oficial binding. I will try to release a new openocean version tonight.

Best regards

Hi Silas,

EEP A5_30_03 is not documented yet, as it is not fully implemented. Currently it just handles the temperature part of the EEP but not the 4 contacts and the wake up part. It is just used as a base class for an Eltako smoke detector which uses a slightly different implementation of this EEP.

Best regards

HI Tanel,

I have uploaded a new openocean release, which fixes your rockerswitch problems.

Best regards

1 Like

Hi Daniel,
thanks for the clarification. The sensor has arrived by now and the basic feature “Smoke detection” and temperature worked like a charm. This special device has also implemented the wake state and i think one of the contacts serve as a battery state signal but I’m not quite shure about that, cause documentation on the manufacturers side lacks this information. Since they recommend using it with a list of approved gateways this might not be a problem for them.
Thanks for your work on the enocean binding!

Hi Daniel,

Thanks, the pushbutton triggers work fine now!

Is there any chance to get the D2-11-02 (Thermokon SR06 thermostat with humidity) fully implemented? Right now it gets recognized and taught in, thing updates these channels:

There are some problems that need resolving:

  • Humidity not getting any values- always NULL
  • Occupancy has value OFF, should be ON
  • Setpoint can not be set from OpenHab to display corrrectly on the thermostat (It should be bidirectional)

Have you gotten any of the D2-11 profiles to actually give feedback to thermostat ie updating setpoint?

Hi everybody,

I have a question regarding an issue I discovered during a long term test period with an eltako/openhab 3 testbench setting. I have several Eltako devices installed (FAM14, FGW14-USB, FUD14, FSB14, FSR14-4x, FTS14EM) and those are connected to OH3 via the FGW14-USB Gateway. With one rocker switch connected to the FTS14EM I created a scene switch to count through different light scenes (managed by rules, in principle like here). So far this setting works very good without any problems.

Anyway, sometimes when i press the rocker switch to change the scene, or another switch (controls also a rule) which is connected to the FTS14EM nothing happens. When I look to the log there is really “nothing”. I get no “PRESSED” or “RELEASED” state in the log. The small status LEDs on the Eltako devices show me, that the button press is recognized by the FTS14EM and send via the RS485 bus to the FGW14-USB.

As mentioned above, another switch (no scene button) does also not response. I can’t detect no pattern behind the behaviour.

I changed the log already to DEBUG but there are also no entries.

More curious, changing the scene states from within OH3 Main UI is further possible.

Rebooting the Raspberry or restarting openhab service solve the issue, but this can’t be the final solution.

I don’t know if this is important, but yesterday before this happend i got an Log entry from the HP Printer Binding as follows:

2021-12-11 18:33:40.913 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from OFFLINE to OFFLINE (COMMUNICATION_ERROR): Total timeout 10000 ms elapsed

2021-12-11 18:33:40.983 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from OFFLINE (COMMUNICATION_ERROR): Total timeout 10000 ms elapsed to ONLINE

2021-12-11 18:33:45.156 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from ONLINE to OFFLINE

2021-12-11 18:33:45.161 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from OFFLINE to OFFLINE

2021-12-11 18:33:45.210 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from OFFLINE to ONLINE

2021-12-11 18:33:55.210 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from ONLINE to OFFLINE

2021-12-11 18:33:55.213 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from OFFLINE to OFFLINE

2021-12-11 18:33:55.291 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from OFFLINE to UNINITIALIZED

2021-12-11 18:33:55.308 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'hpprinter:printer:77c1526f6b' changed from UNINITIALIZED to UNINITIALIZED (DISABLED)

Does anyone observed a same behaviour or has anyone an idea whats might the problem?

Hardware/Software information:
Raspberry Pi 4 Model B Rev 1.1
Eltako (see above)
Openhab 3.1.0 stable release
Enocean Binding 3.1.0 (official from OH3)

Best regards and many thanks in advance

Hi, someone have the NodeOn MSP-2-1-x1 Micro Plug (EEP; D2-01-0E)?
I have trouble to get it working with my OH3 setup.
I find the Device in discovery mode and add it as a thing on OH.

OH receives status changes when i manual press the switch button on the micro plug, but i cannot control the plug from openhab. During the pairing procedure, i flip the switch ON and OFF on webgui but the pairing light stay red and does not pair.

The pairing is working if i use a physical rocker switch (ie the Nodon SIN-2-2-01 Acutator)

Any help is very appreciated

Is there a teachin channel for you thing in openhab within channels (need to click show all)?
If yes you need to use this channel for learning.

No, there isn’t:

Ok just found that maybe is not supported … :frowning:

HI Tanel,

humidity channel should get values now. Occupancy status should be fixed too. The bidir part is still in WIP. The device does not react as it should according to the docs. I suspect a timing issue. Maybe I find some time during holiday to finish this.

Best regards

1 Like

Hi Frederico,

as I mentioned in the issue, I will change the UTE teach in respone and test it with my UTE devices. However until now all my UTE devices could be teached in. Even NodOn devices like SIN-2-1-01.

Best regards

HI Stefan,

I do not own a FGW14-USB nor FTS14EM, I could just test the RS485 implementation with my FAM. So there could still exist some bugs in the implementation :slight_smile:
Do you still receive message from your other devices like your FUD when this problem occurs? Maybe the receive threads gets an unexpected message and breaks :man_shrugging: Do you find error message in your logs before this happens?

Best regards