New Openhabian setup on Raspberry Pi 3 SSH & console access issue

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: Openhabian
    • Java Runtime Environment: what ever Openhabian installed
    • openHAB version: latest build
  • Issue of the topic: No SSH or console access

the install appears to have run sucessullly. I can get to the logs at ip:9001 and the default configuration screen at ip:8080. Samba shares work as well.

the issue is that i don’t have SSH or console access using openhabian/openhabian. any suggestions?

For SSH, I have tried terminal on a Mac and Putty on Windows 10.

I am not a linux expert, hence the Pi and Openhabian route.

At any point during the setup or configuration did it ask or did you provide a change in passwords?

According, to the docs that username/password should work if it hasn’t been changed from the defaults.

What is the command you issue from the Mac?

I ran the install headless. and only hooked up a monitor once i couldn’t SSH to the box. so it should have just done the defaults.

the command from terminal on the Mac was ssh openhabian@

result is connection reset by port 22.

at the console it says login incorrect.

I just ran ssh openhabian@ -v
and it looks like the connection succeeds but with my mac username

there are a bunch of rsa and dosa cert lines with key_load_public: no such file or directory but it ends with the following

debug1: Local version string SSH-2.0-OpenSSH_7.6
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1 Raspbian-5+deb8u4
debug1: match: OpenSSH_6.7p1 Raspbian-5+deb8u4 pat OpenSSH* compat 0x04000000
debug1: Authenticating to as 'openhabian’
debug1: SSH2_MSG_KEXINIT sent
Connection reset by port 22

1 Like

Well, until you can log in on the console ssh is never going to work.

I’m at a loss. All I can think is either the password changed and the docs haven’t caught up, or something went wrong with your install and configuration. I just looked at the script and the default password is the same as it always was so I’m thinking something went wrong during the setup.

You can try to run the install from scratch again (if one thing went wrong it is likely more went wrong as well) or you can follow the instructions in the following link to boot into single user mode and change the password for openhabian.

i will try the reinstall first and not headless this time. If i still have the issue after that i will look at your link.

Thanks for the followup!

the reinstall appears to have fixed the issue.

Thanks again!

1 Like