New TP-Link Smart Home binding with Bulb, Plug and Switch Support

No support for the tapo P100 yet?!
They go for like 12 euros and handle up to 2300 watts. I’m inclined to buying one for the binding maintainer…

1 Like

I bought the KP115 over the weekend, so I decided to install this update (well actually build 273) binding today.
Did all the research and reading I could find for manually adding a binding, and can’t seem to get it “installed”.

I’m running Openhab 3.0.1 on Ubuntu 20.04.2
I created the following folder //opt/openhab/addons and copied the JAR file to it.
Pretty much as per this (rather short) documentation…

Anybody have any further hints as to how I should get this binding installed?
Thanks

Did you uninstall the 3.0 binding via the UI? If so, OH should just pick up the JAR. You may need to restart your system.

I worked out what I was doing wrong.
I mistakenly thought I had a “manual” installation and used the folder quoted above.
I actually have a “Repository Installation”, so the folder I should use is /usr/share/openhab/addons

I copied the new 3.10 binding to the proper folder and the KP115 is working as expected now.

Any update on Tapo P100? :slight_smile:

For anyone following this post, @Bigdesaster has just posted a Tapo binding and is looking for people to test it.

Are there any bindings that can control the KP110 smart plug with energy monitoring?

I assume you either mean the HS110 or the KP115 that replaced it, in which case the binding supports it.

Hi All,
Just bought a KP115 and installed the TP-Link Smart Home Biniding 3.0.2, running Openhab 3.0.2 in Windows.

When trying to add the KP115 as thing using the scan function didn’t deduct KP115, so thought of adding the smart plug manually but among the manual options KP115 was not listed. There is KP100, 105 but no KP115.

So instead added KP115 manually by providing the IP as HS110 and KP115 seems to be working fine, Choose HS110 as according to the TP Link Addon documentation KP115 and HS110 feature same channels

Just wanted to see if anyone else had similar issue trying to add KP115 and wud there be any issues in using KP115 as HS110.

1 Like

I just got some EP10 smart plugs. I noticed they weren’t picked up by the binding. Is there a snapshot release that includes these yet?

1 Like

Just got the EP10 as well. Wondering the same thing

You can configure them manually by selecting a HS103 and entering the IP address. You should set a static IP for the EP10 on your router if you do this.

With auto-discovery, it uses the device ID to find the device, which will not change if your device gets assigned a new IP.

It would be nice to know how to find the device ID. Maybe it’s written on the device or in the app somewhere, but I couldn’t find it. In any case, it’s a lot of numbers compared to an IP. So, for now, I just reserved an address for my EP10 and manually added it as a HS103. Works fine.

Yup did the same thing and it worked. I left device Id blank but made sure to set the switches to static ip

Hi Daniel.

Thank you for this link. I’ve installed it today and it is working perfectly. I’m using node red on my Raspberry Pi to call the Python code.

Installed a KP115 today. Although listed as supported, it’s not shown on the list in PaperUI when trying to set it up, and Scan did not find it, so did not know device id. As others have said, solved by calling it HS110 in the config and using IP address.



Thing tplinksmarthome:hs110:energymonitorplugb  "KP115/HS110 smartplug"             [ ipAddress="192.168.0.235", refresh=60 ]

and


Switch       KP115      "KP115 Smartplug"                      (GF,gPlugs)   ["Switchable"]        { channel="tplinksmarthome:hs110:energymonitorplugb:switch" }

Number KP115_RSSI "KP115 Signal [%d dBm]"  <signal>  (GF) { channel="tplinksmarthome:hs110:energymonitorplugb:rssi" }
Number KP115_Power "KP115 Power Usage [%.2f W]" (GF,gPlugs) [ "CurrentTemperature" ] { channel="tplinksmarthome:hs110:energymonitorplugb:power" }
Number KP115_Energy "KP115 Energy Usage [%.2f kWh]"  <signal>   (GF,gPlugs) { channel="tplinksmarthome:hs110:energymonitorplugb:energyUsage" }
Number KP115_Current "KP115 Current [%.2f A]"  <signal>  (GF) { channel="tplinksmarthome:hs110:energymonitorplugb:current" }
Number KP115_Voltage "KP115 Voltage [%.2f V]"  <signal> (GF) { channel="tplinksmarthome:hs110:energymonitorplugb:voltage" }

TP-Link recently recently release a new LED Strip (KL400L5) and new RGB bulb (KL125). Looking at the addon documentation it looks like these haven’t been added yet.

update: I can confirm that the KL125 bulbs work perfectly, selecting KL130 when adding to OH.

KL400L5 Led strips can be added as a color changing bulb will display the current status however can’t send commands.

@hilbrand Any chance of getting the KL400L5 added? I am able to get a information from wireshark and the plugin (sample of turning on/off below with IDs removed)…

{"system":{"get_sysinfo":{"sw_ver":"1.0.5 Build 210616 Rel.122727","hw_ver":"1.0","model":"KL400L5(US)","deviceId":"deviceIDhere","oemId":"oemidhere","hwId":"hwIdhere","rssi":-54,"latitude_i":548594,"longitude_i":-787978,"alias":"Led Strip","status":"new","description":"Kasa Smart Light Strip, Multicolor","mic_type":"IOT.SMARTBULB","mic_mac":"11:11:11:11:11:12","dev_state":"normal","is_factory":false,"disco_ver":"1.0","ctrl_protocols":{"name":"Linkie","version":"1.0"},"active_mode":"none","is_dimmable":1,"is_color":1,"is_variable_color_temp":0,"LEF":0,"length":16,"light_state":{"on_off":0,"dft_on_state":{"mode":"normal","hue":230,"saturation":97,"color_temp":0,"brightness":7}},"lighting_effect_state":{"enable":0,"name":"Ocean","custom":0,"id":"oJjUMosgEMrdumfPANKbkFmBcAdEQsPy","brightness":7},"preferred_state":[],"err_code":0}}}
{"smartlife.iot.lightStrip":{"get_light_state":{"on_off":0,"dft_on_state":{"mode":"normal","groups":[[0,15,230,97,7,0]]},"length":16,"transition":0,"err_code":0}}}
{"smartlife.iot.lighting_effect":{"get_lighting_effect":{}},"context":{"source":"46a4d58b-6279-432c-ae23-e115c2db8354"}}
{"smartlife.iot.lighting_effect":{"get_lighting_effect":{"custom":0,"id":"oJjUMosgEMrdumfPANKbkFmBcAdEQsPy","brightness":7,"name":"Ocean","segments":[0],"expansion_strategy":1,"enable":0,"type":"sequence","duration":0,"transition":2000,"direction":3,"spread":16,"repeat_times":0,"sequence":[[198,84,30],[198,70,30],[198,10,30]],"err_code":0}}}
{"smartlife.iot.lightStrip":{"get_all_presets":{}},"context":{"source":"46a4d58b-6279-432c-ae23-e115c2db8354"}}
{"smartlife.iot.lightStrip":{"get_all_presets":{"preferred_state":[],"err_code":0}}}
{"smartlife.iot.lightStrip":{"set_light_state":{"ignore_default":0,"on_off":1,"transition":0}},"context":{"source":"46a4d58b-6279-432c-ae23-e115c2db8354"}}
{"smartlife.iot.lightStrip":{"set_light_state":{"on_off":1,"mode":"normal","groups":[[0,15,230,97,7,0]],"err_code":0}}}
{"smartlife.iot.lightStrip":{"get_light_state":{}},"context":{"source":"46a4d58b-6279-432c-ae23-e115c2db8354"}}
{"smartlife.iot.lightStrip":{"get_light_state":{"on_off":1,"mode":"normal","groups":[[0,15,230,97,7,0]],"length":16,"transition":0,"err_code":0}}}
{"smartlife.iot.lighting_effect":{"get_lighting_effect":{}},"context":{"source":"46a4d58b-6279-432c-ae23-e115c2db8354"}}
{"smartlife.iot.lighting_effect":{"get_lighting_effect":{"custom":0,"id":"oJjUMosgEMrdumfPANKbkFmBcAdEQsPy","brightness":7,"name":"Ocean","segments":[0],"expansion_strategy":1,"enable":0,"type":"sequence","duration":0,"transition":2000,"direction":3,"spread":16,"repeat_times":0,"sequence":[[198,84,30],[198,70,30],[198,10,30]],"err_code":0}}}
{"smartlife.iot.lightStrip":{"set_light_state":{"ignore_default":0,"on_off":0,"transition":0}},"context":{"source":"46a4d58b-6279-432c-ae23-e115c2db8354"}}
{"smartlife.iot.lightStrip":{"set_light_state":{"on_off":0,"dft_on_state":{"mode":"normal","groups":[[0,15,356,100,20,0]]},"err_code":0}}}

There is an issue on GitHub to track the KL400 feature request. I’ve put your command in there for reference: https://github.com/openhab/openhab-addons/issues/8709. It will require more work to add the ledstrip as it’s a new type with different command, and I’m not sure if I’ve all information to make it work (besides limited time to implement it).

@hilbrand I appreciate your effort for integration in advance! I’ve gotten command line instructions to adjust the strip successfully and updated github.

In the meantime I’m going to control through rules. But if you need any additional information or logging please let me know.

Also when you do have time to play with it, I would suggest just implementing on/off, color, brightness just like the bulbs for first iteration and only if you have extra time, the effects.

I have an HS105 (firmware version 1.5.6) with version 3.2.0 of the TP-Link binding. It works fine with OH except when I turn it on or off locally or with the Kasa app. In this case OH doesn’t see the status change. Any ideas what the problem might be?

Update: Upgrading to 3.3.0 M1 and reloading the TP-Link binding fixed the problem.