New z-wave device not in database

I just bought a new Evolve LCD-1, which doesn’t seem to be recognized by Openhab. I’m running v3 on a RPi4. The error I got when trying to add it was:
NODE 51: Device discovery could not resolve to a thingType! 0113:4556:4C32::0.31

I tried going to OpenSmartHouse Z-Wave Device Database to add the new device, but the “Create Device” button doesn’t exist for me.

network_cd216933__node_51.xml (8.8 KB)
Evolve_LCD-1_ZWaveSpec.pdf (395 KB)

Attaching the XML file that my openhab install produced when adding the device, and the PDF I found online for the manufacturer. I think they’ve gone out of business - the device was bought open box, and I can’t find a company website anymore.

Can anyone help me get this added to the z-wave database?


Please read

To use the database you must first register on the site, then email, or open a ticket to have your access updated to allow you to edit the information. Please avoid adding comments to this page or other pages to request access or discuss issues. The comments section is to help provide a record of changes, or device issues and shouldn’t be used as a forum as it is not read routinely.

Right. I tried doing that a year ago, but I think they were having issues with the site at the time, and someone else on here uploaded the information on my behalf before my access could be straightened out. Trying again.