New Z-Way Binding

binding
Tags: #<Tag:0x00007f18253540a0>

(Mike Weiss) #181

Great to hear. Thanks! I will test the implemention as soon as it is available.


(Geoff Kalup) #182

I solved the Scene-switch problem with a dummy-multilevelswitch on the Zway-side and rules. The Scene-switch changes its state for simple presses to 10, 20, 50 or 60, the rules in Zway change the dummy to a value of 1 to 4. These changes trigger a rule in OH2.


(Mike Weiss) #183

+Geoff Kalup: Would you describe your approach in more detail. Are there any news concerning the implementation of the wallswitch? Thanks


(Patrick) #184

Hi,

definitely today I make a pre-version available here. Excuse the late processing.

Patrick


(Patrick) #185

I’ve created a pull request: https://github.com/openhab/openhab2-addons/pull/2211 with support for ToggleButton, SwitchToggle and SensorDiscrete.

New version for testing: https://github.com/openhab/openhab2-addons/files/957304/org.openhab.binding.zway-2.1.0-SNAPSHOT.zip


(Patrick) #186

The pull request has already been merged. The changes should also be available in the normal way tomorrow.


(Mike Weiss) #187

Thanks for your kindly and quick support. A first glimpse at the new version shows 4 new channels :slight_smile: like

Z-Wave.Me (24.0.0.1) Button
zway:zwayDevice:192_168_178_32:24:switchControl-ZWayVDev_zway_Remote_24-0-0-1-Scontent_copy
Dieser Channel ist allgemeingültig für verschiedene Geräte des gleichen Gerätetyps, wenn keine weiteren Informationen zur Verfügung stehen.

I will test it in detail this weekend!


(Randy Oliver) #188

I’m having an issue with the state update commands sent to my openhab switch item. From my zway server log:

[2017-04-28 13:05:46.113] [I] [core] Notification: warning (module): Observer not notified - openHAB item: zway_zwayDevice_192_168_2_144_6_doorlock_ZWayVDev_zway_6_0_98 (HTTP Status: 400 - Bad Request - State could not be parsed: close). Failed request: http://192.168.2.164:8080/rest/items/zway_zwayDevice_192_168_2_144_6_doorlock_ZWayVDev_zway_6_0_98/state with body: close
[2017-04-28 13:05:46.134] [I] [core] openHAB item not notified FrontDoor_Lock

My openhab item definition is:

// front door
Switch FrontDoor_Lock (Doors) {channel="zway:zwayDevice:192_168_2_144:6:doorlock-ZWayVDev_zway_6-0-98"}

It seems that the SWITCH item will only accept ON or OFF as a state, not open or close. I tested this via the rest API and was able to reproduce the error. This issue prevents updates to my openhab item via Z-Way and eventually cause my openhab item state to change to UNDEF. Feel free to request additional info. Thanks.


(Mike Weiss) #189

So, I made my first tests with the binding update. My items are

Number switchGFBattery "GF  Batterie [%s %%]" <battery> (Erdgeschoss) {channel="zway:zwayDevice:192_168_178_32:24:battery-ZWayVDev_zway_24-0-128"}
String switchGF1 "GF1 [%s]" <wallswitch> (Erdgeschoss) {channel="zway:zwayDevice:192_168_178_32:24:switchControl-ZWayVDev_zway_Remote_24-0-0-1-S"}

and

String switchGFControl "Control Switch [%s]" <wallswitch> (Erdgeschoss) {channel="zway:zwayDevice:192_168_178_32:24:sensorDiscrete-ZWayVDev_zway_24-0-91-DS"}

I recognized, that the switchGF1 changes only once to ON - but a second press or following press is not recognized as state change. The battery channel and the control switch work as desired.

Thanks for your excellent work!
So I can press one of the four buttons only once.


(Patrick) #190

Hi,

please replace Switch by Contact.

If you create the Items manually, you can look at the description for the required item type.

Patrick


(Randy Oliver) #191

Patrick

Thank you for your response, and thank you for the work you have put into the Z-Way binding. It is the core of my automated home :). In reference to my post, I tried changing the item type to CONTACT prior to posting, but the result was the same. After your post, I tried again. I changed my OpenHab item to the following:

// front door
Contact FrontDoor_Lock <lock1> (Doors) {channel="zway:zwayDevice:192_168_2_144:6:doorlock-ZWayVDev_zway_6-0-98"}

I then reset my bindings through the karaf console and checked the Z-Way server OpenHAB Connector to make sure the observer was still present. It was listed as ‘unknown’, but it was registered. I changed the state of the lock from the Z-Way server via the SmatHome UI. The result was the same. Below is the z-way-server.log entry.

[2017-04-29 10:47:30.783] [I] [core] Notify openHAB item ...
[2017-04-29 10:47:30.783] [I] [core] OpenHAB server found
[2017-04-29 10:47:30.783] [I] [core] http://192.168.2.164:8080/rest/items/FrontDoor_Lock/state
[2017-04-29 10:47:30.785] [I] [core] Notify openHAB item ...
[2017-04-29 10:47:30.786] [I] [core] OpenHAB server found
[2017-04-29 10:47:30.786] [I] [core] http://192.168.2.164:8080/rest/items/zway_zwayDevice_192_168_2_144_6_doorlock_ZWayVDev_zway_6_0_98/state
[2017-04-29 10:47:30.825] [I] [core] openHAB item not notified FrontDoor_Lock
[2017-04-29 10:47:30.834] [I] [core] Notification: warning (module): Observer not notified - openHAB item: FrontDoor_Lock (HTTP Status: 400 - Bad Request - State could not be parsed: open). Failed request: http://192.168.2.164:8080/rest/items/FrontDoor_Lock/state with body: open
[2017-04-29 10:47:30.834] [I] [core] openHAB item not notified zway_zwayDevice_192_168_2_144_6_doorlock_ZWayVDev_zway_6_0_98
[2017-04-29 10:47:30.846] [I] [core] Notification: warning (module): Observer not notified - openHAB item: zway_zwayDevice_192_168_2_144_6_doorlock_ZWayVDev_zway_6_0_98 (HTTP Status: 400 - Bad Request - State could not be parsed: open). Failed request: http://192.168.2.164:8080/rest/items/zway_zwayDevice_192_168_2_144_6_doorlock_ZWayVDev_zway_6_0_98/state with body: open

The below image is a snapshot of the OpenHAB connector on the Z-Way server.

Changing the OpenHAB item to CONTACT prevents control via my OpenHAB sitemap. I would guess this is correct behavior as a CONTACT is an input device and by default should only read status. In addition, I reviewed the documentation prior to implementing the Z-Way binding and assigned the SWITCH item as referred to in the documentation. See below snapshot from the Z-Way Binding documentation for reference.

Let me know if you need any additional info. Again, awesome job on the binding and thank you for the time you put in.

-RoLo


(Randy Oliver) #192

UPDATE

Patrick was quick to respond to this issue and successfully updated the OpenHAB Collector. You can review the dialog on Git here. Great job Patrick and thanks.

-RoLo


(Antony Skinner) #193

Apologies in advance if I’ve missed something but I’ve tried to read all the way through the thread from the beginning but my problem (recently installed Openhab and am trying to use the Zway binding) is as follows:

I cant find any OpenHab connector for the ZWay front end even in 'online apps’
And the contents of my /opt/z-way-server/automation/userModules is simply one file uploadModule.sh no sub-directory

What am I doing wrong? Thanks in advance


(John Schmitz) #194

I installed the connector with the instructions here: https://github.com/pathec/ZWay-OpenHABConnector

cd /opt/z-way-server/automation/userModules
git clone https://github.com/pathec/ZWay-OpenHABConnector.git OpenHABConnector

You do need to restart the Z-way server to see it in your local modules.


(Mike Weiss) #195

I had to reinstall the complete openhab2 including the z-way-binding. Currently I use the 2.1 version, which should include the support for the WALLC switch.

However, using the newest zway-binding I see again

2017-07-02 22:19:34.554 [WARN ] [.zway.handler.ZWayZWaveDeviceHandler] - No channel for virtual device added: SwitchControl [ de.fh_zwickau.informatik.sensor.model.devices.types.ToggleButton@cba0ef[creationTime=1499009210,creatorId=-1,deviceType=toggleButton,h=1129606480,hasHistory=false,deviceId=ZWayVDev_zway_Remote_56-0-0-6-S,location=0,permanentlyHidden=false,probeType=,visibility=true,updateTime=1499026205,metrics=de.fh_zwickau.informatik.sensor.model.devices.Metrics@191ea73[icon=,title=Z-Wave.Me (56.0.0.6) Button,level=on,probeTitle=,scaleTitle=,color=de.fh_zwickau.informatik.sensor.model.devices.Color@17cc48f[red=0,green=0,blue=0],min=0,max=0],tags=[]] ]

The updated version from April worked perfectly for me. So I have no answer, why the binding does not provide support for the four buttons? How can I check what’s going wrong?


(Patrick) #196

Hi,

I think it is a problem with the current build. I’ll come back when the problem is fixed.

Many thanks for your information.

Patrick


(Patrick) #197

Hi,

the feature you need should work. Could you try again, please.

Patrick


(Mike Weiss) #198

Hi Patrick,

would you point me to the download URL of the new binding version? I found only older versions which do not work for me in total?
Thanks,
Mike


(Mihai Badea) #199

I too have a little problem with a ZME_WALLC-S…
It look like the button state is transmitted as on instead of ON.

Items are the following:

Group gTest

Number gTestControl "gTestControl" (gTest) {channel="zway:zwayDevice:192_168_200_202:37:sensorDiscrete-ZWayVDev_zway_37-0-91-DS"}
Number gTestBattery "gTestBattery" (gTest) {channel="zway:zwayDevice:192_168_200_202:37:battery-ZWayVDev_zway_37-0-128"}
Switch gTestButton1 "gTestButton1" (gTest) {channel="zway:zwayDevice:192_168_200_202:37:switchControl-ZWayVDev_zway_Remote_37-0-0-1-S"}

Pressing button 1 on the WALLC-S:

[2017-08-27 10:33:19.470] [I] [core] Notification: device-info (device-OnOff): {"dev":"Z-Wave.Me (37.0.0.1) Button","l":"on"}
[2017-08-27 10:33:19.472] [I] [core] Notify openHAB item ...
[2017-08-27 10:33:19.472] [I] [core] OpenHAB server found
[2017-08-27 10:33:19.472] [I] [core] http://localhost:8080/rest/items/gTestButton1/state
[2017-08-27 10:33:19.547] [I] [core] Notify openHAB item ...
[2017-08-27 10:33:19.547] [I] [core] OpenHAB server found
[2017-08-27 10:33:19.547] [I] [core] http://localhost:8080/rest/items/gTestControl/state
[2017-08-27 10:33:19.644] [I] [core] openHAB item not notified gTestButton1
[2017-08-27 10:33:19.686] [I] [core] Notification: warning (module): Observer not notified - openHAB item: gTestButton1 (HTTP Status: 400 - Bad Request - State could not be parsed: on). Failed request: http://localhost:8080/rest/items/gTestButton1/state with body: on
[2017-08-27 10:33:19.687] [I] [core] openHAB item successully notified gTestControl

and openhab log:

10:33:19.486 [WARN ] [thome.io.rest.core.item.ItemResource] - Received HTTP PUT request at 'items/gTestButton1/state' with an invalid status value 'on'.
10:33:19.771 [INFO ] [marthome.event.ItemStateChangedEvent] - gTestControl changed from 0 to 10

If I try http://localhost:8080/rest/items/gTestButton1/state with boody ON (or OFF) in REST API it works, of course.
Of course, I can use gTestControl to detect any button press…


(Mike Weiss) #200

Dear Mihai,

where did you get the binding version, that supports the WALLC switches. Any pointer would be very helpful for me.
Thanks,
Mike