Newb - pulling out my hair

I really like the premise of OpenHAB but I am starting to wonder if it is viable yet. I have been beating by head against my desk for a week and I haven’t even seen a UI yet. :frowning: I’m already running a Synology DS716+ and have learned a lot. It made since to add OpenHAB to the Synology but I’m not having any luck. Here is where I am at so far:

I finally found the 1.5.0-001 package in the syno community packages. Someone might want to rename it. The package name comes up as “null” so you can’t find it alphabetically.

I tried to install 1.5 from the package center but I get an error about “homes” not being active when they actually are. I read that this was a known issue but that it was later fixed.

Without a package available in the package center I poked around and found the SPK for 2.0 (couldn’t find a 1.8 spk) and installed that manually through the package center. Package running!

That’s as far as I have been able to get in a week. :frowning: when I go to


my browser tries for a long time to load and finally present’s a small bit of border at the top of the page and times out. I took a look at the source and it is pulling 663 lines of html but something is clearly broken.

I figured I would run a demo and start with that as an example. most of the help files I found about where to find the conf files are out to lunch. I scratched together enough putty knowledge to finally SSH into my synology and I found the files here:


although I did create




the install didn’t use these folders. I edited


and set

package = demo

but when I went to the package center and stopped the OpenHAB2 package, it wouldn’t re-start. I also tried

package = standard

but with the same result. Once I commented the line back out, the package will run again but I can’t get my browser to show me anything useful.

I opened port 8080 wide open on my synology. I didn’t set a forward in my router for security reasons but that shouldn’t matter since I am on my LAN and using the local IP of the synology

I went into the package center and took a look at the logs for the OpenHAB2 package. I see errors there but I’m not sure what it all means or how to fix it. To make matters worse, I can’t find a way to copy the logs from the package center and I can’t locate where they are stored. The error starts out with something about Java failing to generate a new SSL certificate.

If anyone has any suggestions, I could sure use some help. Thanks in advance.

I have been through this in the last week. Do you have a recent (1.8) version of Java installed? Not open JDK but the official Oracle one

I installed the 8.0.101-0011 Synology Java Package and my testing system is running with Java 8 update 111.

I’m not sure what you mean by the oracle 1.8 version, I did install from Oracle but they are on Java 8, not java 1.8

Java 8 is the marketing name. Internally it is version 1.8. There are multiple implementations of the Java platform. I started with the Synology package which is based on Open JDK. Some things did not work. I removed that and installed the correct Oracle JDK. Things worked

If you log on to the synology with ash and type java -version what do you get?

I’m using putty but should give same result:

openjdk version "1.8.0_101"
OpenJDK Runtime Environment (IcedTea 3.1.0) (linux-gnu build 1.8.0_101-b13)
OpenJDK 64-Bit Server VM (build 25.101-b13, mixed mode)

I’m just starting to learn putty. I have never installed anything on linux other than with the DSM package manager. Detailed steps would be great! :slight_smile:

I used this package for Oracle JDK. No terminal needed to install. This may not fully solve your problem but should at least stop further problems later. I am remote from my home setup right now so I can’t offer as much help as I’d like