Newbie help required on Mios Bindings item generation

I’m new to OpenHab, I’ve successfully installed Openhabian on a Pi3 and am up and running. I’m a vera user so need the Mios bindings. I’ve my Veras entered in the config file and I have the 3 files needed to do item generation from GitHub but where can I run the generation files? I have a Windows PC and the Pi - I figure I have to run them on Linux but how? Despite hours reading about Linux, trawling the community site and trying stuff I can’t figure it. I know this is a really silly question but my whole install is now stalled :frowning:

Hi Mark,

a long time since I´ve did this; and I have my vera retired now - but let´s see if I can be of some help …
While it is possible to do this on windows 10 with the linux subsystem I recommend to do it on a native linux.

At which step do you fail to generate the items? Is it possible to execute ./ Of course you´ll need your vera IP(s). That should generate a .xml file with some raw data.

With ./ house you should then be able to transform this raw data to a .items file that you can use as a basis for your config; some manual tweaks are needed if I remember right.

Please check also to check the system pre-requisits:

  • bash
  • curl
  • xsltproc

As said - a long time ago I did this; in worst case the new vera units are not compatible anymore. Please provice some more details where you have problems and what error messages you get.

with kind regards,

Really appreciate a response Patrick - I’ve put the necessary files in a share where I log in to the Raspberry, I run the first file and get a command not found error

So then I thought I could use a Linux emulator like Cygwin. I only did a base install so I figure I might be missing components. I get exactly the same error there as well.
(I’m starting to wonder if I should ditch my 2 Veras and move everything over - it’s only the re-pairing of the Z-wave kit that’s stopping me)
Does that help any further in working out what I need to do
Many thanks & Regards

do you have the same problem if you use “./ …” => the ./ might make a difference

It should be possible to transfer the controller without the need to repair the devices; but for raspery someone else would have to help you with that. But I would recommend this …

Pretty much similar result…

did you download the file with windows? Then you might need to convert the line format to unix style (e.g. with notepad++)

For the zwave thing … have a look for controller shift.

I downloaded it in raw form, pasted it into Visual Code Studio then saved it to the different locations from there. Interestingly with Cygwin I get this now:

sorry … the file format was my last idea :frowning:- still; I recommend to invest in the controller shift rather than the inclusion of the vera. Anyhow - backup your zwave network prior to attempt any such operation!

with kind regards,

Thank Patrik - I’m really glad you dropped by, I think I can retire both Veras and one way or another control everything I want through OpenHAB. Unless I suddenly fall on a way to make the binding work I’m going to buy a Gen 5 stick and go for it as I looked at controller shift and I agree it’s a smoother solution overall.
Kind Regards