[Newbie] Z-Wave PIR Sensor shows as Unknown Device

Hey, @chris I just added my Z-wave binging & discovered things.
I have a Neo Coolcam PIR sensor that worked with a previous snapshot. It now shows up as an Unknown Device.
I think when it worked earlier, it was added through OH instead of being discovered on an existing network.
The Manufacturer & Type/ID are blank. I have woken up the sensor multiple times & tried healing it.
If needed I can exclude from the network & re-add. How do you want me to proceed with this?
I believe it should be Manufacturer 0258, Type 0003, ID 0008d.

Thanks, Chris.

This will be the issue then - if the binding doesn’t know this data it can’t work out what the device is.

Can you grab a debug log? Generally this is simply caused by not waking up the device so the binding can discover it - or waiting until it wakes itself if it has previously been configured to do so. The log should confirm if the device is waking, or if there’s another issue somewhere.

How do I do that?
BTW, Snapshot 1619
I wondered if the device, once on the network just does not behave as expected.

I set up debug by following this. There is no xml file in /var/lib/openhab2/zwave for that node.

If the binding doesn’t know the device information during initialisation, then it will try to retrieve it.

No - it’s not created if the binding doesn’t know the device information.

The binding documentation has a section at the bottom about “what to do when things don’t go as planned”.

OK. I set the log to debug (no xml to delete) & restarted z-wave, waking up the node. It now shows up properly identified. :confused:

I assume I now need to set the log back to warn & restart zwave, correct?
I also assume the successful debug logs will be of little use.

It’s up to you - if you don’t want the logging, then drop it back to WARN or INFO, but you don’t need to restart for this to take effect.

Yes, if it worked, then it won’t show anything useful - but at least it’s working :slight_smile:

1 Like

Thank you very much for the quick direction.
Now I need to get over my extreme dislike of Java :frowning:

1 Like

Hey @Chris,
Does the z-wave binding for the sensor have a “units of measure” field? If so, I can submit an update to the database.
The temperature of the sensor appears in Celsius with no UoM. I prefer Fahrenheit here in the US.

Normally when the device sends the report, it will provide the units with the report. The binding then passes the units and the value to the core, and the core will perform the conversion to your locale. Because of this, it will not actually matter what units the device is reporting in, as OH should convert to the units configured for your system if required.

You need to make sure that the locale is set in your configuration for this to work.

This sensor appears to provide no units for temperature, but it is actually Celsius. I guess I will need to create a conversion then.

Thank you for your patience.

I’m not completely sure that’s possible - I forget what the spec says, but I don’t remember an option for no units. It must report this I think.

If you still have debug logging enabled then it would be worth a check.

I will enable debugging when I get a chance & report it to you then.

1 Like

OK. debug logs here.


For reference, if it helps. this OZW config seems to work, but I did not see sensor outputs there.

There is no rush on this. I realize it is getting late in the day in Australia.It is morning here. I can wait, if needed.

I don’t expect this to require any sort of configuration in the binding - the binding should automatically pass the units along with the value into openhab. I just checked the spec, and the sensor must set the scale to either F or C - there is no option for “no scale”. Im pretty confident that the binding will be passing this in to openHAB, so as long as you have the locale set correctly, the UoM system ought to localise this for you.

I’m not in Australia - I’m in the UK :slight_smile: . I’m originally from New Zealand, but have been here a long time now (nearly 25 years). So, it’s mid afternoon here - I’m going to head out on my mountain bike shortly, but can take a look at logs later.

1 Like

@chris I just ran by debug log through your viewer & it appears my sensor is sending units. Perhaps a bug?

Can you elaborate on what you think the bug is? As I’ve mentioned in the past, the device should send units - it’s not possible for it to send data unitless.

OH did not know the units for conversion though. I notice this 2 messages later. A different value and only 1 sensor. I do not recall the value shown in OH at that time

But the state update is showing the units - that’s what matters. That is what is sent to OH - if OH is then not presenting this correctly, that is likely an issue with the locale configuration as mentioned previously -:

If you’re unsure, then please provide the log.

The locale is set. Debug log is still here from Sunday when you asked ;). https://pastebin.com/xKh2wf4m

If no bug, that’s fine. I am using a transform now to convert to Fahrenheit.

Did you double check? It is not the locale from your operating system, it is the measurement system from openHAB which is needed: