Newly installed Eclipse with OH2 has compilation errors

Hi all,
I downloaded and installed OH2 development environment succesfully strictly according to the video and descriptions in the WIKI.

But I have hundreds of compilation error in the packages downloaded from GITHUB.
Typically these kind of errors :

> AbstractItemsProposalProvider cannot be resolved to a type. ItemsProposalProvider.xtend /org.eclipse.smarthome.model.item.ui/src/org/eclipse/smarthome/model/ui/contentassist line: 21 /org.eclipse.smarthome.model.item.ui/src/org/eclipse/smarthome/model/ui/contentassist/ItemsProposalProvider.xtend Xtend Problem

Does anybody have an idea how to proceed ?

Best regards

Which packages have you selected on the installer (in step 4)? The projects org.eclipse.smarthome.model.* are not imported to your workspace in any situation - and if this now happens, this would be clearly a bug of the IDE install.

Thanks Kai for the quick response.

I haven’t explitcilty installed any packages, just as shown in your video, I selected in the Eclipse Installer “Project/OpenHAB/OpenHAB Development” with the important double click and that did the rest.

But when I just watch the video again, I see that my packages look like different, than those in the video.

Here is a screenshot


Your IDE shows “Eclipse SmartHome” in the title, this indicates that you have selected some wrong option.
I just tried it: Selecting in step 4 “” entry, double click “openHAB Development”, I get this setup:

Just tested the installation path you described ( also in the WIKI) - , (not the one in the YOUTUBE- video.)

It worked ! So perhaps withdraw the YOUTUBE- video.

Thank you very much for your assistance ! Highly appreciated.

I will try to develop a binding for an IP-Camera (from with a more generic approach to IP- cameras.
Do you of any such ambitions or similar attempts ?

In the known bindings I did not find anything.


Are we talking about the same video?
On the docu, I have already put a note that step 4 in the video is outdated - but I still feel that it can be useful nonetheless. I’d also love to create an updated one, but simply lacking the time (and no other volunteers were found yet :frowning: )

Got it going : This is the setup of the Eclipse installer that turns everything into bright:

Yes, that’s the one video. Following that path shows the errors I mentioned.

Anyway, I’ve managed to get it running, but now I’m missing the binding skeleton scripts mentioned in this video “openHAB 2 - Getting Started with Binding Development” .

I’m somewhat on a wrong path. It’s a bit confusing for a newbie.


Ok, this is outdated in the video as well - so I agree that it is too confusing and thus I removed the link now.

Look at the documentation instead. It states:

go into your git repository under git/openhab2-addons/addons/binding and call the script


any updated link to the documentation, please? The links pointed out here are pointing to 404 github pages.
I have around 300 compilation errors.

I’ve imported everything, should I just import “Runtime” and “OH2 Add-ons”?

Apart thant that I also have “Other projects”, “ESH Extensions”, “OH1 Add-ons”, “Infrastructure”.