Neye3C configuration with ipcamera binding

Tags: #<Tag:0x00007f6170e9ab50> #<Tag:0x00007f6170e9aa38>

I could not reproduce it here, can you give more details on what you changed and how to break it?

How do you start with it off? with a rule that triggers when the system starts?
Have you tried this instead?
IMAGE_UPDATE_EVENTS=0

It is possible your server is very fast and this is a timing issue, will be looking into it further.

The process is quit simple:

  1. I start OH with start.bat file
  2. I put “Update image Now=off” with the Paper UI interface. Control panel of the Camera
  3. I stop OH clossing Karaf window
  4. I start OH with start.bat file
    That is all.
    As I said previouly my conf file is
    IPADDRESS="192.168.0.16",
    PASSWORD="xxxxxxx",
    USERNAME="admin",
    ONVIF_PORT=80,
    PORT=80,
    UPDATE_IMAGE=false,
    SERVER_PORT=50014,
    POLL_CAMERA_MS=2000,
    IMAGE_UPDATE_EVENTS=1,
    UPDATE_IMAGE=false,
    SNAPSHOT_URL_OVERRIDE="ffmpeg",
    FFMPEG_HLS_OUT_ARGUMENTS="-f lavfi -i aevalsrc=0 -acodec aac -vcodec copy -hls_flags delete_segments -segment_list_flags live -flags -global_header",
    FFMPEG_GIF_OUT_ARGUMENTS="-filter_complex fps=4,scale=480:-2:flags=lanczos,setpts=0.25*PTS,split[o1][o2];[o1]palettegen[p];[o2]fifo[o3];[o3][p]paletteuse",
    GIF_PREROLL=0,
    GIF_POSTROLL=8,
    FFMPEG_OUTPUT="c:\\cameratmpfs\\camera2\\",
    FFMPEG_LOCATION = "C:\\Program Files\\ffmpeg-4.2.2-win64-static\\bin\\ffmpeg.exe"

You have that option set twice in your things file. Don’t know what the cause is perhaps it only happens on PC due to some cache? But I can not reproduce that on Linux.

I really don’t know,
Anyway, if you know this behavior it is possible to avoid it, and usually you are not starting and stopping OH.
Thanks!

What about persistence services, do you have any enabled? If so try turning it off as it may be possible the binding is sent a command when things are not fully ready.

I do not have any persistence services enabled

I am out of ideas, I would need a way to reproduce it on my setup and this may be something that only happens under java on PC. May be worth looking to upgrade the java to the latest version 8 if not that already? Also I just uploaded a Alpha build that has onvif events in it so if your camera works with it, it means far less CPU as ffmpeg is not used for motion detection. See main Ipcamera thread for info on it.