Niko Home Control II

(Brecht) #101

seems to work nice, the overrule counts down on the OH interface

21:42:03.778 [INFO ] [smarthome.event.ItemStateChangedEvent] - ThermostaatLiving_OverruleTime changed from 60 to 59
21:43:03.779 [INFO ] [smarthome.event.ItemStateChangedEvent] - ThermostaatLiving_OverruleTime changed from 59 to 58

(Mark Herwege) #102

@blatruwe Great to hear. That’s what I intended to happen. Make sure you check all combinations: select program, set overrule with and without time etc. All of that should work from whatever control you do it (OH, touchscreen, wall control) in any sequence. If you find any sequence that does not behave, let me know.
I also expect ambient temperature to update. So the temperature channel should always give you the current room temperature.

(Wegh Christof) #103

Strange, loaded the latest version, but I can’t connect anymore (communication error). Can connect to 8883 though.

//edit: restarted the bundle and now it works again.

(Mark Herwege) #104

@cwegh Get me the log of the startup fail. I want to try to figure out the reasons to see if I can improve on it.

(bccrew) #105

Btw, integration with Google Assistant works great. Please note that it is not supported in Flemish yet but you can download the APK and speak dutch (not flemish) to the assistant.


  • Install the Openhab cloud connector via Paper UI - Add Ons - Misc
  • Create an account on and link to it
  • tag your items like this:

Switch Spots_Salontafel "Spots Salontafel" ["Lighting"] { channel="nikohomecontrol:onOff:443b00xxxxxx:4xxxx0f7-xxx9-4xxx-xx7-bxxxa3xxxxxd:switch" }

the lighting tag needs to be in front of the channel

  • expose your items via the Openhab cloud connector configuration panel

Good luck!

(Mark Herwege) #106

I just posted a new version that has support for more action models. Models like socket and pir should now also work.
You may have to remove your things and add them again to have the correct behaviour. They should then also show the model and technology in the properties.

(Wegh Christof) #107

@bccrew Nice, didn’t now this was possible. Definitely going to check that out!

@Mherwege: I added the new version. Sockets are discovered, no PIR.

(Wegh Christof) #109

@bccrew: Google assistant up and running. Thermostat is showing up, but I cannot set the temperature.

Group g_ThermostaatBeneden_TSAT "Living Thermostaat" [ "Thermostat", "Celcius" ]
    Number ThermostaatBeneden_Mode "Living Programma" (g_ThermostaatBeneden_TSAT) { channel="nikohomecontrol:thermostat:----:mode" }
    Number ThermostaatBeneden_Measured "Living Temperatuur" (g_ThermostaatBeneden_TSAT) { channel="nikohomecontrol:thermostat:----:measured" }
    Number ThermostaatBeneden_Setpoint "Living Gewenst" (g_ThermostaatBeneden_TSAT) { channel="nikohomecontrol:thermostat:----:setpoint" }
    Number ThermostaatBeneden_OverruleTime "Living Duur Gewenste Temp" (g_ThermostaatBeneden_TSAT) { channel="nikohomecontrol:thermostat:----:overruletime" }

(bccrew) #110


I see you copied the thermostat items from the help page but you are missing some needed tags. Also I’m not sure if you can control the override time with a voice command like this. I think asking the current temperature and setting wanted temperature should be doable. Maybe change prog? You should try it and let us know! :slight_smile:

If you expose thermostats make sure than you have:

A group item with the tag [ "Thermostat" ]
A number or string item with the tag [ "homekit:HeatingCoolingMode" ]
A number item with the tag [ "CurrentTemperature" ]
A number ityem with the tag [ "TargetTemperature" ]

Please check the FAQ on the bottom of this page:

PS: I use Visual Studio Code to create all files for Openhab, it has a syntax check and autocomplete for many things so you can’t really make typo’s. This tutorial is very helpful.

(Wegh Christof) #111

@bccrew: ha indeed, I forgot the tags. Using VSC also, showed no syntax errors though. But not for tonight anymore. Somehow the Google assistant link to openhab was gone. Re-associating did not work. Going to reinvestigate another time.

Also, the socket show up as switch, but I cannot create an item on the channel (does not show up in the logs also somehow?). It shows a pop-up Internal Server Error 500 for a very short time.

(Mark Herwege) #112

@cwegh For, the pir, can you get me the trace log at binding start? Curious to see what goes wrong. From its definition, I was assuming it was pretty much the same as other devices that need to be triggered.

(Wegh Christof) #113

Sent the logs in private message. Had to restart twice.

(bccrew) #114

Yeah it’s kinda buggy sometimes… Need to play and test with it some more too.

(Bjorn Embrechts) #115

Hi Guys,

Revisited the thread after a while here, good lord, you guys got allot figured out in a short time.
I installed openhab on my server today but i dont get the Niko Bindings, I got the Jar file in the addon folder; restarted… not sure what i forget or doing wrong. is there a step by step somewhere to get me going?

Amazing work guys!

(Mark Herwege) #116

@Bjorn_Embrechts Happy to see you join the testing.
We are not there yet. There is a lot working, but we also still see quite a few stability problems. But the more testing that is done, the more chance we have to figure it out.
The binding itself should work out of the box without much configuration. Don’t install the Niko Binding from the release (that is just NHC I). If you have already, uninstall that through PaperUI. Copy the binding jar, referenced up in this thread into the addons folder. Your CoCo should appear in your inbox. Accept it, and all your devices should appear in the inbo. Accept the ones you want to control.
Check the openhab.log and events.log file for any hints if this does not work.

You can switch logging to a higher logging level (DEBUG or even TRACE) to get more info. You can do that from the Karaf console, see up in this thread and the documentation. There currently is an issue when people switch back from DEBUG to DEFAULT log level. The bridge does not come back online anymore. I am curious if this is true for everyone, or just a timing issue for some users. Therefore also, please test if it comes online before switching logging to a higher level. Maybe it only happens when you switch back.

(Kevin Verbeke) #117

hi guys, love your work, i installed and linked everything.
if i can help let me know. i have energy devices

1 question, how do i get it to use it with homekit?
i installed the service, but the swithes dont show up.

maybe an example, its all new to me

(bccrew) #118

Did you follow all instructions like described here:

Read a few posts back here where I described the correct tagging of items. It’s always best to manually create items instead of linking them through Paper UI.

(Wegh Christof) #119

Google Home and thermostats is a no-go. Below the code and a screenshot.

Group g_ThermostaatBeneden_TSAT "Living Thermostaat" [ "Thermostat", "Celcius" ]
    Number ThermostaatBeneden_Mode "Living Programma" (g_ThermostaatBeneden_TSAT) [ "homekit:HeatingCoolingMode" ] { channel="nikohomecontrol:thermostat:<id>:mode" }
    Number ThermostaatBeneden_Measured "Living Temperatuur" (g_ThermostaatBeneden_TSAT) [ "CurrentTemperature" ] { channel="nikohomecontrol:thermostat:<id>:measured" }
    Number ThermostaatBeneden_Setpoint "Living Gewenst" (g_ThermostaatBeneden_TSAT) [ "TargetTemperature" ] { channel="nikohomecontrol:thermostat:<id>:setpoint" } 

(Mark Herwege) #120

I don’t have thermostats, so cannot test. But I assume you have to create an extra item and some rules to map the Niko modes to the required homekit modes, as used by Google Assistant.
Here is an example for something similar for KNX: Google Home & openHAB connection How-To
The modes used by the binding for Niko are numbers, and documented in the binding doc (same for nhc I and II).

(Wegh Christof) #121

Didn’t know about the rules, I’ll try that.