No auto discovery of Netatmo thermostats API is online

I wonder why the Netatmo API binding is up and running and is online but I cannot discover any devices - what can I do then ? How will I know what to enter manually?


This the only thing I can find in my log:

I added a Thermostat/Plugin to thing

and then I get this communication error:

Are you sure, that you have enabled the Thermostat API in the Netatmo-API-Thing?

Yep I have:

According to your pictures here, your IDs are to short, they consist out of 12 digits. You can look them up in your iOS app. With the correct IDs you should be able, to set up the think manually (as you have already tried). Another way is to do that via files, like described in the doc.

Shouldn’t the ID’s be the Netatmo device Serial Number (I can see in my iOS App) and that looks very much like a Mac Address. And that I have added in point 2 and 3 in this thermostat setup - but I think I have seen the ID as not a Mac Address somewhere (maybe in the Netatmo Webpage):

Maybe this label confused me:


I think, you’ve done it the right way. I was just confused that your channel names had not the whole 12 digits/character in its name.

I had a look at my config. I can’t remember why, but I created the bridge via a textual file. Maybe you can try that. So remove all your things and add a file netatmo.things to openHAB-conf/things folder:

Bridge netatmo:netatmoapi:home [ clientId="******", clientSecret="******", username = "******", password = "*******", readThermostat=true] {
1 Like

Ok I will try that - it sounds like a good place to start

Well no difference - this is starting to annoy me a bit? Should it be this difficult to connect to in-house devices in OpenHab? I can connect my thermostats to Google Home or Apple Home or IFTTT but not to OpenHab - that is very odd.

If i try to add things manual nothing is “shown” in Things in Paper UI - if I just add the bridge line alone (first line below) then it appears in Things.



I have the same problem. My API is Online, because I add the weather station in France to my Netatmo account and automatically have been discovered in In box of paper UI.

My problems are with the Relay. in paper UI shows this:

And my log is saying this:
[ERROR] [nternal.handler.NetatmoDeviceHandler] - Unable to connect Netatmo API : 404 Not Found

I have to say that was fighting with this 1 week. Yesterday I saw the relay connected. This morning wen I wake up I tried to see if is showing some information but when I configure some items it goes down other time.

If you can help me, it is important for me.