No connection to my.oh

using build 436 of OH2 and java version "1.8.0"
Java™ SE Runtime Environment (build 1.8.0-b132)
Java HotSpot™ Client VM (build 25.0-b70, mixed mode)

but can’t connect to my.openhab

upgrade java again and works now

Can you please detail how you updated Java, I’m a noob when it comes to the terminal.

check here https://www.digitalocean.com/community/tutorials/how-to-manually-install-oracle-java-on-a-debian-or-ubuntu-vps

I got it working installing version Java SE Development Kit 8u101 from here http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

I HAD installed the apt-get version which was latest, but old, so I did first apt-get remove oracle-java8-jdk

@Guillermo_Ruffino thank you for sharing. This solved my problem.


For others that are searching on this problem:

When attempting to go to: https://my.openhab.org/openhab.app?sitemap=mysitemapname I received the following error:

openHAB is offline

I was also seeing the following errors in openhab.log (With DEBUG level set in logback.xml)

2016-08-04 01:02:39.675 [DEBUG] [.myopenhab.internal.MyOHClient] - No connection, Item update is not sent
2016-08-04 01:02:39.680 [DEBUG] [.myopenhab.internal.MyOHClient] - No connection, Item update is not sent
2016-08-04 01:02:39.686 [DEBUG] [.myopenhab.internal.MyOHClient] - No connection, Item update is not sent

I removed oracle-java8-jdk as suggested using:
sudo apt-get remove oracle-java8-jdk

I recommend rebooting the Pi after the removal step…

I used the following wget command to download the new jdk:

wget --header "Cookie: oraclelicense=accept-securebackup-cookie" http://download.oracle.com/otn-pub/java/jdk/8u101-b13/jdk-8u101-linux-arm32-vfp-hflt.tar.gz

I then followed the rest of the steps from the tutorial above: [quote=“Guillermo_Ruffino, post:3, topic:12907”]

[/quote]

I’m on a Raspberry Pi 3 running Raspbian 8.0 (jessie)
openHAB runtime v1.8.3