No connection to Openhab on the internet after installation

Hi, I’ve been trying to install my openhab for days. However Openhab does not have a web server after installation. With Putty I get a connection to Openhab (I’ve already used LAN and WLAN) and controlling from the shell via HDMI also works perfectly. A web server is not set up. https://openhab:8080 (or whatever it’s called) doesn’t work. I use the links from the doc. and the links shown in the shell with a Raspberry Pi 4. I’m getting desperate. I installed it using Etcher and the Raspberry Pi Imager. Both with old images and with the new image and the one offered in the Pi Imager. Does anyone have any idea how I can solve this? The Raspi is listed in the Fritzbox.

You need to step back and provide a lot more specifics.

Which links from which docs?

Which images downloaded from where?

From what you’ve said so far, we can’t even guess whether you’ve even installed OH, let alone what might have gone wrong. It seems like you’ve just installed Raspberry Pi OS. But :person_shrugging: . Who knows what else you’ve done?

  1. Do you have any child control or filter active in the Fritzbox, which could prevent this?
  2. please use the IP address, you can see in the fritzbox to access the UI via http://IPADDRESS:8080
  3. then provide us with more information as Rich already told you

and by the way, if you’re using openHABian (as recommended on Rasperry Pi), there is no Wifi AND LAN active in parallel, only LAN, if connected via LAN and Wifi, if you configured it as explained in the openHABian docs.
and yes: there’s no webserver running in openHABian (and openhab), you connect directly to the application server - but this is also explained in the docs.

Port 8080 is being used to run the openHAB application. The underlying software is based on java.
So login to the openhab host using putty/ssh or a console/keyboard/monitor and run

sudo netstat -tulpn |grep -i java

This will list all java processes and related listening ports.
If everything is ok then it will look similar to the following output

tcp6       0      0 :::8080                 :::*                    LISTEN      911/java            
tcp6       0      0 :::8443                 :::*                    LISTEN      911/java            
tcp6       0      0 :::8101                 :::*                    LISTEN      911/java            
tcp6       0      0         :::*                    LISTEN      911/java            
tcp6       0      0 :::5007                 :::*                    LISTEN      911/java            
udp6       0      0 :::58789                :::*                                911/java            
udp6       0      0 :::5683                 :::*                                911/java            
udp6       0      0 :::67                   :::*                                911/java            
udp6       0      0      :::*                                911/java            
udp6       0      0 :::5353                 :::*                                911/java            
udp6       0      0 :::1900                 :::*                                911/java

If there is not output at all then the java process is not running and you need to check e.g. the openhab.log file located in /var/log/openhab.

sudo journalctl

may also help to identify problems.

  1. No
  2. I have already done it
    I menat the application server with LAN or WLAN. I tried both

we still don’t know, what you did, which platform you use (except a raspberry pi) and what your specific problem is. If you expect more help from us, please have a look here:

currently we cannot help you, because you seem to mix different aspects, but we cannot assume your environment and what steps you did and what you already tried to solve your problem.
As a really good starting point, as you are new to openHAB, please take your time to have a look at the documentation and of course as you’re using raspberry Pi as platform it’s highly! recommended to start with openHABian:

I looked at the doc.
I used the Dowbloads from GitHub, the Raspberry Pi Imager and the Official Openhab Site. That isn’t very difficult

wget localhost:8080

If the return code is 200 OK, the server is running and the problem is somewhere else.

Hi, I solved the problem by NOT connecting a keyboard or an HDMI cable to the Rasoberry Pi. After an hour, Openhab was available via openhabian:8080 and I was able to start setting it up.

There’s an caveat in the docs for manual installation and openHABian: after downloading all the stuff, the system needs to configure everything, which can take some more minutes and a reboot.
But again: if you’re using an Raspberry Pi, use openHABian!

PS: pluggin in external hardware does NOT have any impact to the OS - or even openHAB.

But it does for the openHABian image. Sometimes if the keyboard is attached it gets stuck at that first login asking to create a new user that Raspberry Pi OS does now that they’ve removed the default pi user. At least that’s my understanding based on following threads where people have run into this. That’s why the openHABian docs say to run headless for that initial setup.

ok. Strange. I can’t think of a LINUX-OS reason for this - but then again, I’m no sysop and AFAIR I did install some openHABian images with a keyboard plugged in. Admittedly not the last times…

I think it’s not a Linux reason so much that it is a Raspberry Pi OS reason. Until relative recently it would just install and boot with a pi user with a default password. Now, on that first boot, it wants to give you the option to create your own user instead. However, it appears to be smart enough to only do so when there is a keyboard attached.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.