No customized icons on Habdroid (OH2)

Is it a know limitation that the Android app doesn’t show customized (vector) icons?

It works if you put them in the classic icon folder.

In my combination (OH2, svg and app) this doesnt solve the problem.
Putting them to the classic icon folder made it possible to see it via “normal” web access, but not for the app.

Have you tried to use .png?

No, I didn’t try png as I want to use svg instead :wink:
And svg working on the web version


Besides this problem (I’ve tried with .png images too), I’ve found another strange behavior of HABDroid I’m not sure if this was the case before, but with this version dynamic icons would not work if you have mappings in your item label. I’ve tried this with a Switch item with mappings ( ON=Da OFF=Ne) and icon, but HABDroid displays only an icon for ON state, no matter what state the item is in. If I remove [MAP(] from the item label, dynamic icon works. The mapping does not have impact on dynamic icons in Classic UI, and they work properly.

P.S. I’m using OH2 nigthly from 21.10.2016.

Best regards,

for OH2, HABdroid fetches png icons from the icon servlet ( I don’t know the best way to change it, maybe adding a configuration what format to use? Of if it is possible to ask the server what format to use (same as basic ui?)

The issue with HABdroid not fetching the correct state icon for mapped value is probably the result of



Thank you for your help. I’ve tried searching, both this forum and google, but the only thing I’ve stumbled upon was this topic. The issue you’ve linked describes the problem I’m facing with dynamic icons. And, as they said on the github, the problem is REST item state, which displays transformed state in OH2 (in my case “Da”, “Ne”) instead of an original value (“ON”, “OFF”). I’ll keep an eye on this github issue. Thank you once again.

Best regards,