No devices found with private cloud and Alexa skill

Hi everyone,

I’m in the process of swithing from to a private server.

Openhab Cloud is working. My Openhab instance is connected to it and I can access everything remotely via the app.

I have setup the Alexa skill and it appears to have all gone well, except no devices are found.

It seems similar to [SOLVED] Problem with (Own) Cloud and (Own) Alexa Skill, but I have triple checked and I’m using English AU and my Lambda is in us-west-2.

My lambda is also being invoked each time I tell Alexa do ‘discover devices’.

I’ve tried linking and unlinking the skill and have done so via both the ios app and the Alexa website.

I followed this to set it up and used the Docker Compose option.

Does anyone have any ideas?

Let me know if you need more details.

Forgot to mention…it was working with
In my openhab instance, the only thing I’ve changed is the baseurl in openhabcloud.cfg.

Did you See http requests in your local cloud when invoking Alexa? And double check that there is no group without a name because then Alexa wont find any Devices…

Thanks for the reply. I can see http requests appearing when I ask Alexa to discover devices.

I switched back to and devices were discovered without issue, so I believe my item config is all correct.

I deleted everything (openhab cloud and alexa skill) and started again, hoping I’d just missed a step somewhere, but the same thing is happening.

The lambda is running without error, but there’s no clues in the logs.

Any other ideas?

So when you are living in AU, the “next” lambda zone would be ap-southeast-2, wouldn’t it be?

According to this,, you need to use us-west-2 when using English AU.

This is also confirmed in

All sorted.
Turns out I had missed a step to update the base url in a config file in the Alexa skill.
As a result, it was defaulting to, not my Openhab Cloud instance.

Adding the issue below for reference