No login into Amazon/Alexa (Binding)

I just install the “Amazon Echo Control Binding” via Paper-UI and “Add on”,
and create a small amazon,things file.

But the provided link to http://openhabianpi:8080/amazonechocontrol/account1
will not work:
After entering the mailadress and the password I get: “There was a problem”.

I already activate the 2F authorization, also checked my mailadress/password: In browser I can login into

I also remove the binding and re-install it, but still the same :frowning:
Any further ideas? Any basic mistake on my side?

In the log I find this (but maybe this is “normal” until" the first successful login in Amazon Alexa vom oH)

2020-11-17 15:19:02.662 [hingStatusInfoChangedEvent] - 'amazonechocontrol:echo:account1:echodot01' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2020-11-17 15:19:02.666 [hingStatusInfoChangedEvent] - 'amazonechocontrol:account:account1' changed from OFFLINE (COMMUNICATION_ERROR): POST url '' failed: Bad Request to UNINITIALIZED
2020-11-17 15:19:02.692 [hingStatusInfoChangedEvent] - 'amazonechocontrol:account:account1' changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)

The amazon.things file is this:
Bridge amazonechocontrol:account:account1 “Amazon Account” @ “Alexa” [amazonSite=“”, email="", password=“MEIN-PW”, pollingIntervalInSeconds=60]
Thing echo echodotwz “Alexa (Wohnzimmer)” @ “Alexa” [serialNumber=“G090LxxxxxxxxxGS”]

We started having issues with Alexa last week on our openHAB as well (has been working OK for almost a year until now). When asking an Echo device to do something (example, turn off the bedroom lamp), we get Alexa telling us the generic “Master bedroom lamp isn’t responding”.

Today I finally logged into openHab to try and troubleshoot, and I am seeing a similar issue where my existing Amazon Account binding now has an error (shown in PaperUI) of

Status: OFFLINE - COMMUNICATION_ERROR POST url '' failed: Bad Request

Thinking maybe it just needed re-authentication, per I visit my local page at which does show me the Amazon login page, but I get the same error as you with “Enter a valid email or mobile number”.

Maybe Amazon’s login API changed?

Edit: For grins, I logged into the Alexa “management” website at and Disabled the OpenHAB skill, then re-enabled it. It did correctly ask me to login to OpenHab, then kicked me back to the Alexa website.

I can see under Smart Home -> Devices in the Alexa site there is a new group listed that I just created today - so Alexa is able to see the devices and groups OK from within OpenHAB.

However, back to my local OpenHab at, click my Account, then try to login, I still get the “invalid account” message.

It appears Alexa (through the skill) can connect to OpenHab, but OpenHab can’t connect to Alexa any more.

Finding some related discussions such as here and here about Amazon login APIs changing, then checking my own install, realizing I’m behind a little bit on updates as well (2.5.5)

Currently updating everything and will test again.

OK, update worked for me. Now running openHab 2.5.10 (including Amazon binding to match of 2.5.10), and was able to successfully get past the Amazon login screen this time.

Same for me — after some issues (must change owner from config files (things, itemsrules), before it was OK),
Now I can pass the login screen from Amazon … must testing deeper …

Hello, i tried to use the blinding today.
However after updating openhab to 2.5.10-1 and installing amazon echo control binding version 2.5.10, I always end up at the amazon log in screen.
After entering mailadress and password, a screen for authentication shows up to inform me a access notification was send to my smartphone. This screen jumps back to the login screen after ~5seconds. Even after confirming the notification on the smartphone the same procedure starts again :frowning:
Can someone help?

Edit: I just created a new amazon account and registered for the 30 days free prime and added my echospot to this account.
The login to this account works, no request to a 2 step authentication (also there is no phone number registered to the account). However the echospot shows up in the list, but is marked as “offline” all the time …