No Motion after update to 2.1 release version


This weekend i upgraded my raspberry to the newest OH2-Release-Version and then cleaned the folders /var/lib/openhab2/cache and /var/lib/openhab2/tmp.

Evrything works fine, but not the Homematic device “HM-Sec-MDIR-2” (its a motion detector).
I also have other homematic devices within oh2 and they also work!

The motion detector is ONLINE in PaperUI…i dont have entries withing openhab.log.
Nevertheless the motion-item never switches to ON and so my rules dont get triggered.

With the old oh2 version (2.0.1 or so) evrything works fine.

I already tried to delete and reinstall the detector in oh2-paperUI AND in homematic-webUI.
Issue stays the same.

Now i switched back (have a backup of the sd-card of the raspberry) to the state bevor i did the update…works great again.

Maybe someone knows a simple trick or something else to get the detector working with newest release?

Thank you!!

Hi…i just realized that the binding writes “no description” for the detector:

Supported Things

Homematic Bridge
The Homematic bridge represents a Homematic gateway

Wireless Wall Thermostat
Wireless Wall Thermostat (HM-TC-IT-WM-W-EU)

Gateway extras, variables and scripts
Gateway extras, variables and scripts (GATEWAY-EXTRAS-CCU)

Virtual remote control (wireless)
Virtual remote control (wireless) (HM-RCV-50)

No Description
No Description (HM-Sec-MDIR-2)

Wireless Switch actuator with power measurement
Wireless Switch actuator with power measurement (HM-ES-PMSw1-Pl)

Maybe usefull information?


Yesterday i tried a complete purge and then a fresh instalation of oh2 on the raspi (before i just made an upgrade).
Issue is the same (i purged again and instaled again
Would still be very interested in newest version of oh2 but need also the motion detector.

push 2

Hi @asdfasf_adfas, I have no experience with the homeatic binding but if it’s working on one version, but not another it sounds like a bug. Have you Concidering making a bug report at:

First things to try beforehand, are there any new errors or warnings present in the log files? These might come up when the device tries to send an update or only when openHAB is restarted.