No negative values for HEM-G2 Home Energy Meter

I have installed a AEON Z-Wave Clamp Power Meter 2nd Generation, which works fine for measuring my solar panel output and energy consumption. However, when my energy generation is larger than my consumption, my consumption should show negative values, which is not the case. In one of the many different manuals of this device I have found that you could change this behaviour by setting parameter 2. I am not able to set this parameter in HABMIN, it starts with parameter 3. Is there a way I can play with this parameter ?

I also am very interested in this feature because i would buy the home energy monitor.
Do you understand how to fix it?
Thank you in advance!

No, I did not found a solution for it. I am working on some kind of “intelligent” analysis which determines if I am producing or using energy, based on the change in consumption, but that’s quite difficult…

I would try with, which gives you opportunity to access directly the zwave device.

Please note that this HEM has a bug and power consumption is three times higher than in reality (comparing to utility company meter).

My workaround:

rule "calculate power"
    Item HEM_E  changed or
    val vE  = HEM_E.state as DecimalType
    val Energy = vE.floatValue / 3
    postUpdate(E, Energy)

where HEM_E is energy reading returned by HEM and E is the item displayed in openHAB.

!? really?
but it is a known issue?
@murk_van_rooijen do u have the same problem with positive value?

In the xml file there is the configuration for the second parameter:

<Value type="list" index="2" genre="config" label="Reverse Clamping" units="" min="0" max="1" value="0" size="1">
  If the reverse clamping pliers, negative power is detected. 
  <Item label="Disable" value="0" />
  <Item label="Enable" value="1" />

which version are you using?
Try with the last:
(use 1.8.0 snapshoot)

Can someone provide the reference to the manual and I’ll take a look at adding this parameter. There may be different software versions though since the parameter 3 that’s in the database does not correspond with the definition in this post… I’d therefore like to double check…

@khael87: I don’t have any issues with the value the HEM is reporting. I have read stories of people connecting a three-wire system to individual power lines and thus reporting one third of the value, but for the one @JjS is using it sounds the other way around . I have 2 one-wire HEM’s installed on two different power lines which work great.

@khael87: I was indeed using 1.7.1 and now updated tot 1.8.0 snapshot. I don’t see the configuration for the 2nd parameter in the xml file for my node. It starts with the 3rd parameter

@chris: this is a reference I have found:

Thanks - it looks like it’s probably the same, but there are a number of missing parameters and a couple that are just different. I’ll add parm 2 anyway.

1 Like

@chris: Great ! Looking forward to test it. When do you expect that an update of the binding will be published ?

It should already be compiled - it’s normally done every night (except when it’s broken). I’ve not checked cloudbees to see if it compiled last night…

@chris: I updated tonight to ZWave binding… but i don’t see param 2 in the configuration parameters. I also deleted the node8.xml from \etc\zwave before starting, but this also does not change the configuration options when running. Am I missing something ?

No - sorry, I forgot to merge the PR - I did it earlier this evening so try again tomorrow…


I discovered it comparing the HEM kWh readout with the official utility company meter. The HEM was much higher, but fortunately there is a pattern in this error (x3). Maybe it is due to the fact it is three phase device.

I’ve found similar comments on some other forums (domoticz as far as I remember.

@chris: The good news is that parameter 2 is working: it’s reversing the output of the measured value. Thanks for updating

The bad news is that the energy meter does not distinguish the direction of the current flowing, it’s just adding the negative sign in all instances. Handy if you connected your power meter clamp incorrect and you don’t want to re-open your power box. For me it wasn’t the solotion I was looking for.

Thnaks again for updating, great service !

i bought a HEM-G2 and it works correctly.
Report the true power consumption and negative value works correctly!

Hi @khael87, @chris

i have been trying with aeotec energyt meter 3 phase and 4 wire,
it is excepted that it should report 4 types of reading

  1. total energy consumption
  2. Separate per phase energy consumption.

I want know how to map this in wave.items file for getting per phase energy values.
Can anybody tell me what should be correct entries in wave.items file for 3 phase 4 wire aeotec energy meter.

Thanks in advance,

Hello :slight_smile:
All works correctly for me; this is my item file:

Number HEM_E “Energy [%.0f kWh]” { zwave=“20:command=METER, meter_scale=E_KWh, refresh_interval=3600” }
Number HEM_PP “Potenza ist.[%.0f W]” { zwave=“20:command=METER, meter_scale=E_W, refresh_interval=30” }

Number HEM_E1 “L1 Appartamento [%.1f kWh]” { zwave=“20:1:command=METER, meter_scale=E_KWh, refresh_interval=3600” }
Number HEM_E2 “L2 Casa [%.1f kWh]” { zwave=“20:2:command=METER, meter_scale=E_KWh, refresh_interval=3600” }
Number HEM_E3 “L3 Energy [%.1f kWh]” { zwave=“20:3:command=METER, meter_scale=E_KWh, refresh_interval=3600” }

Number HEM_P1 “L1 Appartamento [%.0f W]” (gDashboard) { zwave=“20:1:command=METER, meter_scale=E_W, refresh_interval=30” }
Number HEM_P2 “L2 Casa [%.0f W]” { zwave=“20:2:command=METER, meter_scale=E_W, refresh_interval=30” }
Number HEM_P3 “L3 Power [%.0f W]” { zwave=“20:3:command=METER, meter_scale=E_W, refresh_interval=30” }

Number HEM_V1 “L1 Appartamento [%.1f V]” { zwave=“20:1:command=METER, meter_scale=E_V, refresh_interval=600” }
Number HEM_V2 “L2 Casa [%.1f V]” { zwave=“20:2:command=METER, meter_scale=E_V, refresh_interval=600” }
Number HEM_V3 “L3 Voltage [%.1f V]” { zwave=“20:3:command=METER, meter_scale=E_V, refresh_interval=600” }

Also negative value works correctly!

thanks khael

@khael87 does it reports negative values with default configuration…? OR need to do any configuration