No success Trying to create zwave device

First post. sorry in advance for bad practice.

On trying to incorporate rather new device from Logic Group, Device ZSO7300, I found that the device is not in the database. have been looking at the XML file for the node for trying to understand the basics and adapting the device to suit openhab by the XML file.

After looking the web for cd.jackson where most threads link to, I came across the new opensmarthouse.org for what ive read “Help on creating XML file” but it seems to be incomplete or not fully functioning since i cant upload anything when creating a ticket, just get an error message everytime i try to do anything there, (And no. i don’t have strict cookie settings)

Is there any documentation available for creating Z-wave devices into the existing database of my system?

I can’t seem to find any information.

Adding the device to your own binding jar is difficult and requires recompiling the binding from scratch yourself, if I recall. Simpler just to follow the directions on the database site from the top to add the device to the database and wait for the weekly compile that will include the new device. Here is the doc for contributing to the database:

I would be more than happy to do so, but the site is not working for me, even created a new user and still get error messages when creating a ticket or updating a ticket, tried from multipple browsers but no luck.

To use the database you must first register on the site, then email, or open a ticket to have your access updated to allow you to edit the information. Please avoid adding comments to this page or other pages to request access or discuss issues. The comments section is to help provide a record of changes, or device issues and shouldn’t be used as a forum as it is not read routinely.

Having an account and having access to the database are two different levels of access. Can you even create the simple ticket to request the upgraded access permissions (don’t try to upload anything yet)?

Hi JustinG Thanks for the answer.

The guide states open a ticket and i did so, but bothing happened since, but even the first tickest punches in with “failed tro create ticket, Internal servor error” Does the ticket need to have a specific Headline/Subject, if so I cant seem to find this in the Guide anywhere.

Interesting. OK, sounds like we need to ping @chris so he can take a look at your account and see what’s up.

After a while i see the tickets for each time I pressed submit, Ive read in a different thread about cookie settings in the browser and i have those settings completely disabled. even the newly created account came with the same error when creating the first ticket, but i still see the ticket afterwards.

Sorry - the MySQL server on the web site had a memory problem and that seemed to cause some issues with tickets and some other services that I hadn’t noticed until I saw this this morning. I’ve now restarted the server which seems to work again (I think) and have updated your access.

Hi Chris no worries.

In the mean time i got access maybe because you fixed the server… I now have tried once to create new device and pasting the xml from OH into the field “XML” but it throws a error when submitting. is the server still down or am i missing somthing?

Please provide the information showing what you are doing so I can see if it’s correct. As far as I know the server is working ok - I’ve not seen any issues since I restarted yesterday and I’ve approved a few devices this morning and set up some access. I’ve not tried to create a new device though so I’d need to know what you’re doing and see the information.

Hi @chris Chris.

Ive posted the issue in a ticket on “opensmarthouse.org” including screenshots.

The XML that you have provided is incomplete. The device has not initialised so the XML doesn’t contain most of the information about the device so you can’t create an entry with this file.

Once initialisation is complete the file will contain a lot more information (hopefully) and the device ID and type, and manufacturer ID, will not be 0x7fffffff.