No Wlan Connection after update

after trying to update to the newest OH 3 Version (I have 3.1.0 now) and after reboot my system can´t connect to wlan anymore.

ifconfig shows lo: flags […]

Ethernet was not working too, so I put via

sudo nano /etc/network/interfaces


auto eth0
iface eth0 inet dhcp

Now Ethernet is working and getting a ip via dhcp but I can´t connect via wlan.

I tried to use openhabian-config and wlan - nothing is changing

Any solution? Thank you

You may either use Ethernet or Wi-Fi but not both. On openHABian that’s untested (and there is no point in doing that anyway).

You also must not mess with manual configuration outside openhabian-config (you probably did if you had both interfaces working before).
If you manually change config and things don’t work, be fair and don’t ask for help, please.

Given noone but you knows what you changed on your system, I’d install from scratch to get on the safe (standard) side.

Hi Markus,

thank you for your answer, but I wasn´t able to get any connection. Yes, I used keyboard and Monitor first and go to the openhabian-config to get wlan connection.

The “nanoring” only to check if there is conection via ethernet, because was not working, too after reboot. All my changes are written down, so I went back to early station of the interfaces text.

Ok -start again:

After upgrade the system -no wlan is working. I tried:

  1. Use screen and keyboard on Rasp Pi4 to connect wlan via openhabian-config (checked spelling etc. of SIDD and the Pass. Not working

  2. Reboot with Ethernet connection no ip no connect (is working normally with diffent IP)

  3. Tried connect with changing the file. Then I getting a IP, but no wlan via SSH and openhabian-config, so bringing file back to the starting point.

  4. I tried a backuped SD Card with an 3 month older version of openhabian and wlan is working - so I know it´s not a hardware issue.

I´m using Raspberry Pi 4 with 4GB

Are there any solutions or somthing I could try to bring wlan back?

As I said: install from scratch (i.e. flash again! to some new SD of course).
Use the latest openHABian image.
It will fire up a hotspot when it gets no connection to the inet so you will not need any keyboard.

Mhmmm is one more miracle. I used a backuped SD, but w-lan was not working, too.

No change with configuration via oh-config.

Yes I know you told me that ethernet and Wlan not working together, but last change was to plug ethernet cable in while booting and then Wlan was working well.

Thanks for help

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.