No ZigBee devices show when scanning

I’m trying to connect several Zigbee devices with no luck. I’ve followed the instructions to setup the Zigbee binding and coordinator. Have Ember EM35x Coordinator installed and OH says it’s online.

I have several zigbee light bulbs and hue switch/dimmer and some xiaomi devices, none of which show up when I scan for zigbee devices. I’ve enabled zigbee debug logging and can’t see any errors etc.

I’m new to OH anf zigbee, how do I start debugging this? Is there a way to confirm the devices are actually sending a signal?


Hardware: Raspberry Pi 3 B+, Elelabs ZigBee USB Adapter
OS: openhabian
openHAB version: 2.3.0

If they have been added to another zigbee network before, then you´ll need to reset them, and then active their discovery.
For Hue Dimmer Switch… use the very little pinwhole on the behind. Press it and keep it pressed for 20 seconds (until the light flashing on the front). Then it´s reset.
After that, shortly press and release the pin, and it goes into discovery mode. Then start your zigbee discovery PaperUI.

For the light bulbs, you need to reset them as well. If you do not have a Philips Hue bridge, search the internet for solution… If you have them added to a Hue switch, just delete them using the Hue App.

Resetting Xiaomi devices use the same procedure as the hue dimmer switch…
BUT! I have not had much luck adding Xiaomi devices to my Zigbee network. I have given up trying. Insted I use the Xiaomi gateway.

Hi Kim thanks for reply!

All the devices are brand new. I’ve been pressing the pin-hole button on the back till the light flash on the dimmer switch, tried this maybe 5-6 times. I’ve also reset the lights (these ones you have to turn them off-on 10 times then they flash) a couple of times with no luck. I’ve also ordered the gateway so not too worried about the Xiaomi devices. I’ve also restarted the Rasp Pi a couple of times.

Is there something I can search for in the logs to see if it’s even trying to connect to the devices? I guess since this is all new hardware I don’t know where to start to debug the situation.

When you want to discover the device (hue dimmer switch) you only press the pin button once (short press).

Start by enable debug logging.
I have almost the same hardware.
Rpi 3B
Elelabs Zigbee Rpi Shield
OS Openhabian with openhab 2.3 release.

Hi Kim, yep I’ve done that already, the problem is I have zero idea about what the zigbee log entries mean. By looking at the log entries, how would I determine if there’s a problem with my RaspPi/Zigbee/OH setup or the devices? Should I post the log here?

When I get home I’ll try the hue switch witha single quick press, pretty sure I was holding it down for multiple seconds each time I tried it before.

The log will be pretty big, so you might have to use a cloud or something and then link to it. (Look in the Zigbee binding thread).
Look for something about discovery

If you hold the button pressed too long, you´ll be resetting the device over and over again :wink: