NODE 4: Unsupported command class SWITCH_ALL

Whenever I start openhab I get the following error: NODE 4: Unsupported command class SWITCH_ALL

In the habmin in Configuration > Bindings > Devices, I am unable to see any node.

I tried connecting Aeon Labs Gen 5 USB with Aeon Labs smart in -wall switch. And as per the documentation both connected. I pressed button on USB for 1 second and it started blinking slowly. When I pressed button behind the switch the light blinked fast and was static for a few seconds and then started blinking slowly. As per the manual that means the both devices are now sync. I added following configuration to .items files

Switch LightRoom “Room Light” (Lights) {zwave=“2:1:command=SWITCH_BINARY”}

I noticed a newer version is out. if you think I should upgrade to the newest version, is there a way to save old .conf file so that I don’t have to set it up again after updating?

I am using Aeon Labs Gen 5 USB. Following is the log:

2016-02-09 16:33:28.581 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.7.1).
2016-02-09 16:33:33.776 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-02-09 16:33:34.236 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-02-09 16:33:41.984 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'default.sitemap’
2016-02-09 16:33:42.834 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'mysql.persist’
2016-02-09 16:33:43.056 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'default.items’
2016-02-09 16:33:43.295 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, port = /dev/ttyACM0
2016-02-09 16:33:43.297 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, healtime = 2
2016-02-09 16:33:43.300 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2016-02-09 16:33:43.406 [INFO ] [b.z.i.protocol.ZWaveController] - Starting Z-Wave controller
2016-02-09 16:33:43.408 [INFO ] [b.z.i.protocol.ZWaveController] - Z-Wave timeout is set to 5000ms. Soft reset is false.
2016-02-09 16:33:43.409 [INFO ] [b.z.i.protocol.ZWaveController] - Connecting to serial port /dev/ttyACM0
RXTX Warning: Removing stale lock file. /var/lock/LCK…ttyACM0
2016-02-09 16:33:43.640 [INFO ] [b.z.i.protocol.ZWaveController] - Serial port is initialized
2016-02-09 16:33:47.143 [INFO ] [rialApiGetInitDataMessageClass] - NODE 1: Node found
2016-02-09 16:33:47.144 [INFO ] [rialApiGetInitDataMessageClass] - NODE 2: Node found
2016-02-09 16:33:47.145 [INFO ] [rialApiGetInitDataMessageClass] - NODE 4: Node found
2016-02-09 16:33:47.147 [INFO ] [rialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2016-02-09 16:33:47.148 [INFO ] [rialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2016-02-09 16:33:47.149 [INFO ] [rialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2016-02-09 16:33:47.150 [INFO ] [rialApiGetInitDataMessageClass] - # Nodes = 3
2016-02-09 16:33:47.151 [INFO ] [rialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2016-02-09 16:33:48.384 [WARN ] [.o.b.z.i.p.c.ZWaveCommandClass] - NODE 4: Unsupported command class SWITCH_ALL
2016-02-09 16:33:48.680 [WARN ] [.o.b.z.i.p.c.ZWaveCommandClass] - NODE 4: Unsupported command class SWITCH_ALL
2016-02-09 16:33:51.351 [WARN ] [.z.internal.ZWaveActiveBinding] - NODE 4: No item bound for event, endpoint = 0, command class = CONFIGURATION, value = org.openhab.binding.zwave.internal.protocol.ConfigurationParameter@8dc477, ignoring.

All information for upgrading (and saving your config files) you will find in the release notes.

That’s strange, because in your logs the zwave binding is recognizing your three nodes.

For your error message “NODE 4: Unsupported command class SWITCH_ALL” see this discussion:
Continuing the discussion from ZWAVE strange messages in log:

Thank you for pointing to release notes.

Yes that is indeed strange. I thought maybe it is because of this Node 4 error because of which it is not showing me anything.

As for the link I saw the discussion on that post but couldn’t make anything out of it. It all sounds too alien.

At least it should not be the problem of not seeing any nodes in habmin …

Here is the screenshot. Don’t know if it would be any helpful

Check this post and make sure you are using the correct folders:

Continuing the discussion from OpenHab 1.8 and Habmin:

Thank you for your response. I decided to delete my earlier installation and re-install using the manual method. I am installing in folders as per your post. I shall update about the developments once I am done re-installing.

Quick Question while I am re-installing. Should I stick with HABmin or should I install HABmin 2?

For oh 1.x you should stick with habmin 1.

Ok this is interesting. I deleted Openhab and assumed HABmin will get deleted by itself since it is in addons & webapps directory of openhab folder. But when I open the browser it still works. I thought maybe it was in cache or something so I restarted the raspberry but still I am able to access the link. I even tried to see /usr/share/ folder to see if openhab existed there but nope it doesn’t exist there either. How do I delete HABmin? Where could it be possibly installed?

As I can see on your screenshot you are using a vnc viewer, so easiest way (for me) would be to look for “habmin”, starting with your root folder …

Maybe the linux find is faster, but vnc viewer is easier :sunglasses:

I just don’t know what to say! It is unable to find any such folder.

I have no idea whats going on at your place … have you hidden a second RPi somewhere? :grinning:
To be honest: I’m out of ideas :joy:

Hahaha @ second RPI! Can you suggest a tutorial on how to reinstall the OS on raspberry?
I currently have Linux Raspberrypi 4.1.7 GNU/Linux

I do it with this page (but on Win, not on OSX).

But please note: the page link goes to Raspbian, not to your original operating system …

It was probably in cache or something because once the IP changed of raspberry no more able to access habmin. However, I reinstalled Openhab and now a new problem has occurred.

2016-02-10 07:50:39.832 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, port = /dev/ttyUSB0
2016-02-10 07:50:39.834 [INFO ] [.z.internal.ZWaveActiveBinding] - Update config, healtime = 2
2016-02-10 07:50:39.845 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been started
2016-02-10 07:50:39.943 [INFO ] [b.z.i.protocol.ZWaveController] - Starting Z-Wave controller
2016-02-10 07:50:39.945 [INFO ] [b.z.i.protocol.ZWaveController] - Z-Wave timeout is set to 5000ms.
2016-02-10 07:50:39.947 [INFO ] [b.z.i.protocol.ZWaveController] - Connecting to serial port /dev/ttyUSB0
2016-02-10 07:50:40.065 [ERROR] [b.z.i.protocol.ZWaveController] - Port /dev/ttyUSB0 does not exist
2016-02-10 07:50:44.847 [INFO ] [.service.AbstractActiveService] - ZWave Refresh Service has been shut down

lsusb returns following
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 005: ID 0658:0200 Sigma Designs, Inc.

Yeaah, the beginning is sometimes horrible … :joy:
If you are using Raspbian and have only one usb device connected to your Pi with a 99% percent chance the correct port is /dev/ttyACM0
There are some linux commands to find out (I have to look them up or you will find them here in the forum), but the easiest way for me was to find the port:
Look into folder /dev and find the tty* with the newest date and time stamp. This is the correct port for your z-wave stick. In most cases all the other tty* devices have a time stamp from the last reboot.