Node-red and OH3.3 not playing nicely

I’m having a problem with my node-red openHAB setup. I’ve used node-red as my rules engine for years with no issue. I recently updated to openHAB3.3, and when I did, the old OpenHAB2 nodes stopped working correctly.

I knew this time would eventually come, and that I’d need to update my node-red flows to use the newer version of the openHAB nodes that were updated to support OH3. So I did that. I replaced the old OH2 nodes with OH3 nodes… and it’s still not working.

My “get” and “output” nodes all work fine. I can trigger my flows manually with injection nodes, timers, etc. But none of my OH “in” nodes are working correctly. When initialized, they will pull the current state and display it correctly beneath the node. But, when an item changes state, its respective node doesn’t reflect the change, and no payload gets sent.

The upshot is that no event in OH can trigger a flow, even though the flows are able to send commands to OH.

I’ve rebooted.
I’ve double-checked that the nodes are configured to the correct server.
I’ve updated node-red.
I’ve stopped OH, cleared the cache, and restarted OH.
I’ve check my OH logs (via Frontail) to confirm that the events are, indeed occurring… And they are.
I’ve tried each of the “send initial”, “send changed”, etc. options on the node, but still nothing. (I’m assuming that “send changed” is the correct option, since the logs show “ItemStateChangedEvent” for the events that I’m trying to capture.

Is anyone else having problems with node-red and OH3.3? Any ideas on what else I could try?

You are not the only one experiencing this. There is a tread in the main 3.3 release topic covering this:

Drat. I should have read through that discussion before updating. Looks like there have been some API changes.

The developer of the OH3 nodes just posted a fix on his end. I’ll give it a go and report back…

EDIT: It’s fixed! For anyone else with issues getting node-red to see incoming events, be sure to upgrade to version 1.4.1 of node-red-contrib-openhab3 .

EDIT 2: It’s inconsistent. It was working, and then after an hour or so, it stopped working. I restarted node-red and it started working again. We’ll see if it stops again…

FINAL EDIT: I updated to 1.4.2 and restarted again. Looks like everything is working consistently again.

1 Like

I still seem to have this issue. (Node Red In-Node2 Nodes only updating once after flow start).
Im running:

  • OpenHAB 3.3 on Docker
  • Node Red 3.0.0 on Docker
  • Node-Red-Contrib-Openhab3 in 1.4.2
  • All Nodes are update to *2 Version and (node-red-contrib-openhab2 is removed)

Any hint what I might be missing ?

Sorry My fault. I found a openhab2-controller2 Node that was not yet set to “V3”.
After Updating works like a charm !

1 Like