Nortek HUSBZB-1 Ember Coordinator - Serial Error: Port /dev/ttyUSB1 does not exist

Tags: #<Tag:0x00007f434af7f988>

Well I now have Buster installed on t=he SD card. Now to get openHABian & the testing version.

FWIW I confirmed that it worked my old OH2.3 setup.

I did need to install the old serial binding 1.12.0 to get it working. Never needed that binding with my Aeotec stick for z-wave

I guess I could install the latest snapshot on my OH2.5.0.M4 system?

You could but that is rather radical just for one binding. I was going to try the Zigbee manual install script first to update just that binding.

Roger that. I appreciate all of your help!

Well, that is disappointing! I used openHABian ( with Zulu workaround) to install Milestone 4. I then installed HABmin, zwave, & Zigbee after choosing a Standard install.

I think the serial port not existing is from when you first choose the stick and cannot select a serial port.

Using Rich’s settings, like last time, & both Z-Wave & Zigbee are now inline

Any ideas?? Same hardware (except OS disk). SD card is running the newer Buster just like the OP of this thread.

I am happy to help. I am fortunate enough to now have a stick for testing.

@brianlay Try using the manual install script to update the Zigbee binding. It may fix your system.

OH needs to be running when you update so the script can uninstall the current binding.

Add to the mystery. I am running Milestone 4. I used Scott’s script to install a snapshot Z-Wave binding. I now get the ZigBee serial port error.

EDIT: I used the same script to install the ZigBee snapshot & the serial transport and got the same errors. Restarting openHAB seemed to clear up the errors.

@5iver may have some additional insight. I also noticed the script (version 1.2.3) could not uninstall either Z-Wave or Zigbee from Milestone 4. Uninstalling through Paper UI first permitted the script to run successfully.

EDIT2: My latest theory is possibly the order binding start up may have an impact. I will need to test, possibly this evening,

Into what?

Please report issues for the script in its topic or in GH.

I thought you might have some ideas on the issue here based on your experiences with ZigBee & Z-Wave,

I currently am able to test out theories on this test system. Should I choose to add ZigBee devices into production, I might lose that capability.

With Milestone 4 & snapshot Zigbee & Z-Wave bindings:
When a system starts, if Zigbee starts before Z-Wave, it is OK. Once Zigbee fails it does not batter if Z-Wave is running or not.
Zigbee debug logging did not help. I think I need to turn on logging for the serial port.

EDIT: Same behavior with full snapshot install from yesterday. Updating to the latest snapshot is not a solution. Just restarting the zigbee bundles from the console breaks it until OH is restarted.

@chris
Any guidance on how best to troubleshoot this reproducible issue? It appears of this Zigbee tries starting after Z-Wave, it cannot find the port. Stopping Z-Wave & restarting the Zigbee bundles does not help. Only restarting OH seems to clear the issue if zigbee starts before zwave.

I can reproduce this issue on my test system with Milestone 4 & later bindings.

There should not be anything in the binding that should impact this - it might be an issue with the drivers or something outside of the binding. Are all ports defined on the command line options?

The port is OK and functions when it works. Restarting my he ZigBee bindings breaks OH access to the port even though it is a selectable option in HABmin.

Sorry to ask again, but are the ports defined on the OH command line options?

Otherwise I don’t know why this would happen. It should not be anything to do with the ZWave binding at least as that only opens its own port.

Sorry, I am not familiar with doing that so it must be whatever is default. Where would I check or define this? I did not see anything in /etc/default/openhab2.

If I remember correctly it’s in the main openHAB installation docs.

I also found it described here-:

https://www.openhab.org/docs/administration/serial.html

I’m not sure if it will help, but the driver uses this to work out what ports are available. I think without this it might do some sort of scan, which might cause problems. Otherwise, I’m not really sure what else to look at.

Thanks Chris.
Something there might be worth a try. I will need to look later today.

EDIT: I tried quickly and have some success. Here is what I added to EXTRA_JAVA_OPTS in /etc/default/openhab2.

 -Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyUSB1

@brianlay would need to add their Z-Wave serial port too. It should be tested with vanilla Milestone 4. That is the next step.

to make both my zwave and zigbee stick work I had to actually create symlinks for both of them as described in the link that @chris posted because just adding the ports to the extra java opts was not sufficient. This is what worked for me: Raspberry Pi - Make serial USB ports persistent via symlinks
but the whole thread is actually worth reading. Dont know if it will work that way with your stick as its two in one and I had two separate sticks but my problem was very similar otherwise.
Johannes

Adding the options seems like a workaround to me. Is your server a Pi?

Yes it’s a 3b+. Using symlinks is actually generally recommended in Linux when working with multiple USB devices I think as the operating system assigns port numbers in a different order on reboot or even when unplugging and replugging a device. I think this could be a culprit of a lot of problems people have when using multiple sticks on their pis. With symlinks you just make sure the software actually always finds the right device of multiple plugged ins. At least that’s my understanding.
Johannes