Nortek HUSBZB-1 (zwave and zigbee) not responding

Details: Ubuntu 19.10, Openhab 2.5.1, Zulu 8.42.0.23-CA-linux64, OH running under user “openhab”.

I would like to use HUSBZB-1 with OH. I have added groups dialout and tty to user “openhab”.

ls -l /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 Jan 31 21:13 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 Jan 31 21:13 /dev/ttyUSB1

I can add zwave binding in PaperUI, and I can get to the configuration page where I type “/dev/ttyUSB0” and the status of zwave will change to “online”, but no things are ever found with a zwave scan. Same with zigbee. At one point I was able to add the serial binding but that didn’t help.

I think the problem may be permissions. I was trying to send HUSBZB-1 a command by issuing the command:

echo “help” | /dev/ttyUSB0
bash: /dev/ttyUSB0: Permission denied

What commands can I send? Is this a valid way to test HUSBZB-1? I have a zwave device that has been connected to another network one foot away from HUSBZB-1, and I’m pushing the reset button on that zwave device, but it is never discovered.

I’m using: tail -f /var/log/openhab2/openhab.log -f /var/log/openhab2/events.log
to view the logs, but I only see startup and shutdown events.

I saw some forums talking about using text files to configure, but then no one actually displayed what the config file contained.

Thank you for your replies.

I have used that zwave controller successfully with OpenHAB. Exactly what installation instructions did you follow?

If using text files I strongly recommend still discovering Things. Please follow the binding documentation for when things do not go as planned and post debug logs.

That command tries to execute the device and, as the error states, there is no execute permission. Executing a device makes no sense anyway.

Which device? Does pushing the “reset” button hard reset the device and wipe it’s zwave network? Try setting the controller into exclusion mode (Habmin> Things> controller> tools> advanced) and then follow the device manufacturer’s manual to exclude the device (probably that reset button). If you don’t have the manual, you can find it in the zwave binding device database.

Let OH create the Things. For now, Items are IMO marginally better in files.

Since if the zwave controller is online, then everything should be OK, but there is not much logged by the zwave binding until it’s logging level is set to DEBUG.

I have two of these devices (one for production and one for test/backup). Once setup properly, they work great. People usually have more issues setting up Zigbee. Get your zwave sorted first, then we can go after your zigbee.

1 Like

I have found some devices, for some reason need to be factory reset before including on the network. Sometimes excluding them is not enough.

I have found that hard resetting does not always clear the zwave network, so exclusion is required to clear it. :slightly_smiling_face:

It needs to be excluded but I have found, with cheap Chinese devices and others, that they sometimes need a hard reset before they sanely get included again.

Have you looked to see what openhab.log has to say about it?

That might be normal enough if the openHAB binding is using the device at the time.

For sure.
Their command is trying to execute (run) /dev/ttyUSB0 which does not have execute x permission set.

Executing a device makes no sense anyway.

1 Like

Oh yes, I’d forgotten that point.

1 Like

Thank you for your replies.

How can I send HUSBZB-1 a command? What command could I send to see if it is working? Maybe the physical USB stick is defective?

I wanted to try Habmin> Things> controller> tools> advanced, but when I go to home (http://localhost:8080/start/index) I no longer have the Habmin square displayed there. I tried installing:

sudo apt-get install openhab2-addons-legacy
sudo apt-get install openhab2-addons
but that didn’t bring it back.

Are there professionals that I could compensate to get the initial setup working on my machine? I had a friend already try to help but that just made it worse.

Not that I am aware of. @chris is very helpful when he has the time.
I just looked and he has a donate link on his site. I would be sure to contact him first before assuming he has the time to help.

https://www.cd-jackson.com/index.php/about

You can’t. If you configure the device, you will see log entries that you can use for troubleshooting issues. To install Habmin, open Paper UI and go to Addons> User Interfaces> and select Habmin to install it.

The HUSBZB-1 is for use in the US. Are you in the US and is the device you are trying to connect made for use in the US? If not, the device is not compatible with the controller.

1 Like

Yes
Yes
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/71

Thank you. I have been working on this for a couple weeks. I value opensource but it is hard to explain to the wife why this much effort is better than a $150 hub that has worked for us before.

Scott, who replied above is one of our experienced Z-Wave users too.

OK… have you been able to install Habmin? If so, the zwave controller into exclusion mode and quickly press the button three times to exclude the device. After that, turn on discover for zwave and quickly press the button three times to include the device.

1 Like