Not all Z-Wave devices show up correct on new install

I lost me SD card and had to set up an existing Z-Wave network from scratch. I had backups of all of the configuration files and most of my devices showed up with the same information as before and all I had to do was name them correctly and add the required connections between Things and Items. All of that went perfect but I noticed a few missing Things and when I tried doing a search they all showed up with all the missing nodes, but they all show up as Unknown Devices. I’ve done everything I can think of to make them come back correct, but nothing has worked. I’m using the most current daily snapshot on a RPi 3 running Buster installed from the most recent openhabian image. I’d like to avoid erasing the Aeotec Gen 5 dongle as it would probably rediscover everything in a different order and I’d have to go on an expedition to figure out what everything is again. I was hoping to find some way to fix this sort of forgetting and re-adopting the 8 messed up devices.

Thanks, Ira

Are the unknown devices battery powered? If so, you need to wake them up, sometimes repeatedly, until the binding gets enough information from them to recognize what they are.

Thank you. It seems after getting them all back that they were all battery operated or unplugged. I’ve all but one back on-line and that’s a small cordless switch that’s currently lost. Somehow I figured the information about the device would have been stored in the dongle, but I guess it just keeps IDs and node numbers as they all came back with the same node numbers so restoring only a few files and a bit of work connecting things to items and it just worked.