Not work OpenHAB site

Good day.
I would be grateful for any help. I have Synology NAS, on which I put OpenHAB 2.3 to get familiar with its capabilities. Easily tuned control TV, set up access through the cloud “myopen”. Everything started to work without any problems. After a while, I began to understand the configuration and realized that during installation, the Configuration files are not accessible from the Synology shell, so I decided to reinstall OpenHAB and set up a different path to the files through the “/ public / openHAB” folder. Just released a new OH 2.5 and the version of Java8 SE requested to update it. And now, after reinstalling, openHaAB stopped working: ((. Since Synology runs on Linux 3.2.40 with the BusyBox 1.16.1 shell, the location of the openHAB files differs from the description in the documentation. Unfortunately, I’m not good at Linux, but I understood that the OpenHAB service is started (by going to /var/log/openhab-start-stop.log) also appears at startup, but the page is still not available in the browser. I tried to reinstall, change the port, change the user rights “openhab "- nothing helps. Tell me, please, where to look.

I can’t help much with synololgy but the first place to look are the logs. Look at openhab.log and what ever the equivalent of syslog is. Hopefully you will see some errors that might be informative.

Here’s my experience that I documented recently. Just ignore the restore parts of it since your probably coming in from scratch.

Best, Jay

Thank you gentlemen for the recommendations and detailed instructions.
Unfortunately, reinstallation in accordance with the instructions did not give new results - the service is still running, and the site is not available “ERR_CONNECTION_REFUSED”.
At the moment, I found only the magazine “/userdata/logs/openhab.log”. It is created during installation, but all the time is empty (.
Tried to run OpenHab (OH) so

NAS> ./
Launching the openHAB runtime …
./runtime/bin/karaf: line 362: command: not found
Java HotSpot ™ Embedded Client VM warning: G1 is disabled in this release.
Error occurred shutting down framework: java.lang.NumberFormatException: null
java.lang.NumberFormatException: null
at java.lang.Integer.parseInt (Integer.javainter42)
at java.lang.Integer.parseInt (
at org.apache.karaf.main.ConfigProperties. (
at org.apache.karaf.main.Main.updateInstancePidAfterShutdown (
at org.apache.karaf.main.Main.main (

I do not understand these messages(

I would like to somehow restore the status to the very first installation of OH, without disrupting the work of other services. I will look for more magazines.
If there are more thoughts, I will be glad.

Hi, I have similar situation with my Syno DS710+ (Intel Atom - DSM 5.2). My openHAB 2.4 is a brand new installation(openHAB-, where the service is up and running on DSM web interface, so it seems everything is fine, but the openHAB web interface is not reachable (http nor https). I have checked what happens under the hood. There is:

  • no running java process (ps command)
  • no running openhab process (ps command)
  • openhab pid file is empty (/var/services/homes/openhab/
  • size of @appstore/openHAB/userdata/logs/openhab.log is zero
  • openHAB-install.log is seems fine (there are no errors or problems in the log)
  • openHAB-start_stop.log is seems fine (there are no errors or problems in the log)
  • trying to start manually, get error message KARAF_ETC is not valid:

DS> cd /volume1/@appstore/openHAB/
DS> ls
LICENSE.TXT conf runtime userdata
addons start.bat start_debug.bat ui
DS> ./
Launching the openHAB runtime…
./runtime/bin/karaf: line 362: command: not found
KARAF_ETC is not valid: /volume1/@appstore/openHAB/userdata/etc
./runtime/bin/karaf: line 362: command: not found

DS> ls -l /volume1/@appstore/openHAB/userdata/etc
ls: /volume1/@appstore/openHAB/userdata/etc: No such file or directory

But as you can see there are another logs and tmp directories in userdata, created by the installation:

DS> ls -l /volume1/@appstore/openHAB/userdata/
drwxr-xr-x 2 openhab users 4096 Jun 23 09:34 logs
drwxr-xr-x 2 openhab users 4096 Jun 23 09:34 tmp

So I think the “etc” directory is not created during the installation.

Before the installation I created addons, conf and userdata directories under /volume1/public/openHAB based on the documentation.
After the installation these directories from @appstore are linking to them:

DS> ls -l /volume1/@appstore/openHAB/
-rw-r--r-- 1 openhab users 11232 Dec 17 2018 LICENSE.TXT
lrwxrwxrwx 1 openhab users 30 Jun 23 09:34 addons -> /volume1/public/openHAB/addons
lrwxrwxrwx 1 openhab users 28 Jun 23 09:34 conf -> /volume1/public/openHAB/conf
-rwxrwxrwx 1 openhab users 2794 Jun 23 2018
drwxr-xr-x 6 openhab users 4096 Dec 17 2018 runtime
-rw-r--r-- 1 openhab users 121 Dec 17 2018 start.bat
-rwxr-xr-x 1 openhab users 116 Dec 17 2018
-rw-r--r-- 1 openhab users 72 Dec 17 2018 start_debug.bat
-rwxr-xr-x 1 openhab users 73 Dec 17 2018
drwxrwxrwx 4 openhab users 4096 Jul 30 2017 ui
lrwxrwxrwx 1 openhab users 32 Jun 23 09:34 userdata -> /volume1/public/openHAB/userdata

So it seems to be ok, but etc under the userdata is missing.

Contents of /var/log/openHAB-install.log:

'#### S T A R T - o p e n H A B S P K ####
Set instance variables…
public: true
smarthome: false
home: false
TMPFS: false
Z-Wave: true
port: 8080
port: 8443
tmp: /volume1/@tmp
share: /volume1/public
oh: /volume1/public/openHAB
backup: /volume1/@appstore/openHAB-backup-201906
User that exec the Installation
Start postinst…
Create ‘openhab’ daemon user
Install new version
Move files to /volume1/@appstore/openHAB
No TMPFS Install needed
Move conf to /volume1/public/openHAB/conf and create conf link
Move addons to /volume1/public/openHAB/addons and create addons link
Move userdata to /volume1/public/openHAB/userdata and create userdata link
Fix permissions
copy Startupscript for z-wave binding. Then start it

Contents of /var/log/openHAB-start_stop.log:

Start service
wait_for_status: 0
wait_for_status: 0
… (repeated same lines)…
wait_for_status: 0
PID file created.
Stop service.
Stopping openHAB …
wait_for_status: 1
wait_for_status: 1
… (repeated same lines)…
wait_for_status: 1
stop_daemon: kill service
Start service
wait_for_status: 0
wait_for_status: 0
… (repeated same lines)…
wait_for_status: 0
PID file created.

I have tested other versions of OpenHAB (,, Unfortunately the result is the same.

Could you help me to investigate this problem called “openHAB is not starting properly” or “openHAB is not installed properly”?
Many thanks!

OpenHAB in Synology Package Center screen:

Ok, I think found the root cause of my problem: contains a move command with invalid “-u” option:

I have tested the “-u” option on my Synology DS710+ (DSM 5.2-5967 Update 9) with BusyBox v1.16.1 but there is no “-u” option:

DS> ls test_dir
DS> mv test_dir/* .
DS> ls 1.txt
DS> mv 1.txt test_dir/
DS> mv -u test_dir/* .
mv: invalid option – ‘u’
BusyBox v1.16.1 (2016-04-26 17:10:49 CST) multi-call binary.
Rename SOURCE to DEST, or move SOURCE(s) to DIRECTORY
-f Don’t prompt before overwriting
-i Interactive, prompt before overwrite was downloaded from repo, contains “userdata/etc” directory but the move command was failed in scripts/ and the installer hide this error (no logging the output of this command):

mv -u ${SYNOPKG_PKGDEST}/userdata/* ${OH_USERDATA}
rm -r ${SYNOPKG_PKGDEST}/userdata

My workaround is:

rm -r ${SYNOPKG_PKGDEST}/userdata

There are 2 other “mv -u” command for addons and conf directories. I fixed it as well.
Then I have to repack openHAB spk file (openHAB- to openHAB-

tar cvf ../openHAB- *

Reinstall new “custom” spk again and in the log seems to everything is ok, but the status of openHAB service is “Stopped”:

I have tried to start but service could not started due to Port 8080 alread in use. This is reported in start_stop.log:

DS> cat /var/log/openHAB-start_stop.log
Start service
Port 8080 already in use.
Stop service.
openHAB is not running

As I know there is no service that uses Port 8080 on my NAS. So test it:
And tadaaam:

Ok, the problem is the status.
I have tested it as well:

DS> cd /volume1/@appstore/openHAB/runtime/bin
DS> ./status
/volume1/@appstore/openHAB/runtime/bin/karaf: line 362: command: not found
ps: invalid option – ‘p’
BusyBox v1.16.1 (2016-04-26 17:10:49 CST) multi-call binary.

Usage: ps

Report process status

w Wide output

Running …

Oh…invalid option… again :slight_smile: I’ll be back soon.

Hi lew123, did you manage to run openHAB on your DS210j ? Facing the same problem as you here…