NTP binding can't change refresh interval


I have the NTP binding set up and working, but, the refresh interval is set to 60 seconds.

This results in date change logs every 60 seconds.

When I change the refresh interval in habmin, I get this in the log:

2018-10-03 12:09:29.551 [INFO ] [st.core.internal.thing.ThingResource] - Received HTTP PUT request for update configuration at 'things/ntp:ntp:demo/config' for an unmanaged thing 'ntp:ntp:demo'.

And the next time I look at the thing it’s back to 60 seconds.

What don’t I understand?

Did you define the NTP thing using a .things file, or did you create/discover it using PaperUI? If the former, you can’t make changes to the configuration of a thing defined in a .things file.

no I did not use a .thing file for this.

It does have an item in a .items file.

Changing it in paperui gets a popup “ERROR: 409 Conflict”

Delete the thing in the paper UI and create a thing using a *.things file as per the docs:

Attempting to delete the NTP thing in either paperui or habmin, same “ERROR: 409 Conflict”.

Did you add the binding using the addons.cfg or the paperUI?

That’s really odd.

See if you can uninstall the NTP binding through Paper UI if you installed it that way, or remove from addons.cfg if you installed it that way. The NTP thing now should show a status of UNINITIALIZED.

Then try deleting the NTP thing. If the status changes to REMOVING, delete it again. If you get a popup with the option to “Force Remove” select that.

When I went to uninstall in paperui I noticed the binding was: 2.4.0.SNAPSHOT

Even after removing the binding and the thing said uninitialized, still get the same error removing the thing.

Sorry. I’m pretty much out of suggestions. Maybe someone else has an idea…

I suppose you could try removing the thing from the karaf console. Maybe that will give more a clue what’s going on.

In the karaf console, run smarthome:things list to get a list of your things.

Then run smarthome:things remove UID where UID is the ntp thing from the list generated above. It would look something like this: ntp:ntp:local

Well, some progress.

I removed the binding from habmin. Still couldn’t delete the NTP Server thing…

Install the binding from habmin.
Used .things file to add a thing with interval set to 600 and now updates are happening every 10 mins.


Not sure what I did that changed… :open_mouth:

Please mark the thread as solved, thanks