Nuki Binding very often loosing connection

Hi,

I have a Nuki Smart Lock and Nuki Bridge. Both working great.

I have latest stable Version of OpenHAB installed on a Raspberry PI 4 B. Clean installation.

I added the Nuki Binding and I am able to lock, unlock and unlatch the door, but only sometimes. I very often get the following errors in log:

Thing ‘nuki:smartlock:Nukibridge:NukiSmartLock’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Service Unavailable

Thing ‘nuki:smartlock:Nukibridge:NukiSmartLock’ changed from OFFLINE (COMMUNICATION_ERROR): Service Unavailable to ONLINE

Between those errors I am unable to control the Smart Lock with OpenHAB.

Why is this happens? Of course it is not a network issue.

Despite you denying it:My rough guess is network issues - putting the Nuki bridge to a different location might help.
Faced similar issue, solved it that way.

Not finding the error with your networking doesn’t make your statement a valid one.
Note it could be either the BT connection bridge-lock or the Wi-Fi connection bridge(-AP)-OH or a nasty combo of interferences on the 2.4 GHz band.

Did you mean to say “it never worked from OH” ? In that case it’s likely (but not necessarily) a config issue. Possibly you used a wrong Nuki ID ? The QR code is not the right one. Look it up in the app.

I said, that it is not a network issue, because I double checked that!

My network is working great. My Nuki Smart Lock and Nuki Bridge are working great since years without any problems.

I never used them with OpenHAB. After years of not using OpenHAB I installed OpenHAB 3 a few weeks ago on my newly purchased Raspberry PI 4B. I didn’t installed anything else on that PI.

Now I am trying to control the Nuki Smart Lock with OpenHAB. Those error messages appears randomly. Sometimes everything is working, sometimes not.

In the past I always used the Nuki Smart Lock with my Lupusec XT2 Plus. I used the Nuki Bridge API (HTTP GET) to lock and unlock the door. That worked great.

As Nuki ID I’m using the hex value which is part auf the name received by the Nuki Bridge API (Nuki_XXX).

Where does the error message come from? How do you know, that the Bridge is “offline” ? Are you using an endpoint?

Maybe it is an issue of the Nuki Binding, a not correct implemented API or it is an issue of the Bridge (API issues or hardware defect), but it is not an issue of my network.

You seem to be very fond of and convinced of your capabilities but that still does not mean your network has no issues. Sure there’s other potential causes as well but intermittent issues are very often due to networking. HW and APIs don’t change all by themselves.
Like or at least accept that or not, but I’m telling as someone who has been working in networking for many years.
Feel free to ignore us, this is all just free advice you don’t have to take.

It seems that you are not understanding. I’m an IT expert and head of software development. I don’t ignore you, but what should I do? I know, that it is not a network issue. It is not my fault, that it is not a network issue! Should I be sorry that it is not a network issue? In the meanwhile I checked everything the third time. It is still not a network issue. I wouldn’t say that it is not a network issue, if I’m not 100% sure, and if I didn’t checked and tried everything!

Due to the fact it is not a network issue, I’m asking here for help, to find out if this is an issue of the Nuki Binding or API or a hardware defect.

Hey, I hope you managed to fix your problem. If not, here is a possible problem (taken from the docs):

If secureToken property is enabled, make sure that time on device running openHAB and Nuki Bridge are synchronized. When secureToken is enabled, all requests contain timestamp and bridge will only accept requests with small time difference. If it is not possible to keep time synchronized, disable secureToken feature.