NUKI Opener

It seems that I can’t reach the Nuki Opener with the Nuki Binding.
Can someone or the creator of the Nuki binding add support for the “Opener”?

To access the opener via the Nuki Bridge it needs now an extra parameter called “deviceType”.
This needs to be “2”.

Without this parameter it seaches for an SmartLock and not for the Opener.

So for example:´

I have tried an Opener also in use with the Nuki Binding. No success until yet. Maybe the Owner of the Binding can extend this. If help is needed or debugging help I will try to support.

request already done :


I also very interested that the opener will be integrated in a short while. Not sure if possible to create a nuki lock thing and modify the settings in the json database. But for my opinion it doesn’ work because the difference it the device type (opener = 2) smartlock = 0, the rest lock very simular.

Hey @chrisonline,

do you have any experience in using the nuki api? If it’s just this small change, I could work something out. However, I guess the commands are different too, right?

I have read the docs but have nothing coded with the API yet.
And I have tried it via the link in the browser and it is working if I add the “deviceType=2”.

Would be awesome if you can add Nuki Opener support.

Not sure if someone is interrested for the slution for the opener. This example work together with a nuki doorlock and a Nuki Bridge.

Switch NukiOpener_open "Türöffner betätigen" { http=">[ON:GET:] >[OFF:GET:]"}
Switch NukiOpener_RTO "Ring to open" { http=">[ON:GET:] >[OFF:GET:]"}
Switch NukiOpener_Cont "Dauermodus" { http=">[ON:GET:] >[OFF:GET:]"}

String NukiOpener_Battery "Opener Status Battery [%s]" {http="<[$.batteryCritical)]"}

I add only in a item file the objects which I needed for the opener - all other are defind by the NUKI Binding settings. You can with this syntax all api request for devicetype=2.

ttttt = NUKI Tocken
xxx.yyy = part of the IP of the openhab platform

Hopem this helps - it’s not a integrated solution but it works based on it.

1 Like

Nice workaround!
Thanks for sharing.

But you don’t see the actual state of the Nuki Opener for “Ring to open” or “Dauermodus”?
Anyway a great workaround until someone can add the native support to the binding.

Thanks again!

String NukiOpener_Status "Status [%s]" { http="<[$.stateName)]"}

Think this you mean.

What isn’t possible : to get the ring action - here I use another way : HM-Sen-DB-PCB

It’s a little bit double doing but until opener doesn’t support it (I don’t know why it isn’t) I use this and it works really good. If someone rings Alexa says that there is someone who rings :slight_smile: Nice gimmick.


1 Like

Yes this was it.
Great, thanks again.

There is since 2 days an initial commit for the support for Nuki Opener:

So it seems we are getting this support hopefully soon.

Thanks for this! I fiddled around a little and I think the open command works even better this way:
Switch Housedoor_Lock "Türöffner betätigen" <frontdoor> (gNuki) { http=">[ON:GET:http://192.168.17x.yyy:8080/lockaction?token=tttttt&nukiid=NUKIID&deviceType=2&action=3]", autoupdate="false" }

(action=0 seems to be invalid)

And everyones who’s also searching for the Nuki ID… These are not the numbers which the base is handing out in the nukiId field… It’s the last part in the name-property of the opener (name: Nuki_Opener_THISHERE). You get these by calling your nuki base with http://192.168.17x.yyy:8080/info?token=tttttt

Has anyone managed to get the linked binding at working? I hoped it will be in 2.5.6, 2.6.7 or 2.6.8 but it looks like a review is missing.

Not tried yet.
I will wet until is is officially added.

Hi guys,

I guess this has still not been added meanwhile to the official binding?

1 Like

Hi all,

Any updates on adding this to the official binding?

1 Like

Sorry to bump this old thread, but is there any news on this?

This is already in the official build.

1 Like

Yes, Opener is supported since version 3.2.0 M2.

1 Like