ODROID C2 arm64 : java armhf


I have an issue when I try to install java Zulu on my Odroid C2 on armbian mainline:

dpkg --add-architecture armhf
apt-get install libc6:armhf libncurses5:armhf libstdc++6:armhf
wget http://cdn.azul.com/zulu-embedded/bin/ezdk-1.8.0_131-

unzip the tar.gz to /usr/lib/jvm

/usr/lib/jvm/ezdk-1.8.0_131- -version
Illegal instruction

I am stuck and don’t know wha to look for now :frowning:

Hi @yaazzz, do the instructions on this page help? It mentions RPi 3, but the steps should be the same.

Well, I installed openhabian script and go through all the installation process.
I tried to follow also the process described for RPi3 but still having this … … error message.

I solved the issue by installing the openjdk:armhf. I think the zulu .deb is broken.

1 Like

I’m currently running Zulu on a pi so it maybe an arm64 specific issue.

I’m glad you have it working however.

Thank you Benji for you feedback. It is simple to switch from one java version to another one so as soon as we will have an update of the zulu package I will make it a try and post if it is working.

Could you elaborate how you solved this? I’ve been struggling for a while getting openhab running on my rock64 running arm64. First I tried the webupd8 installer for Oracle Java (which I used on my old openhab erver) but it only installs the 64 bit Java which doesn’t seem to work well with OH. Tried installing Zulu according to @Dim’s guide but it only tells me that the repository doesn’t support architecture arm64.

I thought arm64 shouldn’t be really that uncommon, but getting OH to run on it is really a struggle…

it seems that this repo does not contain the 64bit version of Zulu for ARM
I found these instructions for manual installation that may help: https://www.azul.com/downloads/zulu/zulu-download-arm/

Thanks. Before I proceed though: Is it a good idea to run 64-bit Java? Or would OH work better if I install 32-bit Java? For example I never got Tellstick binding to work with 64-bit Oracle Java :frowning:

edit: From https://docs.openhab.org/installation/ I read:

Please use the 32-bit version of the JVM for ARM platforms, even on 64-bit operating systems. Serial connections won’t work with a 64-bit JVM, preventing bindings like Z-Wave from functioning.

Is this still valid? If so I guess I need to install 32 bit Zulu. Still not clear on how to do that though :blush:

If u still need help I wrote a how to here @DanielMalmgren

Thanks! I gave up my attempts though, too much stuff that didn’t work out in a 64 bit arm environment. So now my OH is on another (pure 32 bits) server instead.