Odroid c4 released anyone using?

This made a bit more sense:

root@OpenHab2-C2:~# ls -l /dev/serial/*
total 0
lrwxrwxrwx 1 root root 13 Apr  7 10:19 usb-Silicon_Labs_CEL_EM357_Zigbee_USB_Stick__Long_Range_0101D166-if00-port0 -> ../../tt                                                  yUSB0
lrwxrwxrwx 1 root root 13 Feb 11  2016 usb-Velleman_Projects_VMB1USB_Velbus_USB_interface-if00 -> ../../ttyACM0

total 0
lrwxrwxrwx 1 root root 13 Feb 11  2016 platform-dwc2_b-usb-0:1.1:1.0 -> ../../ttyACM0
lrwxrwxrwx 1 root root 13 Apr  7 10:19 platform-dwc2_b-usb-0:1.2:1.0-port0 -> ../../ttyUSB0
1 Like

You are trying a very 1st alfa build version of image for Odroid C4 (clearly noted as suitable for testing) and this (no proper reboot) problem is noted at the download pages. It is nearly impossible that v1.0 would work without issues.

We have a solution, but there is simply no time nor resources to integrate and test just like that. It takes time. I also manage to fry my test board and waiting for a replacement.

1 Like

I know how that feels.

All I did was hook up a GPio pin incorrectly and it was “Goodnight Vienna” to the whole board.

Thank you for everything you are doing.

I’m really looking forward to trying a C4.

1 Like

I am using an eMMC not SD card.

From the download pages:

  • Troubles with network. Sometimes it fails to initialise after reboot. All kernels are affected by this bug.
  • apt update & apt upgrade leads to the broken system. Will be fixed soon. Workaround is to freeze system packages in armbian-config menu
  • Reboot works properly on eMMC, while on SD card it doesn’t come back. Power cycle helps.

I will try another download and see if anything changes with rebooting.

Why? And you will rant ant complain if something will not work?

What about the important things like waiting, reading, helping? This is not a commercial service.

At this stage, there is no end user support since it is expensive and stressful like hell.

  1. Download Ubuntu Minimal 20-04 LTS image from here (non official image) and flash using etcher program. If this post is old, check for an official image first.


Only works on eMMC currently so don’t use sd. User:pass is odroid and odroid

Follow the steps at the link below. It /should setup your odroid C4 with samba shares and frontail just like you are used to with a pi. If it fails just post me a copy of the log file to look over. The script is not advanced and must be run on a clean image just flashed so if it fails it needs the image put back on to try again.


@igorp I didn’t mean to come across as ranting, just updating my experience for anyone else that’s interested.

I have been reading some on the Armbian forum but most issues are beyond my knowledge of Unix/Linux. I will continue to learn and help however I can but don’t hold your breath, neither I or my memory are getting any younger. :upside_down_face:

I would also like to thank you for the work thus far and if I can help let me know.

@matt1 Thanks for the links, will give it a try sometime today and post the results.

Update on installing OH with Debian headless image and using @matt1 script.

You will need to edit the sources list to include all deb-src lines, run apt-get update, then install sudo with apt-get install sudo -y. Next add sudo users with usermod -aG sudo yourusername then reboot.

After doing the above Matt1’s script worked perfect. :smiley:

Thanks to all for your great work here. Looking forward to getting OH working on my C4.

@H102, could you clarify which image you used and where to download it?

I tried both of these:

Matt’s script seems to run ok (each time on a clean image) and OH loads afterwards on http://openhabianpi:8080 (I can see the UI and can start setting up OH) but when I press Y at the end of the script to reboot the machine it seems to reboot ok and the blue heartbeart light start flashing after about 5 sec but I can’t connect any more via putty to the IP address and http://openhabianpi:8080 in my browser shows The connection has timed out.

Hardware is Odroid C4 + RTC shield + 32GB emmc

The only error I can see in the log is this one a few dozen times, but I don’t know if it matters because I can connect to http://openhabianpi:8080 on completion:
sudo: unable to resolve host openhabianpi: Name or service not known

This is the install log:
install.log (493.9 KB)

What should I try next?

Thanks again.

Replace the ‘openhabianpi’ with the IP that your router shows the device is using. If you have a pi running on the network installed by openhabian then it will have already taken that hostname and that may be the cause of the issue. Frontail wont work if the hostname failed (easily fixed by editing a file) but the rest should work from memory. gives a timeout error.
I deleted the Mac to IP assignment in the router and power cycled the machine and it does not show up in the DHCP table. To be sure I tried every possible IP the C4 could be assigned to in the browser and all gave a timeout.
There is no sign of traffic through wireshark and telnet cannot connect to the IP but the orange light on the RJ45 connector on the C4 is blinking.
It all works fine until I do the first reboot after the OH install.

Am I using the correct images to install from?


Wild suggestion

But what do you get if you plug a monitor & keyboard into the C4?

What do the commands

ip addr


systemctl status openhab2

Show you?

Sorry, I should have thought to mention that. With a newly loaded image the command line shows the machine booting when connected by hdmi. After running Matt’s script, the screen is black after rebooting or when the power is turned on. It flickers to dark grey about 3 seconds after power on and then is black again.
Connecting a keyboard gives the same result.
There is no login prompt or command line.

What options in the script are you using and have you tried turning a lot of them off to see if any of them causes the issue?

These are the options:
install-openhab-arm64-options.txt (2.3 KB)

I’ll trying disabling everything and running it again.

Would it be useful to run each command from the script manually and reboot after each command to see if I can identify which command breaks the machine?


Stripping the options down to these still gives the same result:

#sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys AB19BAC9

I’m using the ubuntu-20.04-server-odroidc4-20200716.img image for a minimal sized install. It has a user ‘odroid’ instead of ‘root’ - would that make any difference to the script?

I ran each step of the script manually and then rebooted after each step. The C4 rebooted fine after each step until after this command was run:
sudo apt-get install -y mc nano build-essential udev:armhf software-properties-common

This is the log for just this command:
install2.log (37.4 KB)
Unfortunately it’s 600 lines of stuff that doesn’t mean much to me.

Would it be better to start with the Armbian image, follow the Armbian install guide and then manually pick bits from Matt’s script?

Thanks for any guidance.

I wouldn’t bother with Zulu.

I just install the default 64 bit Java.

Why don’t you try using openhabian? last time I tried it worked after I first manually installed curl.
Yes you can also try Armbian and then run the scripts lines to do what you wish, that is why I laid out the commands in an easy to follow order.

As far as the script goes you can narrow it down further by only installing one at a time from that line you already found to be problematic. Start with either of these two udev:armhf or software-properties-common.

After running “sudo apt-get install -y mc nano build-essential udev:armhf” the reboot problem persisted. I’ll move on from the script now - I don’t think my tests are adding any value and I’m sure it’s about as interesting for you as filling tax returns.

Running openhabian worked and I have a running OH system on my C4 now. :slight_smile:

Here’s a summary of the steps that worked for me (having never used an ODROID before):

Thanks again for your help.


Great news and thanks for posting what worked, just don’t forget to change the password so “odroid/odroid” no longer works. Also be great to hear how fast and smooth it runs compared to what you were using before.

1 Like