Official Alexa Smart Home Skill for openHAB 2

Reading your replies prior it seems you’ve never had a problem but there also seem to be many who are having the same as me

1 Like

Sorry that I can’t tell you anything else :grinning:
I just wanted to make clear that it SHOULD work. I have no idea why it does not at your system … :joy:
I’ve read somewhere (but I think that was another binding) that when bridges are connected through hubs or switches, and not directly to the router, this may cause problems. It is worth a try: connect your alexa dot directly to the router (if not already the case) and try again. Try to avoid any access points or repeaters.

@sihui @digitaldan I don’t know if this question was answered before, but I want to know the following:

How is it possible to use “OpenHAB2 Smart Home Skill” directly, without using myopenHAB.org account?

Do I have to follow exactly all these steps here:

You wrote there:

…either directly or through the openHAB Cloud service (preferred).

And if I have followed all steps then I have to edit the config.js with information of my local REST Server configuration?

module.exports = {
    //userpass: 'user@foo.com:Password1',
    host: 'my.openhab.org',
    port: 443,
    path: '/rest/items/',
};

Do I need DynDNS or NAT in my router configuration, or is “Amazon Echo” device communicating directly through my LAN with my REST Server?

if directly through my LAN, then config.js could be as follows?

module.exports = {
    userpass: 'user@foo.com:Password1',
    host: 'IP-Address-of-REST-Server',
    port: 8443,
    path: '/rest/items/',
};

Thanks a lot for your answers!

If you don’t like cloud services, you may use the hue emulation for Alexa:
http://docs.openhab.org/addons/io/hueemulation/readme.html

You might not have a choice at the moment with Alexa but to do hue emulation. Native openhab skills aren’t discovering for me and others yet this is not the case for everyone

You may also take a look at:

I did it through myopenhab.org. The other way was to complicated.

In the Cloud Service I can see all my devices, but Alexa does not find any devices.!!!

My SmartHome Server and Alexa are connected to the same Wifi Access Point.

Did you authorize the alexa skill in your cloud?

@sihui Yes I did!

Then you may be affected by that strange “not finding devices” problem other users are reporting here …

And you did tag your items correctly?

http://docs.openhab.org/addons/io/homekit/readme.html

@sihui Yes, I did!

I tried both: [ “Lighting” ] and [“Lighting”]…

My alexa language is german!

Still no devices detected!

Any hints?

These are two of my working items with openhab 2.1.

Color  Fenster_Color         "Fenster Licht" [ "Lighting" ] { channel="lifx:colorlight:fenster:color" }
Switch Alexa_RadioBK	"Radio Bad"	[ "Switchable" ]	{autoupdate="false"}

How do your item definitions look like?

@christoph_wempe

Switch	Hue_Light3_Toggle		"Licht Bibliothek"	<light>	(GF_Biblio, Lights)	[ "Lighting" ]	{channel="hue:0100:0017882971e8:8:brightness"}	  
Switch GHoma5					"Dose Vitrine"		<light>	(GF_Living, GHoma)	[ "Switchable" ]	{ http=">[ON:GET:http://192.168.178.24:3000/on/3ef204] >[OFF:GET:http://192.168.178.24:3000/off/3ef204] <[http://192.168.178.24:3000/state/3ef204:64000:MAP(onoff.map)]" }   
Number GF_Kitchen_maxActual  "IST Temperatur  [%.1f °C]" <temperature>	(gMAX, GF_Kitchen, Temperature1)	 [ "CurrentTemperature" ]	{channel="max:thermostat:LKF0025489:MEQ1442698:actual_temp"}

@christoph_wempe

and in

https://myopenhab.org/rest/items it looks like:

{"link":"https://myopenhab.org/rest/items/Hue_Light3_Toggle","state":"OFF","type":"Switch","name":"Hue_Light3_Toggle","label":"Licht Bibliothek","category":"light","tags":[" Lighting "],"groupNames":["GF_Biblio","Lights"]}

{"link":"https://myopenhab.org/rest/items/GHoma5","state":"OFF","type":"Switch","name":"GHoma5","label":"Dose Vitrine","category":"light","tags":["Switchable"],"groupNames":["GF_Living","GHoma"]},

{"link":"https://myopenhab.org/rest/items/GF_Kitchen_maxActual","state":"NULL","stateDescription":{"pattern":"%.1f °C","readOnly":false,"options":[]},"type":"Number","name":"GF_Kitchen_maxActual","label":"IST Temperatur","category":"temperature","tags":["CurrentTemperature"],"groupNames":["gMAX","GF_Kitchen","Temperature1"]}

but I have also the following “Lighting” tags, but I NEVER filled into .items file on my own:

    {"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_8_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_8_brightness","tags":["Lighting"],"groupNames":[]}

    {"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_1_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_1_brightness","tags":["Lighting"],"groupNames":[]}

    {"link":"https://myopenhab.org/rest/items/hue_0100_0017882971e8_2_brightness","state":"0","type":"Dimmer","name":"hue_0100_0017882971e8_2_brightness","tags":["Lighting"],"groupNames":[]},

In rest/items, should there be enclosed the brackets […] for tags?

I don’t really know, but I would guess [ "Lighting" ] needs t o be a Color item.

But I am no expert, either. :neutral_face:

Hi,

Anyone got this working with a Harmony hub? I want to mute my TV so I created the item:
Switch Fernseher “Fernseher” [“Lighting”] { harmonyhub=">[press:Samsung Verstaerker:Mute]" }

I also tried to to switch “Samsung Verstaerker” with “harmonyhub:device:HarmonyHub:45963471:buttonPress”

It is showing in the Alexa app and it is recognized by alexa too but it is doing nothing. :frowning:

What am I doing wrong?

Edit: I tried a wake on lan command and that is working so I think the commands in the brackets {} are wrong

Thanks for everys useful awnser
Robin

According to the docs it can be:

Those items are looking like autodiscovered item from your hue bridge. But then they should not have a tag …
Do you have “Simple Mode” switched to ON? (PaperUI -> Configuration -> System -> Item linking).
If you are defining your items via text files you should switch that to OFF, otherwise you get a big mess (all items which are defined through text files are added twice …)

Yes.
Take a look at the docs.
http://docs.openhab.org/addons/bindings/harmonyhub/readme.html

First you need to define a string item:
String HarmonyWZPhilips "Philips-TV" <television> (gRestore) [ "Lighting" ] { channel="harmonyhub:device:HarmonyWZ:26434461:buttonPress" }

Then put a switch on your sitemap:
Switch item=HarmonyWZPhilips mappings=["Mute"="Ton ein/aus"]

Take a look in your harmony remote desktop software which command is used for your TV to mute it.