Official Alexa Smart Home Skill for openHAB 2

If after changing item definitions I then get unexpected behaviour, especially with groups, then normality can sometimes be restored by stopping openHAB, clearing the the cache, and then running a forget and discover in Alexa.

I also noticed that running discovery a few times recovered missing devices.

Hi everyone,

facing the problem, that the name of my items are not discovered by the skill.


Switch  OM_Zwischenstecker_1 "Küchenlicht"                     <lightbulb>    (gLicht_KUE,gChart)                   {alexa="Switchable", channel="hue:xxx:switch"}

I receive in the Alexa Skill the name:

SO it takes “Switch” instead of “Küchenlicht”. I can change the name “Switch” but in V2 the name was pulled by default from the skill. Asking Alexa for Küchenlicht, I receive the information, that Küchenlicht does not exist. Am I doing sth. wrong?


Try clearing the OH cache and then do a forget and discover for Alexa.

I had the same yesterday, Alexa seemed to discover a new item I had created but it don’t appear anywhere for me to use.

I started poking around to no avail, I then walked away in a hump as I couldn’t get it to work only to come back to it a couple of hours later to see it there.

Time was all it needed.

1 Like

I had a discovery issue as well. Tried many delete/rediscover/clear cache but couldn’t solve. I also tried using v2 and v3 definition of items as the 2 are supported by the v3, but didn’t solve: I couldn’t get new items discovered.
I had mixed v2 and v3 item definitoon in my .items files so I decided to only use v3 and it worked.
Is it possible that whilst the v3 tolerates both v2 and v3, it doesn’t tolerate mixed use of v2 and v3?
Don’t know but if you wanna give a try…

1 Like

Have you gone through the troubleshooting guide? Make sure to stagger your Alexa configuration. Start from square one and add one device at a time.

Mixing v2 and v3 configuration is fine. The skill uses v3 syntax over v2 on a per item basis when defined.

Time fixed the issue…now it is working like a charm… :wink: Learning the skill with Alexa from day to day…thank you for your fast and quick support!!

It sounds like you weren’t triggering manual discovery whenever you made configuration changes and that the daily automated discovery triggered on the Alexa side fixed your issue.

Because of security concerns I would like to disable Alexas access to OH when I am not at home (when I am away it does not make sense anyway.
Is there any option to activate / deactivate Alexa’s access to my system?

Block Alexa’s Internet connection temporarily?
Disconnect openhabCloud to my system?
Change UUID of OH, so that openhabcloud does not have access anymore?
something else?

I am confused. I actually recall answering this question before and then I noticed you were the person I replied to in the first place. Did you end up implementing the solution I recommended?

Damn it - you are right.
That slipped through my notes somehow.
Sorry for that.
I will try to play around with your recommendation!
Thanks for pointing this out to me (again) :wink:

I guess I have another issue.
After activating the OH Skill in my Alexa app and tagging the items, I can discover them.
But I guess this interfers with my previous Hue emulation setup, because all items are discovered as Royal Philips Device.
Of course I deleted all Devices before the new discovery (and removed the hue emulation binding), but they seem to be buffered somewhere.
Where can I look for this?

I guess deleting the cache will help!? (as always) :wink:

Have you looked at this post?

Thanks for pointing this out.
Yes, I read that and have the same issues.
The only difference is, that I don’t have a physical hue bridge, but this does not make it any better.

That’s working flawlessly!
Thank you very much!

1 Like

I am trying to use ModeController to control in french my telco box PVR (Orange brand in France) with Alexa.

I have created an item as followed:

String pvr “orange” {channel=“mqtt:topic:d2cfb0fd:livebox”, alexa=“ModeController.mode” [supportedModes=“Play=Démarre,Pause=Stop”]}

I have set up French language in PaperIO

Alexa discovers my “Orange” device, displays the “Démarre” and “Stop” buttons in the Alexa Android app which send the right Play/Pause commands to OH and then MQTT.

However I cannot found the right vocal orders to activate these commands. I always get (in French) “the device Orange does not take into account this command”.

Any idea on what I am missing?

Can you please provide the exact utterances in French you tried?

Also, it seems that the PlaybackController capability may be more appropriate for the functionality you are trying to expose. Although, it will probably require the use of Player proxy item and some rules to integrate.

I have tried the following utterances :
"alexa démarre orange”
"alexa arrête orange”
"alexa ouvre orange”
And I have got always that response from Alea :
“L’appareil orange ne prend pas en charge cette commande.”

For the utterance “Alexa met le mode démarre pour Orange” i’ve got “Je ne sais pas comment régler l’appareil orange sur ce paramètre.”

I have also tried
"Alexa mode démarre pour orange”
"Alexa mets orange en mode démarre”
with only a beep feedback from Alexa

What about trying my suggestion? What exactly is the purpose of that item? I assume it is control a media player.

hi Lars,

did you ever get this to work in German?
What is your German phrase to set it to TV for instance.
I am struggling to make it work.
Thanks in advance