Official Google Assistant Integration for openHAB

myopenhab
openhabcloud
googleassistant
Tags: #<Tag:0x00007f15d3419660> #<Tag:0x00007f15d3419520> #<Tag:0x00007f15d34193e0>

(Filip M) #394

Important note: If you are not able to link your myOpenHab account, make sure you have set openHab Cloude service in your configuration to remote access!


(Raffaello Bonvino) #396

Hi all and thanks for the great job. I have a problem with a philips hue item. I’ve a lamp that I can turn on/off, dimmer and set color and a switch and two slides related to this lamp each one tagged as [“Lighting”]. The problem is that when I say: “Ok Google, turn on Lamp-name”, google assistant answers saying: “Ok, I will turn on 3 smart lights”. It seems that the switch and the two slides are recognized as 3 different smart lights. I have the items defined as follows:


Any suggest? Thanks.


(Chris/si) #397

Is it possible to disable the Google Home voice feedback? In my opinion it’s kind of annoying to hear it every time you’re interacting with OpenHAB via voice command.
For example if I turn on a light I only want the light to be turned on without my Google Home saying ‘OK, you’re light xy is now turned on’.


(Philipp) #398

I have the same problem. Simpel Hue bulbs Number 100 can control in brightness (channel= brightness). The colorbulb 210 in brightness and color (channel= color) with [ “Lighting” ].

//Wohnzimmer Farblampe Ikea
Switch	FF_LivingRoom_Light1_Toggle	    	"Wohnzimmer Farblampe"  <light>             (FF_LivingRoom, FF_LivingRoom_AllLights, FF_LivingRoom_Decke_Lights, FF_AllLights, FF, Home, gLight)   {channel="hue:0210:001788:2:color"}
Dimmer	FF_LivingRoom_Light1_Dimmer	        "Wohnzimmer Farblampe Helligkeit"  <light>             (FF_LivingRoom, FF_LivingRoom_AllLights_dim, gLight)                      {channel="hue:0210:001788:2:color"}
Color	FF_LivingRoom_Light1_Color		    "Wohnzimmer Farblampe"  <light>             (FF_LivingRoom, gLight) [ "Lighting" ]                                                  {channel="hue:0210:001788:2:color"}
Dimmer	FF_LivingRoom_Light1_ColorTemp	    "Wohnzimmer Farblampe Farbtemperatur"      <light>             (FF_LivingRoom, gLight)                                                                 {channel="hue:0210:001788:2:color_temperature"}


//Wohnzimmer einfache Lampe Ikea
Switch	FF_LivingRoom_Light3_Toggle	    	"Wohnzimmer 3"          <light>             (FF_LivingRoom, FF_LivingRoom_AllLights, FF_LivingRoom_Decke_Lights, FF_AllLights, FF, Home, gLight)  {channel="hue:0100:001788:26:brightness"}
Dimmer	FF_LivingRoom_Light3_Dimmer	        "Wohnzimmer 3"          <light>             (FF_LivingRoom, FF_LivingRoom_AllLights_dim, gLight)    [ "Lighting" ]                  {channel="hue:0100:001788:26:brightness"}

But I can’t find any solution to control the Hue 220 color temperature bulbs in brightness and color temperature at once without creating 2 seperat Bulbs in Google Home.

Did anyone have a solution?


(Kim Andersen) #399

Is the openHab Google Home connection still beeing developed?

I as well as others seem to run into problems where Google home returns with an error when trying to sync the devices.

I ran into this problem a coupple of weeks ago, after I have changed some items.
I have been struggling ever since getting Google Home to sync again since, without success.

Last night I removed everything. All tags, removed the connection to openhab in Google Home app, as well as removed the Google application within myopenhab cloud. I rebooted my Rpi and tried to re-add the connection again. But now Google home wont connect to openhab cloud anymore.
Openhab cloud seem to add the connection, but Google Home comes up with an error and does not add the connection. (It tells me to check the connection, which hardly can be the problem, since I can enter openhab cloud just fine).

At this point I see no way to investigate the problem. I really could need some advice on how to troubble shoot this.

I´m using openhabian hasslefree openhab 2.3.0 stable on a Rpi.


(Skinah) #400

Check the list of things that can cause issues in this post linked below. I also had problems start a few weeks ago when I removed the ooenhab device link in the app and now I can not link or sync if I have more than 5 tagged devices. It is like my firewall or the server fails to send/recieve more than 1 packet.


(Kim Andersen) #401

Thanks Matt. But I removed every single tags from my items. And still Google Home wont connect.
The link post, you mention something about a corrupted JSON database… That may be the problem. But, how to know, and better yet, how to fix?


(Rich Koshak) #402

One of the things mentioned in Skinah’s post is you must have at least one Item tagged or else Google Home won’t connect.


(Kim Andersen) #403

Ahh, I see number 5… Thanks Rich!
Will give it another try tonight.


(Kim Andersen) #404

Just tried again, adding a coupple of tags. Still the same problem.
Tried reboot Rpi as well as restart Google Home, still no luck.


(Skinah) #405

If not using openhabian replace with the IP or host name of your server…
http://openHABianPi:8080/rest/items/

The cloud connector uses that link to fetch all your items from, so if the link does not work or comes back with rubbish output for an item it will need to be looked at. The cloud connector then passes the output onto the myopenhab.org server and then on to google.

If you still have problems, start your own thread.


(Kim Andersen) #406

Well…
I´m not really sure how to explain this, but it´s working again this morning.

Last night:
I´d split up my item file into several files.
I made 100% sure I only got one tag and it was 100% perfect.
I cleared cache and tmp.
I cleared all items using karaf console.
I rebooted several times.
I did NOT managed to get Google Home to connect even after several tries.

I then had an idea of installing the Homekit addon insted, since it uses the same tagging, (I have an iphone as well as android phone).
Homekit worked in first go, found openhab, connected and found this single items which had the [“Lighting”] tag. And it worked like a charm.

Then I added a tagging to a different item. But I couldn´t get Homekit to update. (I honestly don´t know how to, as I just use my iPhone for work, and nothing else. So I might have missed some options or something).
All of a sudden Homekit wouldn´t work any more. I tried remove it and add it again several times, but it just wouldn´t work.
I gave up.
Made a last reboot, and got off to bed.

When I got up this morning I thought I would give Google Home just a last try. And all of a sudden, Google Home connected and found two items without any problems.
And trust me, I have not changed anything while a sleep.

To be honeste, I think there is a need for this to be looked at in some way. This seems like it´s a kinda lottery with a random success, but mostly fails. And it´s way to difficult to dig into in case it´s not working.


(Jack Sand) #407

Sorry i also get this cant update/connect

I use tagging on my Amazon echoes and then this should also be supported ?


(Pumbadinho) #408

Hi,

I like it very much.
But if I add openhab in Google home app, after allowing oauth just nothing happens.
Maybe this is because I tagged nothing as light or plug. This is the second issue, how do I tag them, if I added them over the webinterface and not config file?

Thx in advance.


(Skinah) #409

Yes that will be your problem, you need at least 1 item with a tag before it will link or sync. You can use the REST api to apply the tags to items created in paperUI. Install the ADDONS>MISC> rest documentation, then it shows up as a new UI to choose.

Personally I would start using item files, as having everything in files is much faster at removing and adding things when you need to narrow down an issue.

@Ontrackx
Some of the tags that work with echo will break google. You may need to disable some to get them working in google and then reenable them for echo. See my link a few posts above where I list the known issues and it also has the tags which work in which app.


(Some Engineer) #410

Google assistant has recently worked with the Russian language. But the openhab action is not available for the
RU region. How about adding this region?


(Pumbadinho) #411

I added some more Things to openhab with the tags mentioned.
How does my Google Assistant recognize? Last time i removed Openhab from Assistant and added it again. But cannot be the solution…


(B K) #412

Say: OK Google, sync my devices!


(Winton Cape) #413

I am new to openhab and have it configured with ubuntu. When I try to cloud configure, in the expose items field, I get only the channel name of the things to be exposed… not the thing like Kitchen light or Living room light.

As a result when I try to connect google home using iphone, I get no devices present. Anybody experienced this problem and solution suggestions…


(David) #414

I’m facing a problem while trying to add the action to Google Assistant app.
my openhab is OK a I’m using it with Alexa.
when I select the action in G A preferences, it successfully redirect me to the oauth page. I can log then allow the access but I can just see an error message in G A (in French), talking about a parameter that can’t be set.
The action is not added and thus, can’t be used to discover any devices.
I’ve tried several times, but always the same problem.
my phone is running Android 8.1and is up to date.

Any clue?