Official Google Assistant Integration for openHAB

I guess you use the assistant in another language than english? I now in dutch there are users reporting the same issues. Maybe Google someday will fix this.

@aart Indeed using it in Dutch as well, so you’re saying this is a google issue not an openhab one. That’s good news as I expect google to be quite agile in fixing bugs :slight_smile:

Hello all,
Since yesterday I have problem with Google Home synchronization. When I try several times it finally works but the items are not responding. Where can I debug what is wrong? I have the following items:

Switch KitchenLights "Kitchen Lights" <light> (gBedroom) [ "Lighting" ]
Switch BedroomLights "Bedroom Lights" <light> (gBedroom) [ "Lighting" ]
Switch BathroomLights "Bathroom Lights" <light> (gBathroom) [ "Lighting" ]
Switch HallwayLights "Hallway Lights" <light> (gHallway) [ "Lighting" ]
Switch LivingMainLights "Living Main Lights" <light> (gLivingmain) [ "Lighting" ]
Switch LivingSecondaryLights "Living Secondary Lights" <light> (gLivingsec) [ "Lighting" ]
Switch BalconyLights "Balcony Lights" <light> (gBalcony) [ "Lighting" ]
Switch Cooling "Cooling" <hvac> (gCooling) [ "Switchable" ]
Switch Heating "Heating" <hvac> (gHeating) [ "Switchable" ]
Switch Camera "Camera" <camera> (gCamera) [ "Switchable" ]
Group g_HK_Bedroom_TSTAT "Bedroom Thermostat" [ "Thermostat", "Celsius" ]
Number HK_Bedroom_Mode "Bedroom Heating/Cooling Mode" (g_HK_Bedroom_TSTAT) [ "homekit:HeatingCoolingMode" ]
Number HK_Bedroom_Temp	"Bedroom Temperature" (g_HK_Bedroom_TSTAT) [ "CurrentTemperature" ]
Number HK_Bedroom_Setpoint "Bedroom Setpoint" (g_HK_Bedroom_TSTAT) [ "TargetTemperature" ]
Group g_HK_Bathroom_TSTAT "Bathroom Thermostat" [ "Thermostat", "Celsius" ]
Number HK_Bathroom_Mode "Bathroom Heating/Cooling Mode" (g_HK_Bathroom_TSTAT) [ "homekit:HeatingCoolingMode" ]
Number HK_Bathroom_Temp	"Bathroom Temperature" (g_HK_Bathroom_TSTAT) [ "CurrentTemperature" ]
Number HK_Bathroom_Setpoint "Bathroom Setpoint" (g_HK_Bathroom_TSTAT) [ "TargetTemperature" ]
Group g_HK_Living_TSTAT "LivingRoom Thermostat" [ "Thermostat", "Celsius" ]
Number HK_Living_Mode "LivingRoom Heating/Cooling Mode" (g_HK_LivingRoom_TSTAT) [ "homekit:HeatingCoolingMode" ]
Number HK_Living_Temp	"LivingRoom Temperature" (g_HK_LivingRoom_TSTAT) [ "CurrentTemperature" ]
Number HK_Living_Setpoint "LivingRoom Setpoint" (g_HK_LivingRoom_TSTAT) [ "TargetTemperature" ]

Tommorow my Google Smart Hub arrives and I need to be prepared :smiley:

I also I’m having problems since yesterday! I keep getting that google can’t get openhab!

Any reports of problems?

Thank you

I tried everything, from deleting temp files, restarting, link/unlik, 1 item/ all items nothing works :frowning:

Maybe your issues are related to this:

1 Like

Dear @aart, @MARZIMA
On October 1 you wrote that “The Humidity is already in a fixed in a pull request.”
Latest updates include this tag? Could you check please?
I have thermostats with humidity values so looking for working TAG…

Yes, the Humidity is supported now.
For more information see github usage.md.
(The official documentation on openhab.org is not the latest version.)

I cant get the CurrentHumidity tag work. Temperature is working just fine, as well as Thermostat. This is my items:

Group g_lille_bad_TSTAT 		"Lille Bad Thermostat" 																[ "Thermostat" ]
Number lille_bad_Temperature 		"Lille Bad Temperatur [%.1f °C]" 					<cu_heating> 	(g_lille_bad_TSTAT,Temperatur,gTvaer) 			[ "CurrentTemperature" ] 	{ihc="9191188"}
Number lille_bad_Tempsetpunkt 		"Lille Bad Temperature setpunkt [%.1f °C]" 				<temperature> 	(g_lille_bad_TSTAT)					[ "TargetTemperature" ]		{ihc="9194772"}
Number lille_bad_fugt 			"Lille Bad Fugtighed [%.0f %%]" 					<Humidity> 	(g_lille_bad_TSTAT,Fugtighed,gHumidityBathRoom) 	[ "CurrentHumidity" ] 		{ihc="13702695"}
Switch telestat11_lil_bad 		"Lille Bad Telestat [%s]" 						<cu_switch> 	(g_lille_bad_TSTAT,gTelestat) 								{ihc="6516315"}

After syncronising there is no Humidity appearing.

Maybe a stupid question but if I would run my own personal version of the openhab cloud service can I link that to google home/assistant and how would that work.

If I recall well the activation of openhab in google home was picking it from a long list of services and entering credentials but I don’t recall the option to enter a myopenhab url anywhere.

Has anyone actually got the CurrentHumidity tag to work?

Yes, when I ask Google Assistant what the humidity in my living or any other room is I get an appropriate answer. As far as I know humidity isn’t shown anywhere on the thermostat graphic in Google Home if that is what you’re after.

2 Likes

Indeed it was :wink: I never thought of asking Google, when I couldn´t see the Humidity icon/something… I simply assumed it wasn´t working. I wonder why there isn´t a humidity icon. Well, I also wondered why Hudimity had to be part of the Thermostat group.
I´ll give it a try (ask) later… Thanks for letting me know.

I guess what I was thinking about was someting similar to the manual setup described here

It would remove the dependency on the myopenhab.org being up

Google Assistant stopped working for me I believe two days ago (Nov. 12). I’ve restarted the server a few times, and the openhab log shows no errors and indicates the cloud service is connecting fine. All openhab functions operate normally using the UI (and the event log/device status on myopenhab.org are updated appropriately using the UI). But when using Google Home, it responds with “sorry, I can’t reach openhab right now”.

It’s been working fine since the release of the integration, and I’ve made no openhab configuration changes for months. Any ideas? Thanks.

1 Like

I have the same problem since monday evening.
myopenhab.org shows “online” but I can’t open the sidemap over Remote-Url in Openhab and Openhab Beta Android-App or over the home.myopenhab.org Website. Google Assistant don’t work or switchs one of 5 lamps in a room.
In Lokal Network the Apps and Website works fine.

Is it only a Server Problem or can I do something on my Openhabian Installation?

Thanks

Hi all,

I have dimmer and switch items and used [ “Lighting” ] for them and was able to say e.g. “turn lights off” and all the lighting items were switched off. Yesterday I changed my settings so that the switch items are [ “Switchable” ] and lights connected to plugs are [ “Outlet” ]. Problem is that saying “turn lights off” now only turns off the remaining [ “Lighting” ] items, not the switch or outlet :roll_eyes:

I found on Reddit that you can actually rename the items tagged with “switchable” or “outlet” to something like “Kitchen Light” (“Lumière cuisine” in French in my case) in Goggle Assistant and it will now also consider this outlet or switch as a lighting.

I don’t know if this has already been posted here but I just found that super cool :blush:

1 Like

Hello, I m also having a connection issue since 2-3 days between google home and myopenhab ;
Symptom : google home is saying that it can’t contact openhab when I ask for an openhab action
Tests done :
Access myopenhab OK
Restart Openhab OK
Ask google home to synchronize --> google home is saying that it can’t contact openhab
Dissociate Openhab from google home
Reassociate Openhab --> log to myopenhab --> click in allow --> error message : impossible to update the parameter, verify your connexion.

Do you have some idea about this issue ?

Maybe? related to:

  1. [SOLVED] Remote Access is slow
  2. [Solved] Is home.myopenhab.org down? - #26 by Dim
  3. [SOLVED] Long delay in rest command to myopenhab
1 Like

Just to let you know… It´s working like a charme! Again, thanks alot… I would never have figured this myself.

1 Like