Official Google Assistant Integration for openHAB

Just looked up the code and percentage indeed only supports min and max and no custom on/off.
If you create a feature request on the eclipse smarthome git repository, I will tackle that.

Another problem I have is that Google Home Assistant often provides me with the response that it’s unable to sync devices from OpenHAB.
On the other hand, when I issue a voice command of an existing item, it works. It’s just unable to recognise new ones (even though they are listed in myopenhab, so the eposure is OK)

1 Like

It is the direction GA to openHAB. We dont report state back, so this might cause your situation. There is now a reportState functionality at Google, but on OH side we dont use it. Google wont know about any state change currently if the state of your item will be changed in any other way.

BR Mehmet

Why not??

Also, do you know if/when we can use Group type items?

Hi @MARZIMA, is this planned for a next release?
It would be really useful, since not everything is controlled ‘only’ bij Google Home Assistant.
As a fact, to me this is only a secondary option. A nice-to-have. But primaraly my lights are controlled via hardware.


Dear Google Assistant experts,

I need a short hint how do decide between items I want to expose to Google Home and those I only need on my OH server.

Could you please quickly check All items with tag are exposed to Google Assistant and Amazon Echo? and give an advice? Thank you!

Edit: Resolved in that discussion - thanks!

Lock/unlock actions

Is there any plan to implement lock/unlock actions to the skill?

I want to say “Ok Google Unlock Frontdoor”


The same goes for open/close.

That would require Google to integrate that into their API, which currently is not the case.
Until then, you can use something like “Turn on front door lock”. With a proxy device called “front door lock” and the appropriate rules to forward the right commands to the door lock item.

How can Nuki have Okay Google, lock the door?


Is there any way that i can use my google home as a bridge to control device with my openhab?

For example, i have a device that is not supported by openhab but can be controlled by google home and i want to control it via a button in habpanel or add it in a rule. Is that possible?

thanks for you work by the way


Yes. I will be publishing a how-to on that.

Hello, tried setting up a thermostat in home assistant. I can see the theremostat and open it in google home app, but it doesnt show the current temperature and i cant set the targettemperature or the mode. neigther can i see the current humidity.

Group  GF_Hallway_Thermostat            "Thermostaat gang"                                                                     [ "Thermostat" ]
Number GF_Hallway_HeatingMode           "Verwarmingsmode gang [%s]" (GF_Hallway_Thermostat)         [ "homekit:HeatingCoolingMode" ] 
Number GF_Hallway_Temp_Meas_BedroomDoor "Gemeten temperatuur gang [%.1f °C]"  <temperature>        (GF_Hallway_Temp_Meas, gTemp_Meas, ID125, GF_Hallway_Thermostat)      [ "CurrentTemperature" ]      
Number GF_Hallway_Temp_Target           "Gewenste temperatuur gang [%.1f °C]" <temperature>       (GF_Hallway, gTemp_Target, gHallway_Temp_Chart, GF_Hallway_Thermostat)      ["TargetTemperature"]
Number GF_Hallway_Hum_BedroomDoor       "Luchtvochtigheid gang [%.1f %%]"     <humidity>          (GF_Hallway_Hum, ID125, GF_Hallway_Thermostat)      [ "CurrentHumidity" ]

Does anyone see something wrong with my items? I really cant semm to find a problem.

Lighting tags work great for me.

First trying the easy things: Add spaces between the brackets and the quotation marks:

[ "TargetTemperature" ]

First trying the easy things: Add spaces between the brackets and the quotation marks:

Hello, thanks for the suggestion. I made shure i have spaces between the brackets and quotation marks for all the tags now but the problem persists :slightly_frowning_face:

Also after you synced your devices? “Ok Google, sync my devices”, or looking at your Item labels “OK Google, synchroniseer mijn apparaten”.

If it still persists. I am not sure if having the humidity and heating mode in the same group messes up things, you might try removing them from the GF_Hallway_Thermostat group. (And again sync)

Hello! When is it planned to add support in Russia? Voice control does not work.

Hi, yes i synced the devices (in English and in dutch :yum:)

I am not sure if having the humidity and heating mode in the same group messes up things, you might try removing them from the GF_Hallway_Thermostat group

Do you mean remove the current humidity, remove heatingmode or remove both from the thermostat group?

I removed only the humidity from the group, synced, but no change. The allso removed heatingmode from group, synced, but still no change.

I allso noticed the thermostat appeared in google home after adding only “current temperature” tag.

When using only “current temperature” the thermostat widget appears in google home, but no temperature is indicated.

Is it possible the thermostat tag is not propperly supported yet? Is there anyone else on this toppic that has the thermostat functioning properly? If so could you paste your item definitions pls?


Hmm out of idea’s then… My thermostat works fine, I have everything defined via Paper UI though, and added the tags through Karaf.

Ok, thanks for your time anyway. I have everything configured thru files, maybe thats the problem. Or maybe because only current temp and current humid are linked thru chanels to a thing.

I might try linking the others to a generic mqtt thing and see if that makes any difference. Otherwise maybe when i order my new eq3 thermostats in the future.