Official Google Assistant Integration for openHAB


Could be an issue with the items file, if there were any adjustments. Check your items file first for “errors” (the “quotes” being that they’re not OpenHAB errors, but Google Home Integration errors). Be sure tags are spelled properly and that you only have Lighting and Switchable tags (no Thremostat, etc.)

If you want to troubleshoot more on your own, comment all items with tags and start with one.

Hi Ryan,

Thanks - it’s embarrassing, but when I reverted the change, I was able to re-link! (That’s engineering 101 - why I didn’t do that before I don’t know…)

I had checked for errors in the Openhab logs, but as you pointed out, there must be an issue in the change that Google Home integration didn’t like. I’ll investigate that now… At least all my other devices are back in operation.


I am going to deploy tonight some PRs and fixes.
This would bring initial Thermostat support and hopefully solves the tagging issue.
Sorry for the delay, but it needed some testing and I also been quite busy.

Will give you an update here soon.

BR Mehmet


Thank you abi!

Did these fixes get deployed as expected? I’m still unable to link my account (which I presume is due to the tagging issue)

1 Like

I’m wondering the same, maybe we are too eager to try this out :). I am able to re-link (or resync) with the [“Thermostat”] tag in place, but it doesn’t show up in the devices list in Google Assistant. Enabling a [“CurrentTemperature”] tag throws the error you mention. At least that tag appears not to have been enabled yet and according to the outstanding PR on GitHub about the tagging issue the sync error will still be present for unrecognised tags.

@DutchTaurus, @danielwalters86

The updates were just applied to the dev version on Github, so if you have this deployment you do a pull to your Cloud Function. However, I think they need to be further tested before it goes to Google (which I am sure will test it even more!)

Keep in mind there are some guidelines when adding a Thermostat item - using the homekit tags:

Here is an example from my item file:

Group g_HK_Basement_TSTAT "Basement Thermostat" [ "Thermostat", "Fahrenheit" ]
Number HK_Basement_Mode "Basement Heating/Cooling Mode" (g_HK_Basement_TSTAT) [ "homekit:HeatingCoolingMode" ]
Number HK_Basement_Temp	"Basement Temperature" (g_HK_Basement_TSTAT) [ "CurrentTemperature" ]
Number HK_Basement_Setpoint "Basement Setpoint" (g_HK_Basement_TSTAT) [ "TargetTemperature" ]

The phrase used was “deployed” not “merged” so I’d have expected that to mean it was about to go live. However looking at the repo, it indeed does not appear the linking issue has been merged yet even though you have provided a PR. IMO I think the priority should be fixing fundamental issues (such as linking) rather than implementing new functionality (query), but for now I will wait eagerly until I can use the integration :slight_smile:

1 Like


please keep in mind that there are some processes to be fullfilled if it comes to a deployment. There are some tests ongoing and I am checking the for a fix for the tagging issue. Please be patient, since that deployments of a productive version needs Google QA.

As I wrote I will keep you updated. But please lets not ignore these facts.

First step is to merge. Than further tests and a deployment. Then Google will accept the new revision if all went fine.

BR Mehmet


Iam not sure if this makes sense.
Not everybody has an issue with tags…and as written I am on this too. So again, there are several things that need careful testing…lets not make quick shots. Step by step.

1 Like

@MARZIMA I agree not everyone has issues with the tags, but there is definitely merit to the fact everyone told to limit their tags to “Lighting” and “Switchable” has resolved their linking issues - doesn’t prove anything, but just as a temporary workaround, it has been consistent.

Just for understanding as a non-developer:
I don’t have to do all the hassle with gactions, creating storage buckets and deploying in google cloud for simple usage of this integration, right?
There should be an open hab integration for “all users” available in my google home app?

That’s correct - you will still need to set up your myopenhab cloud if you don’t have that done already, but once you have that it’s just a matter of linking it to your Google Home app.


@MARZIMA, Nice work. I just want to know if anyone is using “routines” from assistant. Every time I try, I get the response that “I can´t reach X many lights”, I think maybe is because openhab receives too many requests in a short period. Some times I get 2 lights to change, but still get the can´t reach message. Other than that controlling the house with voice, work great. Thanks

I experience the same.

If you simply want to use the Google Assistant with the productive version of the binding and the myopenhab server, you only need to install the binding and connect your Google Home App.

All the mentioned stuf is only necessary if you want to use a development version or set up you own cloud server for openHAB.


Hi all,

small update: There is a new metadata concept in ESH now available in early stage.
I will try to directly use this, to make the Tagging experience as easy as possible. We target and need a common convention among Alexa, Google Assistant etc. I hope we can achieve this and it will directly fix the tagging problem. If this wont help, I am going to rollout a quick fix.

I will give you updates asap. I am already on it and hope that we can quickly test a prod deployment.

BR Mehmet


(Also tagging @Daniel_Linder)

I use routines to simply turn on a scene proxy switch in openhab. The rule that fires sets all my items directly. This avoids any issues Google has with my Hue bulbs or sending too many requests through myopenhab cloud.

Take a look at my How-to use scenes with google home post to get an idea.

1 Like

Hi Bartus, I use the same method as you with the proxy switch to trigger multiple events via OH from within Google Assistant routines. The action does get triggered, but GA doesn’t seem to be happy with the response from OH as it reports “I’m unable to reach -insert name of proxy switch here- right now, please try again”. You are not experiencing the same result?

I have had issues with it (GA) when hitting Hue bulbs, but not with my scenes/proxy switches. I account that to Google Home acting up and just try again :slight_smile: