OH 2.2 Z-Way sitemap freezes after an hour

Good morning everybody,

I’m experiencing some problems since I updated OpenHAB from 2.0 to 2.2.
Everything seems to be fine in the beginning, then the reaction times for my Z-Way items get slower and until it doesn’t react any more. First, I thought there were some issues with the Chromecast and/or the TR064 bindings and uninstalled them both. Now only Z-Way remains and the issue still occurs.
After a reboot everything works fine for around an hour and then the same story again.
I also checked the logs and set them to debug but don’t see any obvious issues other then there are delays:

Timeout of 30000ms exceeded while calling
’ThingHandler.handleUpdate()’ on 'org.openhab.binding.zway.handler.ZWayZWaveDeviceHandler@1839108’
The task was still queued.

Would be great if you had some ideas what could cause this issue.


Do you need the Zway intermediate controller or can you install the z-wave
binding and directly control your z-wave devices?


I have installed openHAB in December and started using Z-Way. I have noticed that CPU usage was huge (over 100%) and after a few hours system started to block, additionally there were errors with parsing JSONs from Z-Way API.

After a few days of testing I gave up and switched to Z-Wave binding - works like miracle and CPU is up to 3%.

Piotr “Rook”

Thanks for your answers!
@e-rook The binding with ZWay indeed took over my CPU completely. Strange enough since it worked without any issues on the older OpenHab versions.
@robjkamp Actually I went to ZWay because none of my devices is recognized or only partialy initialized (though most of them are in the database, e.g. Danfoss LC 13)). I had similar issues with ZWay but by using the reinterrogation function I was able to include them bit by bit and they worked perfectly. I tried it again to switch to Z-Wave binding today and I had the same issues…

I experienced the same behavior on my Raspi 3. After few hours ntp, Z-Way status exchange, influx feeding stopped updating in openhab. Z-Wave was running stable without issues. After a reboot openhab was ok till it overloaded again. It took me two weeks of hard work to find log entries or the root cause. I updated to the last snap shot version with no success. Now I set up a new SD card with openhab 2.1 and everything is running as years before.

@marker Thanks for your answer. That actually worked for me.
For documentation purposes here’s what I did: First I tried to get the Z-Wave binding running (RPi3 + Razperry GPIO board) in OpenHab 2.2 supported by all the threads in this forum. Unfortunately, still this was very instable: either the board would be “OFFLINE” or only briefly online. Once I managed to keep it online (not reproducable though) but then non of my nodes was initialized properly (see the other post).
Then I downgraded to 2.1 and tried the same without any luck. After I switched back to Z-Way on 2.1 everything works smooth again.
The only thing I didn’t try and might do so later is to erase the Z-Way server completely or use a new image without it and see if the Z-Wave binding works then.